Sensors Not Working And Lag On S4Support


Last Updated:

  1. jackabutlers

    jackabutlers New Member

    The sensors on my S4 (GT-i9505) are currently not working. There is also a lag, sometimes up to 10s, from pressing the home button till the unlock screen shows. The sensors are recognized on cpu-z but are not shown as working. I have factory reset the phone several times and occasionally they work for 5-10 minutes before stopping again so I'm guessing this is a software fault not a hardware fault?

    I have read on another thread about someone having similar problems and that it was a warrenty case. However I had to replace the screen on mine 3 months back myself as the digitizer broke in my pocket (I'm guessing from bending) and now my warranty is void.

    I have tried flashing the same UK firmware with odin and also tried a German version... still no luck :(

    Does anyone have any ideas as I'm stuck? Any help or recommendations would be greatly appreciated.

    Thanks in advance! Jack

    Advertisement
  2. SebaKL

    SebaKL Well-Known Member

    I have nothing helpful to contribute, sorry Jack.

    But I like to let you know, that what you described above, is very common to people who fix their own screens. It's either sensor problem or touchscreen response and misfiring.
    The display (digitizer) and front glass are fused, with a layer of optical adhesive. I suppose self repair is never as good as factory bound. Which result in such problems down the line.
    If factory reset didn't fix it, I don't think there is much you can do, on the software end. I suspect it's a hardware. I had similar problems with other phones. Home buttons, sensors etc.. they would work fine for a while after a reset, but would quickly go back to normal as I would use them. Hence why I rather buy costly parts and get service to fix it for me, than play around myself, and possibly cause more problems.

    Try to test the sensors, by opening the dial pad and keying in *#0*#
    How do they respond while testing ?
    jackabutlers likes this.
  3. jackabutlers

    jackabutlers New Member

    When I replaced the screen myself I replaced the whole front bezel as I didn't trust myself to stick the digitizer on myself. Do you think it would be worth opening up again to check everything is fully connected? Seems odd it would only start to occur about 3 months after I did the replacement?

    Thanks for the quick response!
  4. jackabutlers

    jackabutlers New Member

    Have done this several times it shows FAIL as expected :(
    When I do reset it shows PASS in the 10 mins before they fail again.

    Thanks

Share This Page