Sent my only launcher to SD card


  1. buckeye3175

    buckeye3175 Member

    The phone is a android Optimus V Model number VM670. I rooted the phone 2 days ago with GingerBreak. I deleted my default launcher and moved Go launcher ex to the Sd card. I figured it would be completely fine since it was still connected to the phone. I was wrong and now it boots to a black screen with just the notification bar. I also have no internet connection so i cant push a installation through the google store. I have read other forums about this happening and the answers didn't help with my phone. Does anyone know how to fix this on my phone?

    Advertisement
  2. Hadron

    Hadron Well-Known Member Contributor

    Hi buckeye3175, and welcome to AF,

    Did you take a nandroid backup (a backup made from a custom recovery) before modifying the system? If so it's easy - boot into recovery and restore that backup. Otherwise, well it's a bit late now but you should always do this before modifying the system precisely in case something like this happens.

    Assuming you don't have a nand backup, do you have a custom recovery at all (or did you just root the ROM)? If so you should be able to flash a new ROM from recovery, which will fix this.

    If not, was usb debugging enabled? If it was, you may be able to push a launcher apk to the phone and install it using adb (I'd have to look up the commands).

    Failing all of that, you should be able to install a set of stock firmware (which will unroot the phone). However, I don't know LGs at all, so can't advise on this.

    The best bet would be to ask people familiar with this phone, so I'll move this thread to the Optimus V All Things Root forum.
  3. buckeye3175

    buckeye3175 Member

    Before all of this happened i had debugging on.. I also had the wifi enabled on the phone.. But i did a factory reset and i am guessing that disabled wifi and debugging. When i go to android system recovery screen. The 4 options are reboot system now, Apply sd card:update.zip, Wipe data/factory reset and wipe cache partition. How do you push a launcher APK to the phone and install it using adb? I have looked it up and i cant get directions on how to do it? If i can find stock firmware for my phone. How would i install it to my phone without a Mobile internet connection??
  4. Hadron

    Hadron Well-Known Member Contributor

    Can't advise on stock firmware flashing. Tools are vendor-specific, and I don't know LG. Someone here should know. See if the All Things Root Guide sticky post says anything about this (may be under the heading of unrooting). You really want advice from someone who knows the phone though, to make sure you don't make things worse.

    Doesn't sound like you have a custom recovery, which probably means adb is out. On the phones I do know it won't work from stock recovery, and you are right that a factory reset will turn it off.
    buckeye3175 likes this.
  5. Earthnfire78

    Earthnfire78 Well-Known Member

    Your best bet is to install the the VM update and then re-root the phone again. Download it from here and place it on the root of the sdcard, meaning not in any directory. Boot into recovery and chose option "Apply sd card:update.zip" it should auto reboot when done.

    Read this if you plan on going back to root. But I would read up on the does and don't of root before rooting again.
    Hadron and buckeye3175 like this.
  6. buckeye3175

    buckeye3175 Member

    Thanks for the reply. How would i place it to the root of the sd card?
  7. Hadron

    Hadron Well-Known Member Contributor

    Use a card reader if you can't do it from the phone.
  8. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    Take the micro SD card out of the phone and put it into the SD card adapter that came with the phone. If you have a newer laptop it should have a slot for a standard SD card. If your computer doesn't have a standard SD card slot, then you will definitely need a card reader (ten to twelve bucks at Wally World).
    Note: Make sure the little sliding tab on the left side of the SD card adapter is pushed all the way up.
    buckeye3175 likes this.
  9. buckeye3175

    buckeye3175 Member

    Ok i got the card reader and adapter. do i got to extract the files that came with the update before i can put them on the card?
  10. Earthnfire78

    Earthnfire78 Well-Known Member

    No, keep the update.zip compressed, un compressing it well mess up the signature and the stock recovery will not flash it.
  11. buckeye3175

    buckeye3175 Member

    I got a sandisk adapter and i have a targus card reader. I plugged the card reader into the computer with my sd card and it says "there is no disk in removable disk E". An now when I plug it in it shows nothing is plugged in when i go to devices under control panel of my pc..... I am confused now
  12. Earthnfire78

    Earthnfire78 Well-Known Member

    When you plugged in the card reader did Windows bring up a Installing Device Drivers?
  13. buckeye3175

    buckeye3175 Member

    No nothing pops up.I went to update driver and it said it was up to date. I also got a card slot on my Laptop but when i plug the adapter in it does nothing.. I am also running windows 7 if that may be a problem..
  14. Phatninja55

    Phatninja55 Well-Known Member

    Before flashing the update.zip, I belive that after a factory reset the phone should still be in debug mode, I would download adb and try adb devices.
    You have to have a usb cable for this...
    Follow this guide: How to Set Up ADB on Windows 7 for Android PhonesJaxov
    After you get done setting it up in command prompt type
    adb devices
    if there is something that looks like
    A000000000 Device
    then your phone is still has debug on.
    Then download a launcher apk from some 3rd party place, and then go back to command prompt and do:
    adb install <location of apk> For example C:/users/phatninja55/desktop/launcher.apk

    Hope this will solve your problem. - Phatninja55
  15. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    There's a little tab on the side of the adapter. Make sure it's pushed fully forward/up. If not it might give the error you see, and or say it's right protected.
  16. buckeye3175

    buckeye3175 Member

    This one doesnt have the lock on it. Im guessing maybe it is not getting full contact. Or maybe there is something wrong with the sd card..
  17. Phatninja55

    Phatninja55 Well-Known Member

    What I said should work, When my mother broke her screen on her V, I rebooted into recovery and did a factory reset to clear the phone of her stuff before I got rid of it.
    Then I rebooted it, and debugging was on, she never turned it on tho.
    So try my suggestion.
  18. buckeye3175

    buckeye3175 Member

    i am trying your idea and i did everything that that link you gave me said. I went to the command line and it wont let me type anything.. I went to devices under control panel and clicked on "LGE android platform composite usb device".. Under device status it says:"Windows cannot load the device driver for this hardware The driver may be corrupted or missing". (Code 39)
  19. Phatninja55

    Phatninja55 Well-Known Member

    Command prompt wont let you type anything?
    Also in the all things root guide, towards the bottom is a link to the optimus v drivers.
Loading...

Share This Page