Serial Number Registration IssuesSupport


Last Updated:

  1. Country_Gravy

    Country_Gravy Well-Known Member This Topic's Starter

    Joined:
    Nov 16, 2010
    Messages:
    52
    Likes Received:
    8
    Is anyone else having trouble registering the phone with Samsung? It won't take my serial number and the customer service rep that I called was no help.
     

    Advertisement
  2. LaTuFu

    LaTuFu Well-Known Member Contributor

    Joined:
    Nov 10, 2009
    Messages:
    1,286
    Likes Received:
    254
    Yeah, my guess is they have not set up the "Premium" site for Mesmerize users yet. I've had the phone since 10/28, the site usually doesn't come up for me on my mobile. If I try to register from a PC I get the same "SN not valid" error.
     
  3. USCellularAndroid

    USCellularAndroid Well-Known Member

    Joined:
    Oct 19, 2010
    Messages:
    84
    Likes Received:
    26
    yes I had the same issue. I had to call Samsung and the women finally figured it out. She gave me a totally different Code to type in.

    Once I dealt with Samsung, I can now see my device is registered. I guess just keep calling until you get an informed customer service Representative.

    I think the issue is with the whole Fascinate/Mesmerize same phone yet different carrier deal.
     
  4. Special_opps

    Special_opps Member

    Joined:
    Nov 1, 2010
    Messages:
    17
    Likes Received:
    10
    Menu/settings/about phone/status. It is the hex number under meid. Begins with A..... Forget the Ox which preceeds the A....
    I got no where with their online support, figured it out myself. Hope this helps!
     
    Vader01, wooderd, Tonitz and 6 others like this.
  5. LaTuFu

    LaTuFu Well-Known Member Contributor

    Joined:
    Nov 10, 2009
    Messages:
    1,286
    Likes Received:
    254
    Thanks for that. I was entering the code off the battery box, like I've done with phones in the past. As well as the number "behind the battery" as the site indicated.
     
  6. ladybadger2007

    ladybadger2007 Well-Known Member

    Joined:
    Oct 26, 2009
    Messages:
    186
    Likes Received:
    3
    Thank you so much I needed to register the Mesmerize as well as the Samsung Galaxy S Tab that I got. I've tried everything. I am now registered. Phandroid never lets me down I love this forum.
     
  7. rich.sandy

    rich.sandy Active Member

    Joined:
    Nov 28, 2010
    Messages:
    34
    Likes Received:
    0
    I just tryed the Hex # with out the 0X, and it didn't work. what now?
     
  8. Jessster

    Jessster New Member

    Joined:
    Dec 23, 2010
    Messages:
    1
    Likes Received:
    0
    You have to use capital letters in the hex code.
     
  9. rich.sandy

    rich.sandy Active Member

    Joined:
    Nov 28, 2010
    Messages:
    34
    Likes Received:
    0
    yes
     
  10. Shimmy_69

    Shimmy_69 Member

    Joined:
    Dec 28, 2010
    Messages:
    12
    Likes Received:
    0
    Mine would only work when I entered the 0X
     
  11. Rusticus

    Rusticus Member

    Joined:
    Nov 24, 2010
    Messages:
    19
    Likes Received:
    5
    Thanks, that worked,
     

Share This Page

Loading...