Root SetCPU 2.0.2 works with Froyo!

Discussion in 'Android Devices' started by crazydog, Aug 2, 2010.

  1. crazydog

    crazydog Well-Known Member
    43

    May 20, 2010
    240
    46
    43
    Student / Systems Analysis Assistant
    Flagstaff, AZ
    SetCPU didn't work for me until today's update, so disregard this if it worked for everyone else! :p

    Anyway, after updating SetCPU today, I can disable my Perflock, and SetCPU works just fine with the stock kernels on the leaked Froyo ROM. Enjoy!
     

    Advertisement
    yojoe600 likes this.
  2. yojoe600

    yojoe600 Well-Known Member
    143

    Apr 14, 2010
    2,188
    207
    143
    College Student
    NC
    thanks ive been waiting for this
     
  3. xkingofgodzx

    xkingofgodzx Well-Known Member
    38

    May 15, 2010
    342
    23
    38
    New York
    Will this OC with the 2.2 kernel? or does this allow you to set the cpu clock manually?
     
  4. Muerte_X

    Muerte_X Well-Known Member
    18

    May 2, 2010
    60
    11
    18
    It only lets you adjust settings within the stock range. You won't be able to overclock until the source code is released and someone makes an overclock kernel.


    Thanks for heads up, installing now...
     
  5. frishmans92

    frishmans92 Active Member
    15

    Nov 10, 2009
    44
    0
    15
    But you know what this means! Underclocked "screen off" settings. :) better battery life, ftw!
     
  6. welbinator

    welbinator Well-Known Member
    68

    Jul 1, 2010
    581
    44
    68
    www.hydrakernel.net/overclocked_kernels.htm

    i'm running CyanogenMod6 test8 so I started with the third link and i am currently clocked at 1.13GHz. it's runnin great! I can't speak of any other ROMS, i've only used this kernel with the CM6 test8. =]

    Guidelines from hydrakernel.net regarding the kernels:

    1. Try the 1st link (in overclock section) FIRST, only if you have stability issues (bootloop/lockup/reboots) should you then move on to the 2nd link with the slight overvolt at the 1.15ghz slot. If the 2nd link fails for you then move on to the 3rd link, this is a 1.113ghz kernel with stock 1ghz speeds. If the 3rd link fails for you move on to the 4th link, this is a 1.113ghz kernel with a 25mv overvolt at only this speed. If by some slim chance NONE of these work for you, stick with the stock speed undervolt kernel.

    2. If you are using CM6 you should start with the 3rd link instead of the 1st link as the first 2 kernels are unstable with CM6.

    3. I recommend not using the setcpu controls or governor with these kernels. Let the stock governor do the work. If you have setcpu installed I recommend clearing out the settings before flashing the kernels. You can use it to monitor cpu speeds or an app from the market called systempanel if so desired.
     
  7. Hand76

    Hand76 Guest

    So if I want to set up a profile for when the screen is off to save on battery life what setting/speeds should I use?
     
  8. BreakTheStatic

    BreakTheStatic Active Member
    18

    Mar 25, 2010
    30
    15
    18
    These kernels are not for 2.2... They are using the older kernel and not .32, so you will lose some functionality (camera for sure, maybe a few other items)
     
  9. welbinator

    welbinator Well-Known Member
    68

    Jul 1, 2010
    581
    44
    68
    aw dang I didn't realize that. I hadn't tried to use the camera with the hydra kernel until you mentioned it. shoot. I guess I'll go back to the old kernel.

    are there any good .32 kernels out there that will work with my CM6?


    go to the profiles tab in SetCPU, select enable profiles. then select add profile. in the Condition menu, select screen off. drag the max and min down as low as it will go. under priority, make this one 100% (high) that way no matter what other profiles you set up, when the screen is off this one will take priority. you can use this to set up certain speeds based on battery life too, that way when your batter is close to dying you can lower the CPU speed and try to make the batter last a bit longer.
     
  10. yojoe600

    yojoe600 Well-Known Member
    143

    Apr 14, 2010
    2,188
    207
    143
    College Student
    NC
    mines 245min 384max with no problems for sleeping and saves battery
     
  11. Hand76

    Hand76 Guest

    Guys I still don't think it works right. I do the perflock disabler and all is fine until I restart the phone than it stops working until I do the perflock disabler again.

    This is the way it has always been for me, even since 2.1
     
  12. crazydog

    crazydog Well-Known Member
    43

    May 20, 2010
    240
    46
    43
    Student / Systems Analysis Assistant
    Flagstaff, AZ
    That's how it's supposed to work. You have to disable perflock every time you reboot the phone, because there is a chance the phone could crash. If you have it set to disable the perflock automatically, and the phone crashes, you'd be stuck in an endless reboot cycle.
     
  13. Hand76

    Hand76 Guest

    But this is the way it has always been for me. This worked with the perflock disabler (and stock kernals) since 2.1

    I just thought something had changed.
     
  14. crazydog

    crazydog Well-Known Member
    43

    May 20, 2010
    240
    46
    43
    Student / Systems Analysis Assistant
    Flagstaff, AZ
    What changed was that on the version of Froyo I was running (the nonmodified leaked ROM version), SetCPU didn't let me disable my perflock until yesterday.
     
  15. Hand76

    Hand76 Guest

    Oh gotcha.... ;) Ok we are on the same page now.
     

Share This Page

Loading...