Setting domain mail as default "From"


Last Updated:

  1. droidjunkie

    droidjunkie Member This Topic's Starter

    Joined:
    Dec 6, 2009
    Messages:
    14
    Likes Received:
    0
    I apologize for posting this again as a new thread. Here's the issue. I want to use my domain email address to show in the "From" line for all my emails sent through the gmail SMTP server. I have gone to the gmail settings and have put my domain name in and selected it as default. I have even set my domain email address as the "Reply-to" for the gmail address.

    This works perfectly fine for mail sent from my desktop client, Thunderbird. But, when I send mail through Droid using the gmail setup, when delivered the mail shows my gmail address in the "From" line. This causes confusion among my recipients, who think I have changed my email address.

    Google even says that they will always put the gmail address in the From line, even though they do not do this. My domain ISP does not allow you to use their SMTP server if you are using a forward, so I can't solve the problem that way.

    Is there no way out of this little irritation? Appears to be a glitch in the Google setup. Why allow you to specify another "sent from" address if you are not going to use it?

    Suggestions solicited!!!
     

    Advertisement
  2. jeepguy_1980

    jeepguy_1980 Well-Known Member

    Joined:
    Nov 7, 2009
    Messages:
    111
    Likes Received:
    0
    I use Google to manage my personal domain email address and my ISP provided email address. From my desktop web browser I logged into Gmail and changed my default send mail as account.

    Every email I send from my phone is sent from my personal domain email address and not Gmail.
     
  3. droidjunkie

    droidjunkie Member This Topic's Starter

    Joined:
    Dec 6, 2009
    Messages:
    14
    Likes Received:
    0
    That doesn't seem to work in my case and I cannot for the life of me figure out why. I have done as you suggested ... Gone to Settings -> Accounts and Import and set:

    My Name <mygmaillogin@gmail.com>
    Reply-to address: mylogin@mydomain.com
    make defaultedit info
    My Name <mylogin@mydomain.com>
    defaultedit infodelete
    Send mail from another address




    Learn more
    When receiving a message:
    Reply from the same address the message was sent toAlways reply from default address (currently mylogin@mydomain.com)(Note: You can change the address at the time of your reply. Learn more)

    I have changed the actual names to dummies to hide my actual email addresses, but you see what the settings are.

    What am I missing here, if anything? Just will not set my domain name email in the Droid sent messages, but works just fine for outgoing mail from Thunderbird on the desktop. ?????
     
  4. jeepguy_1980

    jeepguy_1980 Well-Known Member

    Joined:
    Nov 7, 2009
    Messages:
    111
    Likes Received:
    0
    This is how mine is configured:

    [​IMG]
     
  5. droidjunkie

    droidjunkie Member This Topic's Starter

    Joined:
    Dec 6, 2009
    Messages:
    14
    Likes Received:
    0
    Mine looks much the same with one major exception. It looks like you are sending your Droid mail using your domain SMTP server. I cannot do that because GoDaddy, my SMTP server, does not let you use their SMTP server if you have a forward set up. I am using their forwarding on my domain name and sending that mail to gmail.

    Maybe that is where the snafu is.
     
  6. jeepguy_1980

    jeepguy_1980 Well-Known Member

    Joined:
    Nov 7, 2009
    Messages:
    111
    Likes Received:
    0
    My personal domain is on GoDaddy. I have nothing forwarded though.
     
  7. droidjunkie

    droidjunkie Member This Topic's Starter

    Joined:
    Dec 6, 2009
    Messages:
    14
    Likes Received:
    0
    Jeepguy, I have set up an email account on GoDaddy where my email domain name is located. I can now have access to their SMTP server and want to replicate what you have done. Here is what I assume from the screen shot you sent:

    Send mail as: YourGmailLogin@gmail.com
    Reply-to address: YourGoDaddyLogin@YourDomain.net

    can't figure this one out ... some other account somewhere??

    YourGoDaddyLogin@YourDomain.net
    Mail sent through smptout.secureserver.net (GoDaddy SMTP)

    When receiving a message:
    x Reply from the same address the message was sent to

    The Pop3 service seems to be working fine.

    Can you confirm the above settings? Thanks! I still have problems.

    Also, in your Droid, you have your phone outgoing settings to point to the gmail SMTP server, right???
     
  8. jeepguy_1980

    jeepguy_1980 Well-Known Member

    Joined:
    Nov 7, 2009
    Messages:
    111
    Likes Received:
    0
    Actually, I send mail from my default account (Godaddy). However, messages I send from my Gmail account will use my GoDaddy email address as the reply to address. I should probably change this behavior. I never had a Gmail account until I got my phone a few weeks ago.

    I'm not entirely sure what you're asking here.

    In the When receiving a message: section, I do have GMail setup to reply using whichever email address the original email was sent to. This helps keep conversations organized for myself and the other person.

    I do not have such a setting for each individual address listed in my GMail settings.

    The email service on the Droid was not working well for me at all, so I configured GMail to access all of my personal email. In doing so I had to create a GMail address. Once I setup GMail to handle all of my email, I deleted all of my settings in the Droid email app and use the GMail app exclusively.

    When I send an email using the GMail app, it uses my default settings (GoDaddy). Using GMail to handle all of my email produces an instant email notification and handling every bit as good as my Blackberry was.
     
  9. droidjunkie

    droidjunkie Member This Topic's Starter

    Joined:
    Dec 6, 2009
    Messages:
    14
    Likes Received:
    0
    Well, you pointed out one thing that fixed my problem. I had been using the email app on the phone. When I send mail from that app, I have the "From" problem. But, when I used the Gmail app, it worked fine with my GoDaddy domain name in the return!!!!

    Thanks. That fixes my issue. BTW, I have the same setup as you. Funnel all accounts into gmail using POP3 service to read them.
     

Share This Page

Loading...