Severe start-up problems with Xperia Pro - Battery problems ?Support


  1. ChristianHJW

    ChristianHJW Member

    Hi Folks,

    i guess my Xperia Pro is dying on me, it doesn't start anymore. I am actually not quite sure if this thread should really be here, as this may well be a general problem with SONY Xperia's, mods feel free to move it if so.

    Here is what is happening:

    Before, when i shut down the phone and connected it to the charger, a kind of BIOS screen flashed up shortly after that, showing 'SONY Ericsson' and then some simple graphics displaying the loading status of the battery.

    Now, if i shut down the phone normally, these BIOS screens are not there anymore, and subsequently the phone can also not be started. Here is what i have to do get it working again:

    - pull the battery
    - wait for 5 - 10 mins
    - connect the phone to the charger with NO battery inserted
    - wait for the 'SONY Ericsson' screen, then insert the battery quickly

    The phone will then startup normally. The following potential problems were checked:

    - battery is fully loaded
    - SD card removed, to no avail
    - SIM card removed, to no avail

    Phone is rooted, and has a 1 GB EXT3 partition on the SD card as ROM extension (SD Link).

    Strange enough, the phone is also sometimes not correctly recognized on my laptop. If that happens, also SONY's support program for Windows, called 'PC Companion 2.0', is unable to connect to the phone when on USB.

    What could that be ? Is my battery dying on me ? That's highly unlikely, because the phone is only 3 months old and i can run the phone for 3 days without recharging, if necessary (Thanks to root, removing facebook and the like, and the app 'SetXperia').

    On the other side, the missing recognition from my Laptop would most likely indicate a problem with that BIOS being loaded from the ROM, no ? Do ANDROID phones even have something like a BIOS ? If so, is it made by the phone manufacturers ?

    Thank you for helping me out, as i have rooted the phone i can not easily send it to service.

    Regards

    Christian

    ADDENDUM / 0% battery problem related :

    It may so happen that my problem is somehow related to the fuel gauge problem reported in this thread here, but i never experience a 0% loading state ? My batter never goes lower than 30% typically, and the restart problem will also happen if the battery status was showing 98% when i am shutting it down. However, it seems that the guys suffering from this do have a similar problem, i.e. the KERNEL not booting when they try to switch on the phone ?

    Is it possible that some hardware part in the phone checks the status of the battery, detects it as too low and refuses to start-up, even though the battery is actually full ? But then, why doesn't it start with battery inserted when i connect it to the charger ? I first have to pull the battery, then it will start ?

    ADDENDUM 2 / Power Saving App SetXperia messing with CPU clock:

    As mentioned above, i am using the app 'SetXperia' to save battery. In 'default' mode it will constantly vary the CPU clock according to real need, in order to save on battery. Can this app confuse the fuel gauge, and my battery show it is fully loaded, while in reality it is almost down ?

    Advertisement
    :
  2. ChristianHJW

    ChristianHJW Member

    Hi, here an update on the situation:

    It seems as if the problem in fact IS somehow related to the defect fuel gauge, because i could make the following observations:

    - sometimes the batter capacity in Android is displayed to be better than 60%, but if i shut the phone down and connect it to the charger, the battery is shown to be almost empty. This is a clear hint that on the Android level there is wrong information on the actual remaining capacity of the battery, most probably a result from the defect fuel gauge ?

    - the problems are getting worse if i do recharge with Android running, especially when being connected to the USB port, and they are getting less if i recharge the unit using the charger, and shut off.

    However, it is still confusing why the phone can not be restarted even if the battery is more than 50% full. In this case it will sometimes work to start the phone if i simply connect it to the charger (not USB on the Laptop, that hasn't worked for me so far) and wait for a few seconds, but in most cases i do have the use the trick described above, i.e. pulling the battery, connect the charger and insert the battery then.

    I would really appreciate any comment from your side on how to solve that problem. Being a professional sales manager in the machine business myself, i am touring literally the whole world, and i need a working smartphone ! If this problem persists, i will have to switch back to Blackberry (which never let me down).

    Will using an extra strong MUGEN battery pack help here ? They offer one for the Xperia Pro, i guess with almost 2,5 times higher capacity (3400 mAh) ?
  3. ChristianHJW

    ChristianHJW Member

    Update:

    Meanwhile i have sent the phone back for repair, more precisely to AMAZON's service partner for mobile phones in Germany:

    w-support.com GmbH
    the service factory for wireless
    Niederfrohnaer Weg 2
    D-09232 Hartmannsdorf
    Tel.: +49 (0)3722 713-514
    Fax: +49 (0)3722 713-605
    Startseite | w-support.com - Die Profis mit der Lizenz zum L
  4. Sam-SonyXperia

    Sam-SonyXperia Well-Known Member

    There could be a number of things preventing them from running a backup such as a problem with the main board or simply some corrupt data that is causing issues with the backup file. Regardless it sounds like you don't have a lot of options but to go ahead with the repair unfortunately.
  5. ChristianHJW

    ChristianHJW Member

    Last Update: Phone is back from repair, they had to replace the mainboard (free of cost).

    Restoring my data from Google now, this is working better than i had thought.

    Phone working flawlessly again so far, thank God.

    Regards

    ChristianHJW
  6. Josh-SonyXperia

    Josh-SonyXperia Well-Known Member

    Is unfortunate that you had to send the phone to repair but really nice that it is working properly now. Hope you can now enjoy your phone very much :)
  7. ChristianHJW

    ChristianHJW Member

    You bet :) !

    I had to use my old Blackberry for a couple of days now, while the Pro was in repair. That felt like going back from a car to a bicycle :-D !!

    SONY could take a preorder for the next Xperia Pro model from me right now already, i am very much looking forward to a dual core with 12 MP camera and 4 GB RAM, or whatever specs it will have, although i hope it will not be less advanced than the Xperia S.

    However, as i am working with this phone, and not toying around with it, i NEED a keyboard ! So i will continue using my Pro, until the Pro II will come out, or until SAMSUNG or HTC will launch an up-to-date model with keyboard ;-) ...
Loading...

Share This Page