SGS not booting properlySupport


Last Updated:

  1. mudy

    mudy New Member This Topic's Starter

    Joined:
    Aug 7, 2010
    Messages:
    2
    Likes Received:
    0
    Hi guys,

    I am new to android OS trying to get head around with my new mobile phone Galaxy S (second Android after my biggest mistake HTC Dream). It was a great little [big] phone until it started freeezing. like any other handset i thought i might have installed to many apps, hence, i went forth to reset everything through the settings option. now the phone doesn't boot at all. I tried googling around but couldn't find any help. I can see galaxy GT-i9000 and the the rainbow "S" and galaxy S underneath and after that the screen goes blank. I thought restoring through computer or reloading the firmware would fix this issue; and now i discovered that even Kies have issues with drivers installation for this handset. i am not sure what to do. my computer is running windows 7 64 bit. i also tried the hard reset i found in few website: pressing volume down and then pressing power button and blah-blah...... but can't see nothing past the rainbow S screen. any help would be much-much appreciated.

    thanks in advance.
     

    Advertisement
  2. Galaxyforme

    Galaxyforme Member

    Joined:
    Jun 14, 2010
    Messages:
    24
    Likes Received:
    3
    Hi try visiting this site


    Home -


    you need to download ODIN to flash your firmware (available there)
    Along with the firmwares that you will need for your phone, and the correct .pit file (512pit or 513pit file) You do need to use KIES to get the usb drivers, Im running win 7 64 bit and have no issues at all.

    Hope this is of some help
     
  3. mudy

    mudy New Member This Topic's Starter

    Joined:
    Aug 7, 2010
    Messages:
    2
    Likes Received:
    0
    Thanks for the advise! I've already downloaded Odin and the Australian Optus Firmware; but the main problem is my computer won't recognize the device!!!! I've installed Kies latest version - uninstalled it and again reinstalled it hoping that it would get fixed but it didn't do any good!!! Is there any other USB drivers I could try without installing Kies???
     

Share This Page

Loading...