SGS2 LTE USB Storage problem - help!Support


Last Updated:

  1. wittyforumname

    wittyforumname Member This Topic's Starter

    Joined:
    Dec 8, 2011
    Messages:
    6
    Likes Received:
    0
    ** Everything works on a Laptop with XP Pro and a Windows 7 32 bit machine I have, but still no go on my Windows 7 64 Desktop

    Hi all - first post. Got this new device 2 days ago and I'm having an issue connecting properly to my PC (Windows 7 64) I have spent 2 days reading any thread I can find on my problem and cannot get it working - so here I am:

    SGS2 LTE with rogers, Canada
    32 GB SD card installed - shows up under /storage
    Newest version of Kies

    When I connect the phone to my computer via USB: /settings /USB utilities /connect storage to PC (plug phone in via USB) /Connect USB Storage
    1) I get 2 removable drives under /My Computer that I cannot access (please insert disk)
    2) KIES cannot connect with phone (cannot connect to device)
    3) Nothing shows up under Windows /Device manager

    So I try /Settings /Development /USB Debugging (check) /plug in phone /Pull down slider from top and select connect USB
    1) I get 2 removable drives under /My Computer that I cannot access (please insert disk)
    2) KIES CAN connect with my phone, but I CANNOT transfer data (shift right click "transfer to device" does not work. Wireless KIES operation DOES transfer data
    3) Windows device manager shows "Samsung Android ADB Interface" - no yellow triangle

    I have tried PC reboot, phone reboot, un-mounting SD card prior to PC connect, tried connecting without SD installed, tried uninstalling KIES, tried with new version of KIES, different cables, different USB ports.

    I came from an iPhone 3GS and I was excited to try something new and get on the android bandwagon. Open source and free moving data between devices and PC were a major reason I came to this phone - Please Help!

    Thanks All
     

    Advertisement
  2. wittyforumname

    wittyforumname Member This Topic's Starter

    Joined:
    Dec 8, 2011
    Messages:
    6
    Likes Received:
    0
    My word Samsung customer phone support is weak....

    2 different "agents" second being a cell phone "expert" - no help

    After a long explanation of my connection issue I got riveting questions like "Well, what do you want to do with your phone?"
    "How do you want to set this up sir?"

    Set your phone to mass storage was the only actual advice given, lol, so I explained the steps I had taken, again, then I got put on hold... again, and again, and again

    I'm told it's the operating system and I'm SOL, nice


    *Update - so I found something on USB storage (advice for accessing a problem flash drive) about changing the drive letter under disk management in Windows, tried that and I have access to my SD card now through the PC!

    **thought this was a fix but apparently I need to change the drive letter every time I connect the phone, not good.
     
  3. Reggie3

    Reggie3 Well-Known Member

    Joined:
    Jul 20, 2010
    Messages:
    193
    Likes Received:
    15
    This sounds like a setup issue with your pc not the phone
     
  4. wittyforumname

    wittyforumname Member This Topic's Starter

    Joined:
    Dec 8, 2011
    Messages:
    6
    Likes Received:
    0
    Ya, it worked right away on the XP Pro laptop - I have no idea what needs to be done to make it work on the Windows 7 64 though, all my other USB/Firewire/Sata stuff works without issue.

    Typing "Windows 7 64 samsung Galaxy S2 LTE" or "Samsung Galaxy s2 LTE and windows blah blah blah" into google only gets me reviews of the phone and irrelevant stuff. Every other "help" thing is just how to do it, not how to really trouble shoot it if it doesn't work
     
  5. Mr. Ed

    Mr. Ed Well-Known Member

    Joined:
    Jun 27, 2010
    Messages:
    6,675
    Likes Received:
    1,464
  6. wittyforumname

    wittyforumname Member This Topic's Starter

    Joined:
    Dec 8, 2011
    Messages:
    6
    Likes Received:
    0
  7. vice86

    vice86 Well-Known Member

    Joined:
    Jan 17, 2011
    Messages:
    216
    Likes Received:
    22
    I was getting a CRC Serial (?) error when I plugged the phone into my Windows 7 machine...i then read that installing Kies would fix that...i did and i didn't get the error but I don't care to use the software at all. After being stuck with iTunes syncing, i love just dragging and dropping into Android
     
  8. FILIPINOY79

    FILIPINOY79 New Member

    Joined:
    Dec 10, 2009
    Messages:
    2
    Likes Received:
    0
    It seems as the only problem is that something with the 64-Bit Version of Windows 7 cause right now i'm having the same problem. People are saying to install Kies, but I didn't realize that there is a .exe file under the USB drivers folder. After running that, a pop comes out showing that the drivers are being installed. However, when i attempt to connect to the phone i still get the "Please Insert Disk" error.
     
  9. Midiman

    Midiman Well-Known Member

    Joined:
    Jan 1, 2012
    Messages:
    238
    Likes Received:
    36
    Following the directions in the manual worked perfectly for me on 64-bit Win7. No driver installation needed. Windows saw the phone and installed it as a removable device. Two removable devices because I have an external card in the phone.
     
  10. rtg

    rtg Member

    Joined:
    Dec 22, 2011
    Messages:
    24
    Likes Received:
    5
    I am not sure this will help but I have found that on both PCs and MACs if the Skyrocket is not fully charged it draws too much current from the USB port and data will not work. This can be addressed by putting a powered USB bridge between the PC and the Skyrocket.

    FWIW,

    Rob
     
    Midiman likes this.
  11. Midiman

    Midiman Well-Known Member

    Joined:
    Jan 1, 2012
    Messages:
    238
    Likes Received:
    36
    Interesting. I've only plugged this phone into a fairly beefy Dell XPS M1730 for data. I've never had a problem but I've rarely run the battery down. The night before last I actually forgot to plug it in before bed (I usually charge once a day over night) and when I plugged it in last night it STILL had a 70% charge. I've been testing various chargers to see what might be contributing to another charge issue some users, myself included, are experiencing. Standard USB hubs had escaped my attention. I use a couple of old, powered USB 1.0 hubs to power MIDI keyboards and other devices in my studio. I'll start checking some of those along with some 2.0's and the single 3.0 I use on one computer.
     
  12. Mr. Ed

    Mr. Ed Well-Known Member

    Joined:
    Jun 27, 2010
    Messages:
    6,675
    Likes Received:
    1,464
    Very interesting....have not seen this issue with our phones on any of the 8 computers we connect to.

    What app did you use for testing how much current was being drawn.

    I am currious if this issue could also be related to the stuck at 100% issue
     
  13. davidgoerndt66

    davidgoerndt66 Well-Known Member

    Joined:
    Dec 10, 2011
    Messages:
    51
    Likes Received:
    4
    My laptop is an Alienware 17X running Windows 7 64 bit and when I first hooked my phone to the PC to transfer music from iTunes, I got a "driver install failed" warning, however, the connection was made using iSycnr and was able to transfer the files with no problem. I have since tried using Kies and that also worked (at least on my home wifi) to transfer files. I can't use Kies at work to connect for some unknown reason as the connection times out.
     
  14. Midiman

    Midiman Well-Known Member

    Joined:
    Jan 1, 2012
    Messages:
    238
    Likes Received:
    36
    There seem to be issues when trying to connect to multiple computers and some of the issues, from what I have read fairly frequently from other users, seems to revolve around using both cabled USED connections and Kies. I've never used Kies and I've never had a problem making a wired connection to my Dell M1740 (Win7/64), which would have been an Alienware if they had bought the name before they made it. One common suggestion is to reboot the phone before you try to make a connection to a computer that is different from the last one you connected to. The "drivers failed" message is common. I got it myself and did not install any other drivers. The connection works fine regardless and I always see two removable devices (one for the internal and one for the external SD card). My understanding is that installing Kies DOES install some drivers and there may be a conflict between the two.
     
  15. jsandro

    jsandro New Member

    Joined:
    Jan 24, 2011
    Messages:
    1
    Likes Received:
    0
    When I tried connecting my new SGS2 LTE to my PC
    it had the "insert disk" as well but I noticed on the
    notification bar the USB logo and I took a look and
    it said "USB connected, select to copy files to/from
    your computer". When I pressed it a screen popped
    up w/a "connect USB storage" which I pressed and
    then I could access the USB storage for drag & drop.
    Still can't access the 2nd drive which I assume is
    RAM and I wasn't expecting to be able to access
    anyways.

    hth
     
  16. Mr. Ed

    Mr. Ed Well-Known Member

    Joined:
    Jun 27, 2010
    Messages:
    6,675
    Likes Received:
    1,464
    If you have an sd card in the phone you should be able to access both the internal storage and the external sd card.

    you cannot access the space reserved for ram without root and special tools
     

Share This Page

Loading...