Signal loss killing my batterySupport

Last Updated:

  1. sharpgator

    sharpgator Well-Known Member This Topic's Starter

    Apr 18, 2010
    Likes Received:
    I have had the Droid X since launch day and have had no significant problems until last week. My battery suddenly went from lasting about 24 hours to lasting 5-6 hours. Now, I can't even charge my spare battery before the one in my phone dies!

    While troubleshooting this, I went to the battery manager and found that Cell standby was my number one battery consumer. The surprising part is that it also says that my "time without a signal" is 50%. I have perfect reception at my house. I get -70dBm or better on every phone we own.

    I am running Froyo and I have done at least one factory reset since doing the Froyo upgrade.

    I went to the Verizon store yesterday and they agreed to send me a new phone, but I was just wondering if there is something else I can do because I really like my current phone.

  2. BookLover

    BookLover Well-Known Member

    Oct 11, 2010
    Likes Received:
    Only thing to do is to turn off mobile data when you're in a low signal area.

    Are you getting your decibel readings from the phone or from a widget?

    If from phone, you might want to consider installing Mobile Signal Widget, which gives you a more granular view of your signal (e.g., more bars than stock) and also includes a decibel reading.

    When you notice it going low, just turn off mobile data.

    If you were on AT&T, I'd tell you to force the phone to Edge :) No such option with VZW.
  3. binary visions

    binary visions Well-Known Member

    May 14, 2010
    Likes Received:
    The 50% "time without a signal" is a bug. I get the same thing, despite constantly having great signal and superb battery life. If you keep monitoring it, you'll find that you have a perfect 50% time without a signal, all the time, no matter what your usage patterns are. It doesn't seem to correlate with the actual amount of battery consumed by the cell standby.

    At least, that's my experience. If you search Google for the problem, you'll find lots of people saying they have it. The recommendation is to turn Airplane Mode on and off again, which does indeed fix it for me... but I don't find that I'm actually spending half my time without a signal, so I just ignore it now.

Share This Page