Signal problem after motherboard replaceSupport

Last Updated:

  1. amatose

    amatose New Member

    Hi everyone,

    a few months ago I bought a galaxy s4 I9505 and unlocked it via unlock code. I did this immediately on first boot.

    Everything worked since I had a hardware problem in which the blue LED was on all the time. The phone is under warranty so after 3 weeks I got the phone back from service.

    They told me they have changed the motherboard and that everything is working right now. After turning the phone on I had to put in the unlock code again because it said sim locked. This was successful !!!

    Now I have no signal indoors end very poor signal outdoors. I tried factory reset and hard reset a few times but it didnt work. Even under a small roof I have no signal at all and I cant make any calls or texts. I tried different sim cards of other operators but no luck !

    My question is: could it be my fault because I put the unlock code or is hardware related so I should give it back to service (which is frustrating) ?

    Thanks for your help !

  2. lotus49

    lotus49 Well-Known Member

    SIM unlocking is part of the built-in functionality of the phone, not some illicit hack, so using it should not cause any problem.

    Under the circumstances you describe, it's almost certainly a hardware fault.
    amatose likes this.
  3. JimZA

    JimZA New Member

    90% certain that the antenna connector pins are bent... This means that your handsets antenna is effectively capacitively coupled instead of a direct connection.

Share This Page