SIII, AT&T, Tethering, Hardware errorSupport


  1. penright

    penright Member

    First I subscribe to AT&T's tethering plan.

    When tethering, I am using ping "www.google.com" to test. Sometimes I get a response, but most of the time I see "hardware error".

    If I "ipconfig /all" it looks good. I am using XP pro. Under network connections it shows connected/firewalled.

    Any thoughts?

    Advertisement
  2. Stigy

    Stigy Some say... VIP Member

    Does anything work when you ping google.com - sometimes I am not able to ping their servers, but am still able to surf the net.
  3. penright

    penright Member

    Same message "Hardware error."
    I wander what Hardware is in error?
    Again, according to the control panel "network settings" it is showing connected/firewall and when I run "ipconfig /all" I see it listed. Also, if I unplugged the USB while watching the "network settings", the interface goes away. Then re-plugging the interface, I see it appear, then show authentication, then going to connected.
  4. Stigy

    Stigy Some say... VIP Member

  5. penright

    penright Member

    Some of this may be guesses. As I said, sometimes it worked, but most of the time it has not. I have I have tethered and un-tethered 5 times and it has worked every time. New record :)

    Here is what I have learned so far...

    I figured the drivers had to be good or else I could not see the "MTP" and when clicking tethering, I would not have seen "connected/firewalled" on my laptop.
    Again, my OS is XP, not sure if newer OS would have shown different results.
    My clue was the "hardware error". When I thought to myself, sound like a NIC not connected, the light bulb went off or should I say when on :). I had my wireless radio turned off and my wire NIC un-plugged. Even if they were showing "disconnected" could the OS have been still trying to use them? Next I disabled them and boom, tethering started working (could now ping google.com).

    Although this is not part of my questions, I will include it for reference.
    Then I tried to VPN (Cisco client though VPN concentrate). I could connect and get a secure connecting, but when pinging a IP that is on the internal network it would not work. Both Wire and Wireless had a internal address, I changed them to DHCP and the VPN worked. Who would have thought that a disabled interface would still win.

    Anyway so much, I am getting ready to test in the field, if I learn anything else of value, I will post it.

    Thanks all for your help.
  6. burtonvdp

    burtonvdp Well-Known Member

    My suggestion would be to find a windows 7 machine this is up to date on patches (That is how most drivers are delivered) and see if it works. XP and USB aren't really the best combo for newer devices imho. Sounds like you found the problem though (Multiple NICs not playing nice)....

    Another suggestion might be to use the wifi hotspot option instead of USB. I've been using FoxFi (No tether plan) and its been working wonderfully with my N7 tablet.

Share This Page