1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

Silent cameraSupport


Last Updated:

  1. primeprover

    primeprover Member This Topic's Starter

    Joined:
    Feb 11, 2011
    Messages:
    5
    Likes Received:
    0
    Hi, I need to be able to take photos with my GT540 during school silently(my teachers know but still musn't hear). I have searched high and low on the android market for a camera app that will take pictures silently or a program that will mute the default camera program(preferable option) Many claim to do what I need but none seem to succeed in taking a silent photo. Anyone using a free silent camera app for a non-rooted android 2.1 GT540?
     

    Advertisement
  2. dudeman1996

    dudeman1996 Well-Known Member

    Joined:
    Aug 20, 2010
    Messages:
    1,276
    Likes Received:
    264
    Sorry, there's no way to do it.. I had the exact same problem as you, there isn't a way to turn off the camera sound in 2.1. However, if you upgrade to 2.2 or 2.3 (2.3 link 2.2 link) and you put the phone into silent mode, the camera won't make a sound when you take pictures :D
     
  3. lukemovement

    lukemovement Well-Known Member

    Joined:
    Jan 28, 2011
    Messages:
    76
    Likes Received:
    6
    There is one way. Go into terminal and type

    Su

    Find / -name camera

    This will find were your camera file is. Copy it, back it up and use a music edditing software to make the sound silent then replace it. You'll probable have to use root explorer to mount system as R/W to copy it first.

    I said back it up because I haven't tryed this yet.
    *ROOT required*
     
  4. Nirob

    Nirob Well-Known Member

    Joined:
    Sep 13, 2010
    Messages:
    539
    Likes Received:
    167
    There is another way... First you need to be rooted... Then Download & Install Root Explorer(Post #2 here: http://androidforums.com/lg-optimus-gt540/238374-youtube-v2-0-26-android-2-1-a.html)... Open it... Press the "Mount R/W" Button on top... Navigate to "/data/local/tmp/3rd_party/Arcsoft/Camera/"... Now, long press on "camera.conf">select "Open in Text Editor"... Change shutter_sound=1 to shutter_sound=0... Then Save & Exit... Done! No more annoying Shutter Sound.. :D
     

Share This Page

Loading...