Support Silk Browser Constantly Crashes

Discussion in 'Android Devices' started by Holydoc, Nov 26, 2012.

  1. Holydoc

    Holydoc Well-Known Member
    38

    Jun 14, 2010
    241
    21
    38
    Male
    Panhandle, Florida
    While browsing the web, I am getting constant crashes on the SILK browser. I thought this was a tried-and-true browser and did not expect to have this much trouble. I have read several threads on the AMAZON site also discussing problems with the browser.

    If anyone has any thoughts or suggestions for settings that will prevent this constant crashing please share.
     

    Advertisement

  2. alan sh

    alan sh Member
    35

    Feb 16, 2011
    18
    0
    35
    Try Dolphin Browser. While it is not immediately apparent on the Amazon Market site, I did find it once and downloaded it. I have no idea how I got to it as a search doesn't seem to find it, but it is there.

    Alternatively, look for a .apk on the internet and side load it.

    Alan
     
  3. Ih8apple

    Ih8apple Active Member
    16

    Oct 1, 2012
    40
    3
    16
    Silk sucks. Period. Go to 4shared.com and download either Opera or Dolphin browser. You need the APK file.

    Then, use a file explorer (I use ES file explorer, availiable free from the Amazon app store) to open your download folder and run the file.

    Problem solved.
     
  4. Holydoc

    Holydoc Well-Known Member
    38

    Jun 14, 2010
    241
    21
    38
    Male
    Panhandle, Florida
    I did download Dolphin HD as well as Flash. I just wish I could set up Dolphin as the default browser. It appears that Amazon has silk locked down as default and will not let you make that change.

    Just as an update: Since I loaded Dolphin, I have yet to have a crash or non-response on it. Very pleased with it.
     
  5. Jesslynh

    Jesslynh Well-Known Member
    18

    Jul 7, 2011
    71
    12
    18
    You can also try to turn OFF automation in the Silk browser. That may help.
     
  6. Holydoc

    Holydoc Well-Known Member
    38

    Jun 14, 2010
    241
    21
    38
    Male
    Panhandle, Florida
    Thanks for the suggestion, Jess, but I had already tried this as well. I also turned off acceleration and seemed to do no good.
     
  7. PRallday168

    PRallday168 Well-Known Member
    53

    Jul 17, 2012
    283
    62
    53
    Male
    Vet Tech
    Also chrome browser works flawless on this device . If you want to give that a go . Im also trying to figure a way i can make it a primary browser.
     

Share This Page

Loading...