Sim card errorSupport


Last Updated: 2014-09-30 03:54:51
  1. PsychDoc

    PsychDoc Well-Known Member

    I just spoke to HTC and they indicated that it very certainly is a known issue that's currently being worked on. The indicated that the fix will be a pushed software update ate some point in the not too distant future.

    Again, I'd encourage any of you who have concerns about the sim card issue to call and/or write them to express your concern and displeasure. The more contact they have from us, the customer, the more pressure they'll put on their tech staff to resolve the problem. If you're interested, their number is (866) 449-8358.

    Advertisement
    CrackedLCD likes this.
  2. CrackedLCD

    CrackedLCD Well-Known Member

    As long as it's being worked on and an update can be pushed via software, I'm willing to deal with the issue as it stands. A hardware problem affect all the handsets would be a nightmare.

    Judging by the responses, it seems people have this happen in a multitude of situations. So far the only times it's gone out on me I've been at home and on wifi, so I didn't miss any notifications.

    Phone calls are not a big deal for me. I bet with my old phone/carrier, I made less than 30 minutes of calls in the entire two year contract.
  3. MikeC01

    MikeC01 Active Member

    I just bought my DNA this week and I'm pretty sure I experienced this problem twice today. I actually need my phone to be a phone and reliable source this really ticks me off. If the damn thing weren't so awesome idea return it.
  4. rivera02

    rivera02 Well-Known Member

    These types of issues are definitely a drawback to buying a phone that's a carrier exclusive. It would be best that everyone in this forum call or email to report their issue so HTC allocates the appropriate resources to push out a fix in a timely manner
  5. Outlaw.99

    Outlaw.99 Well-Known Member

    Had mine a few days and finally got the error tonight when I hit a low signal area... A reboot didn't fix so I popped out the card and reseated, and it seemed to help... I also used the 4G app to take it off global and use CDMA/LTE only to see if that helps...
  6. sch911

    sch911 Well-Known Member

    Just switched over to my second DNA. I had eight "Sim Card Error" messages, and two "Puk Lock" error messages all on Friday. The VZW CS rep sent me a new phone. Next step will be swap it out for a Note II.
  7. AntimonyER

    AntimonyER AF Addict VIP Member

    I haven't had the issue in a while, since Reseating the card the last time it happened...
  8. CrackedLCD

    CrackedLCD Well-Known Member

    I've been four days now with no SIM errors, so it appears that re-seating it has helped, for now.
  9. Outlaw.99

    Outlaw.99 Well-Known Member

    Did anyone else get their error in a low signal area where it may have tried to switch to global? Just trying to narrow down the scenarios to see what's causing it for so many. Hard to believe its the card seating, since it doesn't move in there and is working for weeks then gives errors... It's in there to tight for that I believe...
  10. CrackedLCD

    CrackedLCD Well-Known Member

    Not for me. It's always done it at home where the LTE signal is showing anywhere from -67 to -73 dBm.
  11. Outlaw.99

    Outlaw.99 Well-Known Member

    Gotcha... Our 4g around here is spotty at best.. The only time I got the error is when I went into a building and had no signal....When I cam back out it went to the Sim error....
  12. NightAngel79

    NightAngel79 Bounty Hunter Administrator Moderator

    Just want to reiterate. Ever since I called tech support and csr changed device Id in system I haven't had a problem. It's been since late November since it happened
  13. Bearcats

    Bearcats Well-Known Member

    Same here, but I got a new SIM at the same time. But I did have the same device id issue as well that my local guy couldn't fix. He had to call a Verizon direct rep.
  14. John58543

    John58543 Well-Known Member

    There was an update put out but I guess it did not address this issue. I've had my DNA four days and already reseated the SIM card once and it keeps happening...guess I'm going by Verizon store tomorrow. :(
  15. John58543

    John58543 Well-Known Member


    Well went by Verizon store today and they stated EVERY DNA they have sold has had the issue and the new SIM card fixes it everytime.....so far so good for me. Hopefully I am in the clear now...
  16. 05evors

    05evors Member

    swapping phones and sims wont fix it.... its a temporary fix till it happens to the newer eqpt.....store reps say it fixes em every time cuz it does that DAY! They have sales quotas to hit they dont wanna aknowledge a problem and have you escalate. Just swap it and get em out of here is the mindset....everyone knows its an issue w design/sotware/network.....it gets worse as phone age it seems. Mines been real bad lately. We just gotta wait.

    Reps either dont know whats really going on and really believe swapping it is gonna fix it, or they know whats going on and hinestly DONT have a true fix for you. It sucks for reps at stores and cal cemters knowing there aint jack S***t they can do to really fix your phone....all they can do is swap you. Re-registering a new esn/sim combo and/or having the new sim that hasnt been heat cycled/voltage applied seems to be working....for a few days or weeks...then it gradually comes back. Ive read all the posts and it makes sense that there is a design/registration flaw going on.

    I say everyone call HTC on that number a few posts back and get to complaining....only way it will get escalated appropriately
  17. 05evors

    05evors Member

    put in airplane mode for 20 sec, turn airplane mode off, wait 1+ minutes fixes it 95% of the time
  18. NightAngel79

    NightAngel79 Bounty Hunter Administrator Moderator

    Yes but that is temporary.

    It is a HUGE pain to pull my phone out and notice that it has been god knows how long since I've had a signal.

    How many with the issue use cases, just out of curiosity
  19. CrackedLCD

    CrackedLCD Well-Known Member

    I haven't had an issue since reseating the SIM card back in December, but I'm also using a case now, too. Smoked Cruzerlite so I can still see the rear notification light. :)
  20. NightAngel79

    NightAngel79 Bounty Hunter Administrator Moderator

    Funniest thing happened to me. I didn't have any problems since calling vzw months ago.

    Then I started using a case, a diztronic. (or however you spell it) all a sudden I get no simple card errors 4 days in a row, once or twice a day.

    Now I'm not blaming the case.... Yet.

    I pulled it out of the case 2 days ago, since then no issues.

    I'm going to go another day or so, then start using the case again and see how it goes.
  21. Bob Cat

    Bob Cat Careful, They're sharp!! Moderator

    I've had mine in a case since day one. Also I've not had the issue as many times that some members here are saying. It just happened to me a couple days ago and I just rebooted it. Verizon know's it's an issue and I would consider changing to a Note 2 only because I use my phone for business but since I've had it since launch day they wouldn't swap it out for a Note 2 and I'm not going to burn up another upgrade so I'll just deal with it.
  22. Bearcats

    Bearcats Well-Known Member

    Mine has been in a case since I have had it. I run an Otterbox Commuter. I had a bunch of issue prior to getting a new SIM and having the issues associated with not being able to pull the phone up correctly in the Verizon system. So that was two correction items. Phone has been fine since. I had that done second week of December.

    So the issue occurred in the case as well, but was not directly associated with the case from what I can tell.

    And yes, airplane mode is a work around; not a fix.
  23. John58543

    John58543 Well-Known Member

    It's been a week since they replaced my SIM card, no issues yet. This is day 14 with phone and I'm on the fence about whether or not to return...there's really not another phone out right now that I'd want to swap...guess I'll stick with it. This phone gets such good reviews online it makes me wonder how widespread this issue really is...:confused:
  24. balefire

    balefire Active Member

    Same issue. Occurs about 2x per week. Reset always fixes it. Seems to occur in low signal areas. I have turned off global roaming to see if that works.
    For me reseating and a new sim card did not fix the problem.
  25. ncampbell21

    ncampbell21 Well-Known Member

    I had the same problem when I first got my DNA. They replaced the sim card and still had the problem. Then they replaced the phone with a new one and the problem went away for good!

Share This Page