SIM card not recognizedGeneral

Last Updated:

  1. danomite

    danomite New Member

    Today I got a replacement Droid 3, my old Droid 3 had camera issues. I switched over the SIM card, SD card, and battery from the old to the new phone, activated it, and everything works well except the new phone doesn't seem to be recognizing the SIM card. When I press the unlock button to get the phone to the unlock screen, it reads "Extended Network|No SIM Card." at the top of the screen. Also, when I go into location and security and press "set up SIM card lock" a message pops up that says "No SIM card found. Please insert a SIM card into the phone". However, there is definitely a SIM card in the phone, and I can send and receive text messages. Verizon wireless is my cell phone carrier. Does anybody know how to fix this? Thanks!

  2. doogald

    doogald Guides Guide

    It sounds to me that it is either a bad SIM or a bad phone.

    Verizon Wireless does not use GSM SIMs in the Droid 3 on their network - that's only for international travel to areas that are not CDMA (CDMA is not a SIM based network for phones without LTE.) In fact, you should be able to run the phone without the SIM card while you are in the US on Verizon's network.

    Still, you can call Verizon to see if they will send you a replacement SIM and, if that doesn't work, I'd guess that it's time for another replacement handset.
    danomite likes this.
  3. doogald

    doogald Guides Guide

    Ha, and I just learned that if you run the phone without a SIM, power it down and replace it with a valid SIM, the phone will boot up in Global mode. So, if that happens to anybody, from home, menu->settings->Wireless & networks->mobile networks->network mode and change back to CDMA.
  4. fosterj

    fosterj Member

    I had an issue with an Atrix 2 getting a similar message yesterday. It's on ATT so the SIM is necessary for the phone to work. I tried re-seating the SIM, but no go. I did some research that suggested wedging some paper in there. I did and it worked like a charm. What you want to do is be sure the paper is on top of the SIM so that the pressure is pressing down. If that fixes the problem, then you know that it's your hardware
    Carlos3686 and danomite like this.
  5. danomite

    danomite New Member

    Thanks fosterj, I tried that and it worked! I still had my suspicions though, so I inspected the SIM card area with a magnifying glass and discovered that one of the contacts is damaged, it is pushed too far down and isn't making contact with the SIM card like it should. I contacted Verizon and they are shipping out another replacement Droid 3. Just goes to show, always double check things like that. Thanks for the help though everybody!
  6. Carlos3686

    Carlos3686 New Member

    Worked Like a charm. Thankyou for making this post. You helped me to help my sister get her phone back running and for that my man GOD BLESS YOU!!!!
  7. Delphina Nautu

    Delphina Nautu New Member

    I tried it but doesn't work.
  8. Delphina Nautu

    Delphina Nautu New Member

    How can I unblock or break the code for my Droid Razr HD MAXX XT926 using a sim card in my territory Pago Pago,American Samoa?
  9. doogald

    doogald Guides Guide

    As far as I know, you don't have to. Verizon global phones like the Razr Maxx HD are SIM-unlocked.
    themib likes this.
  10. themib

    themib Well-Known Member

    Last edited: Apr 15, 2015
  11. bizzyboy67

    bizzyboy67 New Member

    Here is a method to try,... you may not have the same phone or sim card slot, but this solution has helped a couple of my friends. It is simple and easy to do. The card may not be making consistent connections to the connectors on the board. Take a look and see if it will work for you.

Share This Page