SIM Card won't unlock after CupCakeSupport


  1. filbertman

    filbertman New Member

    I've got a problem with my SIM Card not unlocking properly. Here's some background.

    I got a G1 in October. I've used my VoiceStream SIM Card from 2001 or so and it's worked fine all this time. I have the SIM card set to be locked using a 4 digit PIN (same once I've used since I got the card.)

    Three weeks ago I got the CupCake update. Ever since then, when I turn on the phone after a flight (I travel for work), it won't unlock the SIM Card. It prompts me for the PIN and I enter it. After that the SIM Card lock icon remains in the status bar and it won't register on the network. I tried turning on and off plane mode and re-entering the PIN but no change, even after 30 minutes. I've also tried re-booting with no effect. I can force the phone to connect to the T-Mobile network but the sim card lock icon remains.

    However, if I go into phone settings and turn off the SIM card lock, then cycle the phone, it will connect fine and the Sim Card lock icon disappears after a minute as normal.

    I guess I don't really need the SIM card lock, but I'd rather have it on, just in case. I kind of like having my original VStream SIM Card but I guess I could try to replace it, but I would like some people's thoughts on this first.

    Advertisement
  2. shivers316

    shivers316 Godmember VIP Member

    Have you tried doing a wipe and then manually reinstalling 1.5? Sometimes that can do the trick with little problems like that.

Share This Page