SIM numbers won't appear in contactsSupport


Last Updated: 2010-12-30 22:52:29
  1. Caprylate

    Caprylate New Member

    Hello all,

    Just got my first ever Android phone in the form of a lovely Nexus S. I'm trying to get my contacts saved on my SIM card (previous phone Samsung G600) to show up on my Nexus S.

    I select the contacts app. And the menu button which brings up a few options, including "Import/Export" which I select. I then choose "Import from SIM" and the phone finds the names on the SIM, I press the menu button again and select "Import All" which is does with no issue, but when I go to the contacts tab again it comes up showing "No Contacts with phone numbers".

    However getting a text still shows the name of the person and their number.

    Is there something blindingly obvious that I'm forgetting here? (I'm UK based, on an Orange contract SIM card which I just swapped into the Nexus S bought handset only today).

    Additionally, when I try to enter the numbers manually it doesn't show up in my contacts list.

    Thanks for any and all help.

    Advertisement
  2. nickmv

    nickmv Member

    I had this issue as well. Turns out the option to display non-Google contacts wasn't enabled. When in contacts, hit the menu button, select Display Options. Then click your (presumably) Gmail account, then check "All Other Contacts".

    I'm also guessing that, like me, you tried importing multiple times. You'll now have that many copies of each contact. When in the main screen, hit the menu button, select settings>App Settings>Manage Apps>Contacts and clear out the data. Then re-import your contacts.

    They didn't make it very untuitive for new users, as this is my first smartphone and I was lost/thought my SIM wasn't working right.
    Caprylate likes this.
  3. Caprylate

    Caprylate New Member

    Just tried this and it worked perfectly! :D

    Thank you times a million! I was planning on going to the Carphone Warehouse tomorrow to complain!

    I should mention that rather than clear data in "Contacts" to remove the multiple copies of the same name, I had to go into "Contacts Storage" instead.

    Can't believe it required ticking an option in gmail account for it, who would want it to not show numbers stored on the SIM?!

    Once again, thanks!

Share This Page