Sims 3 not compatible?Support


Last Updated:

  1. Rambopants

    Rambopants New Member This Topic's Starter

    Joined:
    Dec 15, 2011
    Messages:
    4
    Likes Received:
    0
    I was gonna download this today and now it says its not compatible? It never said that before the Android Market switched to Google Play...WTF?
     

    Advertisement
  2. MacFett

    MacFett Well-Known Member

    Joined:
    Mar 28, 2011
    Messages:
    3,236
    Likes Received:
    740
    They may have updated the app which raised system requirements. Some apps are also no longer compatible with Froyo.
     
  3. brotherswing

    brotherswing Well-Known Member

    Joined:
    Feb 22, 2011
    Messages:
    3,054
    Likes Received:
    1,282
    Odd, it runs great on my phone...
     
  4. Rambopants

    Rambopants New Member This Topic's Starter

    Joined:
    Dec 15, 2011
    Messages:
    4
    Likes Received:
    0
    very stupid
     
  5. brotherswing

    brotherswing Well-Known Member

    Joined:
    Feb 22, 2011
    Messages:
    3,054
    Likes Received:
    1,282
    Try getting it from Amazon, they don't do compatibility checks.
     
  6. McNerdius

    McNerdius Well-Known Member

    Joined:
    Dec 19, 2011
    Messages:
    108
    Likes Received:
    32

    Both bits are equally important !

    Are you rooted, Rambopants ?
     
  7. Petrah

    Petrah Psychotic Female

    Joined:
    Jun 13, 2011
    Messages:
    4,085
    Likes Received:
    1,439
    Something is funky with the new Market. I tried to install a free app the other day and it popped up with an error that said it couldn't process the payment. Wouldn't install from my phone or from my browser on my PC. I ended up having to sideload the app.
     
  8. McNerdius

    McNerdius Well-Known Member

    Joined:
    Dec 19, 2011
    Messages:
    108
    Likes Received:
    32
    +2

    Just had an odd experience when attempting to try out an app...

    Under the "Install" button, it says "This app is compatible with your Virgin Mobile LGE LG-VM670."

    Clicking the install button results in popup saying "Oops, we could not determine if this item is compatible with your device. Please try again later."

    Um. What ?
     
  9. onlinecash2012

    onlinecash2012 Active Member

    Joined:
    May 27, 2011
    Messages:
    33
    Likes Received:
    1
    Same here I tried to download it and its not compatible... grrr....lol
     
  10. Rambopants

    Rambopants New Member This Topic's Starter

    Joined:
    Dec 15, 2011
    Messages:
    4
    Likes Received:
    0
    Its completely stock
     
  11. AngryTeddyBear

    AngryTeddyBear Well-Known Member

    Joined:
    Mar 20, 2011
    Messages:
    255
    Likes Received:
    35

    Try erasing your credit card info on Google Wallet.
     

Share This Page

Loading...