Siyah Gingerbread kernel (v2.x)

Last Updated:

  1. ironass

    ironass Well-Known Member

    No problems here with charging on 2.2rc1. Been connected to charger for about 3 hours and battery temperature at 31C.

    For anyone wishing to check their battery temperature...

    Dial pad > *#*#4636#*#* > Battery information

  2. fonegyro

    fonegyro Well-Known Member

    rc = release candidate
    Sydney99 likes this.
  3. Hawker

    Hawker Well-Known Member

    I will give rc1 a go in a minute, but I'm not holding out too much hope if i'm being honest, but I have a feeling my problems are down to my screen off profile. I shall test...

    For those who have had enough of Siyah, I can totally 100% recommend Ragemod kernel
  4. PureLoneWolf

    PureLoneWolf Well-Known Member

    Release's right before the Final Release stage

    I am running the RC and it seems superb at the issues, smoother than a cashmere codpiece on Go Launcher, using Smartassv2 100-1200

    So far so froody

  5. Rudedawg

    Rudedawg Well-Known Member

    I'll wait till RC2 myself. Let it break itself in first. Beta 16 seemed really good at first but that over night charge is quite horrific. I havent felt my phone get that hot since my 1st unit I recieved from Orange back in June. Charging fast on Beta 6 up to 80% so far and cool as ice.
  6. Rudedawg

    Rudedawg Well-Known Member

    Not convinced it was the battery a such , I ean the whole screen was hot to the touch near to the top of the phone. :( Its always one of those things that you experience and no one else does :D
  7. ironass

    ironass Well-Known Member

    Siyah 2.2 rc2 is up! :D


    ondemandx, ondemand fixes and lulzactive tweaks.
    changed memory allocator (from SLAB to SLQB)
    possible fix for lag during hotplugging. because of that I have reverted some performance tweaks which were causing battery drain & the device to become hot
    some code cleanups to get ready for the release
    fonegyro likes this.
  8. Sydney99

    Sydney99 Well-Known Member

    Ooh might test myself
  9. ironass

    ironass Well-Known Member

    Naff off Sydney99!

    Don't you dare put your curse on this one for me as well. :eek:
  10. Slug

    Slug Check six! Moderator

    Ondemandx and lulzactive = smooth.
    Smartassv2 = tiny but noticeable microstutters remain.
    fonegyro likes this.
  11. fonegyro

    fonegyro Well-Known Member

    Battery has improved a lot on RC2, 5% in 8-9 hours.
  12. Sydney99

    Sydney99 Well-Known Member

    consider it cursed ironass, back to beta 6 (again) for me

    on rc2 got stutter ++ with smartass, + with lulzactive/ondemandx, but smooth as butta baby on beta 6:cool:
  13. Kie

    Kie Well-Known Member

    Been on speedmod 2.2 for a week now to give it a shot. I have a great suspicion that it's the cause of my battery issues. I'll switch to RC2 tonight and see if it makes a difference.
  14. Rudedawg

    Rudedawg Well-Known Member

    Beta 6 and I don't remember making a battery last on one charge this long before :D

  15. Hawker

    Hawker Well-Known Member

    Testing rc2 now.
    Seems smooth on TW4.5, but still stuttery on Go Launcher. Not as smooth as RAGEmod.
    Still waiting to see if I get a system freeze as per beta 7 thru 16

    Rudedawg: thats a LOT of wakeloks you have there.
    Have you looked into it with betterbatterystats?
  16. Rudedawg

    Rudedawg Well-Known Member

    yeah it just says phone connection or wi fi :( I have those things switched off when its not in use so who knows.


    you get the point...
  17. Hawker

    Hawker Well-Known Member

    so facebook and maps are messing you up big time.
    i dont use facebook at all (thankfully!!)
    what are your latitude settings?
  18. Rudedawg

    Rudedawg Well-Known Member

    It looks like all google services. GTalk is even Frozen using titanium. Thinking ill delete tht app altogether. Latitude ...didnt think of that. I always have sync off including gps.

    UPDATE: Doubt this helps :D

    Also switched off notifications via the facebook app. Time for another dicharge and charge cycle. Hoping tomorrows report is much cleaner. :)
  19. Hawker

    Hawker Well-Known Member

    Tick those first 3 boxes
    in latitude itself, make sure you are not recording your position constantly and have history enabled etc. switch these off. ie location reporting>do not update your location, and disable auto check ins and check in notifications
    (unless of course you want all this happening!)

    rc2 update:
    I got a freeze. The screen stops responding to key presses. The home+power buttons respond but not the screen itself. I've now disabled my screen off profile to see if it is this that is causing the issue.
  20. Rudedawg

    Rudedawg Well-Known Member

    Ok well to be honest Latitude was cool when I was using Google+ but that died on its ass pretty quik so I cancelled my account. Now latitude is about as useful as a one legged man in an ass kicking contest.

    Goodbye latitude. \o
  21. Hawker

    Hawker Well-Known Member

    by the way, in betterbatterystats, set your bar height to 8 to see the bars properly
    Rudedawg likes this.
  22. Rudedawg

    Rudedawg Well-Known Member

    Blimey i never noticed the preferences before ^^. Thanks that IS easier.
  23. Kuragari

    Kuragari Active Member

    I'm on beta6 as! how on earth did you get 22 hours Rudedawg?

    For all the beta 6 experts out there: If you take into account my awake time, which are almost in sync with my screen on time. Except for a bit at the start and near the end which are due to the music player. Does this seem reasonable usage to anybody? I also left it on auto brightness today because squinting at a dark screen was beginning to give me the poops. :p Oh and also put Never when plugged in for the Wi-Fi sleep policy.


  24. Hawker

    Hawker Well-Known Member

    That doesnt seem unreasonable to me considering you had around 7 hours of screen-on time.

    Possible tweaks are to look at CPUspy at what are the most frequent MHz active, and also to ensure your phone is going into deep sleep. If you have a lot on 1400-1600Mhz, it may be an idea to limit it to 1200Mhz in SetCPU, but this of course depends on if slowing down will be a problem for you (eg if you are heaviliy into gaming which it appears you are not) Setting max to 1200 could extend your battery when your screen is on

    I've sorted out the phone freeze issue i've been having on the last 5000 versions of this kernel.
    Seems it was down to my screen off profile:
    500 max, 100 min, Priority 100, Conservative.
    I disabled this, and no freeze.
    I've upped it now to 800 to see if it will freeze again......

    Edit2: Freeze on 800
    I have now disabled all profiles altogether....
    Kuragari likes this.
  25. Kuragari

    Kuragari Active Member


    I don't know how good a reading this is because I started charging once it reached down to 15% which was when I took those other two screenshots. I don't overclock at all, I just keep it on 100-1200Mhz using lulzactive.

    Yeah I don't actually play any games, my heaviest usage comes from whatsapp and dolphin browser mini. Everything else is pretty minimal usage.

    But if it's just mostly the screen being on that is draining the battery, then I think I can live with that, no point not using a screen so big and nice to its fullest, right? :D

Share This Page