Skyrocket has battery meter issue... i.e. stuck at 100%Support


Last Updated: 2012-05-03 22:36:11
  1. scott14719

    scott14719 Member

    Ok, I'm not sure if this is am AMP issue or not. The travel charger w/ USB cord that comes with the Skyrocket is part# ETA0U80JBE. It has a 1.0 AMP charging capacity. Most other chargers only have a 0.7 AMP capacity. It seems odd that both the AT&T store and Samsung's own website lists the extra / replacement charger for this phone as one that only handles 0.7 AMPs? Most other places also list 0.7 AMP units as being compatible units. However, if you search by exact part #, there are a few places online including Amazon.com and Ebay that sell the ETA0U80JBE 1 AMP units. They are made by Samsung (they have the Samsung name on them) and they look and have the same specs as the one that comes with the SkyRocket.

    It seems many (if not most) people that are having the 100% battery issue are using chargers that only deliver up to 0.7 AMPs but the people that use the chargers that came with the phone (1.0 AMP) do not have the problem. The 0.7 AMP chargers work, but I can't help but wonder if they are what is causing the issue. I thought it might be a problem related to the overcharge protection and it still might be. Or it could be a combination of the lower AMPs and the overcharge technology. However, if the overcharge detection ciruit is located in the phone itself, it shouldn't make a diference. If the overcharge circuit is in the charger itself, it might be part of the problem with the lower AMP chargers or chargers that do not have overcharge protection.

    I am ordiering one of the ETA0U80JBE 1 AMP chargers from Amazon.com just to have a spare. It will be interesting to find out if anyone can identify (without a doubt) what exactly is causing this issue and how to fix it. The lastest OS uprade for the phone did not seem to address it.

    Advertisement
  2. joeynym

    joeynym Active Member

    i never had a chance to try the original charger... So i cant answer that...
  3. MWFrels

    MWFrels Member

    Just ran across this forum while googling for Skyrocket battery issues. I have had mine since 01-Dec. On Saturday evening I plugged it into the charger that came with it and the display said "fully charged" or something like that so I unplugged it. Sunday morning it was almost dead. Did a full re-charge and no problems till today. When I left the house this morning icon showed full battery. Just went to us it and all I get is a buzz when I press to light the display. This is irritating for a six day old phone.:mad:
  4. bhype1

    bhype1 Member

    I'm having this issue as well and its pretty annoying. I had been using my stock wall charger and bought a mini-usb cable from monoprice.com to charge while I'm at work. I used the non-oem mini usb at work to charge, then charged it at home that night using the stock cable and block and woke up the next morning with the battery full issue. Coincidence or not, I don't know, but after a week of a working battery meter, then to suddenly the 100% full battery indicator all times, I think it was the non-oem cable that screwed me.

    Is this something that would be taken care of under warranty through the manufacturer? Whom should we talk to? BB or Samsung?
  5. MWFrels

    MWFrels Member

    Yesterday evening when I got home I decided to do things a little more methodically. I noted that the battery icon was showing battery fully charged. I then opened the phone and unplugged the battery. On re-installation and power up icon now showed about half. I loaded Battery Solo Widget. BSW showed 52%. I put it on the OEM charger (#ETA0U80JBE) which is 5.0V at 1.0A. By the time I was about to go to bed the phone had reached 100% according to BSW. I repeated the battery removal procedure and it still showed 100%. I dimmed the display and went to bed. This morning after six hours sleep for me and the phone BSW still showed 100%. I repeated the battery removal procedure. BSW now showed 74%. WTF! Zero usage but a 26% drop in battery charge. I recharged it to 100% before leaving the house. Now at work two hours later it shows 98%. I am going to monitor charge till lunch time then repeat the battery removal procedure. Then likewise for the afternoon. I will report again this evening.

    M
  6. Mr. Ed

    Mr. Ed Well-Known Member

    I just exchanged my 3rd Skyrocket for a white one...after having the issue on the first Skyrocket I was unable to replicate this issue on the second and third.


    I will try on the white one when it arrives
  7. marcusone

    marcusone Member

  8. MWFrels

    MWFrels Member

    No change to phone behavior till I changed my charging behavior. I used to unplug from the charger a little while after reaching full charge. Not being electrically knowledgeable I am afraid I will burn up the phone, battery, or charger. But that's my problem. The other evening I plugged in to charge then forgot and went to bed. Phone got a good eight(8) hours charge. Yesterday power consumption was much slower and more palatable with what I expect from modern technology. I am going to try to follow this routine for a couple of days and take notes. To be continued, M
  9. Mr. Ed

    Mr. Ed Well-Known Member

    Just got my shiny new white one in. charging now
  10. jeremylub

    jeremylub Member

    The issue here is clearly a charger issue. It is not going to be affected by the cable, so anyone wasting time with that theory... stop. I am an Electrical Engineer and have worked on this type of stuff at the IC level. While I dont know exactly what Samsung has done here, I can make a pretty educated guess. The wall plug has a 'chip' in it. That chip is very specific (in that ALL the ones sold with this phone, and probably most of their phones have the same one). A few manufacturers make them and this is the one Samsung chose to use, and it probably has some programmability - or sends some specific signal to the phone when it is charged. OR it is possible the phone detects something in the charger unit OR the phone sends some acknowledge signal to the charger and if it doesnt receive back a specific signal it dont 'play happy'.

    Given the quick-charging nature of the phone, it is likely this is a fairly newer USB chip in the wall unit - and it is a little buggy. But that functionality could also be in the phone, which is also buggy (Samsung is NOT know to make the most quality product - and in fact they are such a bad company that any engineer I know who has ever worked with them refuses to EVER own one of their products... I almost didnt buy this phone because of it, but I still like it better than the current alternatives, so...)

    I have had this issue with my 2wk old Skyrocket a few times. Full charge. Let it sit 3 hrs. Dead. Also partial charge and dies very quickly. Also full charge but pull battery and it reads correctly (ie 30% down or whatever). I would expect there to be a fix sometime as this is a pretty big issue, but it is also POSSIBLE there is no simple fix... just depends on how they made the phone. But given a reboot works there should be a simple fix. So I am being patient because as much as this issue REALLY PISSES ME OFF (to the point that I am very close to ditching this phone for an iphone) I am willing to wait it out because I like the phone enough to deal with it.

    In any case, it appears that if you charge with the OEM wall-wart, or battery-out reboot, it seems to behave properly. If anyone knows of an app that correctly tells the phone % battery left in the notification area I would very much love to know about it.
  11. Mr. Ed

    Mr. Ed Well-Known Member

    It's even simpler than what you suggest. The 5v 1a chargers are causing the issue...one of us just needs to take the time to verify the theory. The .7a chargers do not cause the issue.
  12. diturl

    diturl New Member

    I have the 100% indicator issue too. I returned my first Skyrocket because of that and the fact that it was crashing during games (the crashing problem disappeared after the last patch). The new phone had the same battery indicator problems. I used the battery and charger that came with the phone. I always charge overnight, and I really have better things to do with my time than stare at my phone and see if it's charged or not, so unplugging it right after charging really isn't an option.

    Also, I called Samsung, and they claimed that no one had called them before for this issue. So I would ask that everyone call, so we can get some attention on this issue. 877-392-4252 is the number. And their answer was to factory default the phone, and if that doesn't work, send it to them for repair (yeah right).
  13. Mr. Ed

    Mr. Ed Well-Known Member

    The stock charger is a 1a charger in most cases. A few have posted receiving a .7a charger.

    When I use the 1a charger the problem happens (trying to verify on a 4th and 5th skyrocket tonight)

    When I use ANY of our other chargers, all of which are .7a, the problem does not occur.

    Check your charger, is it 1a?
  14. MWFrels

    MWFrels Member

    Just when I thought my problem was gone the phone showed me how wrong I was. After overnight charging Thursday into Friday both the battery monitors (icon and the app one I installed showed 100% charge till past lunch time. I of course did not believed it and removed and re-installed the battery. 71%! Expletive, expletive.

    I guess it's time to try the .7A charger theory. Any suggestions on which one I should source?

    M
  15. bhype1

    bhype1 Member

    My battery indicator light has not shown this issue again since doing one thing. Removing the battery for a bit then reinstalling BEFORE charging one night. Since then, 7 days ago, I have not seen this issue reappear on my SR. My battery meter displays as it should. I mainly stick to using the OEM cord/block for overnight charging. It is rated at 1.0a.
  16. Mr. Ed

    Mr. Ed Well-Known Member

    I wish I did, we have a ton of them lying around the house so I have just been using those. Some are HTC branded, others Samsung.

    I am not entirely certain the issue is the charger now. It may be the phone. I am continuing to test, but in my testing last night I could not get this to happen again on the new phone.

    i.e.

    I used the 1a charger that I suspected to be causing the issue to test my new white skyrocket and I can not get it to do this. The battery meter works every time so far.

    I am going to leave it on the charger for a few hours today at 100% and see what happens.
  17. I'm very curious to see what happens as I have had mine for 3 days an am experiencing the same issue..
  18. Mr. Ed

    Mr. Ed Well-Known Member

    So far still working. Tonight i will plug in at 100% and leave it plugged in overnight
  19. MWFrels

    MWFrels Member

    Yesterday afternoon I got the store I got my SR from to lend me a Samsung ETA0U60JBE .7A charger. That evening I removed/waited/reinstalled battery then charged to 100% with it. This morning eight hours after charge according to the monitors the phone had only used 10% of the charge while it and I slept. This is much better than the 26% I reported a few days back but I am still skeptical. To be continued, M
  20. Mr. Ed

    Mr. Ed Well-Known Member

    I have no new news.

    Left both of our phones charging 8hours at 100% on the .1a chargers last night and both are displaying battery correctly.

    This may indeed be phone specific and the .1a charger is simply the trigger The question at that point will be is it software phone hardware or battery
  21. MWFrels

    MWFrels Member

    Somewhere around 30 hours since .7A charge and battery indicators show 67% battery left. Encouraged but still skeptical! I am not going to recharge till phone stops working. That way I can get a better picture of indicators verses function. The story continues, M
  22. MWFrels

    MWFrels Member

    Last night before sleep my battery indicators showed 30%. This morning they still showed 30%. Went through the battery removal/wait/reinstall and the indicators showed 0(zero)% on power-up. A few moments later 1%. An hour later as I was leaving for work and the phone had just been sitting not being charged I saw 17%. When I got to work 15 minutes later it was still at 17%. Switching to the .7A charger seems to have made things much better but not completely fixed. So as a previous poster said it is probably a combination of quirks that is making use of the 1.0A charger impossible. I am going to continue to monitor for a couple of days and report observations here. M
    Mr. Ed likes this.
  23. vracer

    vracer Active Member

    Mine has worked perfectly for 11 days, but under the FWIW catagory - I have read that the original GSll had a problem with battery usage and slow charges. I wonder if that phone used a .7A wall charger and charging circuit, and if the S'rocket got the same internal charging unit that was designed for .7A, and they just threw a 1A wall charger at it under the old theory that if it doesn't work, hit it with a hammer. If it still doesn't work, get a bigger hammer.

    Another thing you might try if you continue to have problems is an iPhone charger. It is 1A, and the QC may be better, or the Kindle charger is, I believe, .75A.
  24. Mr. Ed

    Mr. Ed Well-Known Member

    the apple 1a charger is what gave me issues on my previous skyrockets. I have been using it for the past 4 days now with no issues (different skyrockets now)
  25. MWFrels

    MWFrels Member

    Just when I am starting to get a good feeling the problem is workable even thought not gone the phone again proves me wrong. Charged with .7A unit to 100% last night only to find it was down to 84% just sitting there while I slept for 6 hours. Plugged in to same charger when I got to work till the phone told me "fully charged" or something like that and to unplug charger. By the time I left work 9 hours later and only making one phone call on the phone the battery was down to 37%. This is BS! Phone is getting exchanged as soon as I can get to the store where I bought it. I hope I don't have to go through 4 or 5 phones to find one that works correctly. Other than the battery bs I really like the phone.

    M

Share This Page