Skyrocket has battery meter issue... i.e. stuck at 100%Support


  1. Mr. Ed

    Mr. Ed Well-Known Member

    I can appreciate your input but I don't think you are having the issue we are discussing. We are referring to charging then the battery level indicates 100% the entire time it discharges. Your complaint appears to be battery life related.


    I have had my new skyrocket a week now and the issue has not been present/regardless of charging method used fyi
  2. MWFrels

    MWFrels Member

    I got a replacement SR 15-Dec. Still using the same 1.0A charger that came with the first SR. No quirky battery life problems at all now. The problem was either in the first SR phone or its battery. Now I can move forward and enjoy the phone.

    M
  3. Mr. Ed

    Mr. Ed Well-Known Member

    The unnoficial answer is bad firmware in the battery. The 1a charger triggers the issues. Contact your carrier or Samsung for a new battery.



    Sent from my SAMSUNG-SGH-I727 using XDA App
  4. MWFrels

    MWFrels Member

    For the first time since exchanging phones two weeks ago mine acted up overnight. Similar to once before in that battery showed 82% before I went to sleep and then 31% seven hours later when I got up. Reading Mr. Ed's post from yesterday was an interesting coincidence. Is there any way to identify which batteries have the "good" firmware in them? My current battery shows EL-L1D7IBA and S/N:NA1BA31DS/4-B.

    M
  5. jktrahan

    jktrahan New Member

    I got my SR 2 weeks ago and on the second day started researching the 'Battery Meter' issue. I read Mr Ed's post and started using the "Status Bar Battery' app and battery meter now reports accurately instead of dropping in large chunks.

    I just tried stopping the app and running for a little while and the original battery meter never moved. I started the app again and it immediately dropped by 9% to report the correct amount.

    So, am I missing something or is this the same thing that you all are seeing? I'm now understanding that this is not normal and i should ask ATT for the battery to be changed? Or, are your issues different?

    Thanks,
  6. Mr. Ed

    Mr. Ed Well-Known Member


    I believe yours may be a different issue. The stock battery meter displays 15% incremental changes ...i.e. you won't see the meter change until it reaches 85%

    In the cases above the battery level never changes until battery pull, or it dies
  7. Midiman

    Midiman Well-Known Member

    First: MWFRELS: Your issue is not the same thing that the rest us us in this thread are talking about. You are throwing out all kinds of different battery level numbers. The only number we are concerned with in this thread is... 100%

    Second: I bought my Skyrocket on the 21st. I brought it home, opened the box and was instantly unimpressed with the length and flimsiness of the charge cable. I immediately ordered 2 high quality MediaNet 6' MicroUSB cables and an OtterBox Commuter case. I then spent a week waiting while using the normal routine I have used for a couple of years. I have a Belkin dual port charger by my bed. 2amp, 1amp per port. I charge both my phone and my 64G iTouch overnight while I sleep. Everything was fine for a week until the cables arrived. First night on the much nicer, heavier, and most importantly.... longer MediaNet cable, I awoke to the 100% battery stuck issue. The next three nights in a row resulted in the same thing. Last night, I switched back to the stock cable. This morning... no 100% battery stuck issue. I only have one day of testing to base this opinion on but FOR ME... the issue appears to be what cable I use and has nothing to do with the charger (theory disproved, definitely a combination of the two). I did absolutely nothing else... no pulling batteries, no change in software. The phone is completely 100% stock with the apps I pretty much installed all during the first two days of owning the thing. The only thing that changed... was the cable.

    This is my composite testing chart.
    It containing results from all posts that follow.


    --------------------------------------------------------------------------------------

    All testing done with Belkin dual port charger, 1amp per port, charged overnight for about 8 hours:
    12/27/11 - 3' AT&T Zero Charge Cable/Belkin Dual Port 1a/port charger - No problems to date
    12/28/11 - 6' MediaNet Cable/Belkin Dual Port 1a/port charger - Stuck battery indicator - first time
    12/29/11 - 6' MediaNet Cable/Belkin Dual Port 1a/port charger - Stuck battery indicator
    12/30/11 - 6' MediaNet Cable/Belkin Dual Port 1a/port charger - Stuck battery indicator
    12/31/11 - 3' AT&T Zero Charge Cable/Belkin Dual Port 1a/port charger - No problem
    01/01/12 - 3' AT&T Zero Charge Cable/Belkin Dual Port 1a/port charger - No problem
    01/02/12 - 6' MediaNet Cable/Belkin Dual Port 1a/port charger - Stuck battery indicator
    01/03/12 - 3' OEM Cable/Belkin Dual Port 1a/port charger - Stuck battery indicator (8:45)

    The end of testing with this specific Belkin charger tells me I get very consistent, predictable results with three different cables. Only one of the three cables (AT&T ZERO Charger) charges properly with this charge block. My initial results tell me it's not a matter of one or the other (block/cable) but a combination of the two.

    --------------------------------------------------------------------------------------

    All testing done with an HTC wall adapter, single 1amp port, charged overnight for about 8 hours:
    01/04/12 - 6' MediaNet Cable/HTC wall adapter, single 1amp port - No problem (9:15)
    01/05/12 - 3' OEM Cable/HTC wall adapter, single 1amp port - No problem (9:00)
    01/06/12 - 3' AT&T Zero Charge Cable/HTC wall adapter, single 1amp port - No problem (8:00)

    --------------------------------------------------------------------------------------

    All testing done with OEM wall adapter, single 1amp port, charged overnight for about 8 hours:
    01/07/12 - 3' OEM Cable/OEM wall adapter, single 1amp port - No problem (8:30)
    01/08/12 - 6' MediaNet Cable/OEM wall adapter, single 1amp port - No problem (9:15)
    01/09/12 - 3' AT&T Zero Charge Cable/OEM wall adapter, single 1amp port - No problem (8:30)

    --------------------------------------------------------------------------------------

    All testing done with Scosche reVIVE II, dual 1a/2.1a ports, charged overnight for about 8 hours:
    01/12/12 - 3' AT&T Zero Charge Cable/Scosche wall adapter, dual 1a/2.1a ports - No problem (8:45)
    01/13/12 - 6' MediaNet Cable/Scosche wall adapter, dual 1a/2.1a ports - Stuck battery indicator (8:00)
    01/14/12 - 3' OEM Cable/Scosche wall adapter, dual 1a/2.1a ports - Stuck battery indicator (8:00)

    --------------------------------------------------------------------------------------
    01/01/12 - It appears that the cable I have been using since buying the phone which does NOT result in the stuck indicator issue is the aftermarket cable I bought from AT&T for $9.99. It's part of their ZERO Charger system. It has the little black tag on it which says "Charge only Cable." So, I have apparently never used the OEM cable. Chart revised

    01/05/12 - I discovered, in another thread concerning USB data connections, that the aftermarket, AT&T ZERO Charger cable I have been testing (along with two others) which has NEVER resulted in a stuck battery indicator, is marked as a "Charge only Cable" on its little black tag. It does NOT work for data connections but reliably charges the phone without the issue at hand... so far.

    01/07/12 - Doesn't seem to be much point continuing with the HTC charge block tests. All three cables charged the phone reliably once. In the interest of expediting other charger testing, I'm moving on to the OEM charger tonight. I may come back to chargers that only got one test per cable later, but my first try at multiple tests of individual cables yielded consistent results. One specific cable never performed differently a second or third time.

    01/08/12 - The $64,000 Question. OEM charger, OEM cable, no stuck battery indicator (for me). The OEM cable has performed fine on 2 out of three charge blocks I have tried so so far. The only one it didn't like was the Belkin, but the Belkin was fine with the Charge Only, AT&T aftermarket cable.

    01/12/12 - Starting testing of a Scosche reVIVE II (USBH3) Dual port (1a/2.1a). The 2.1a port is for charging iPads which I don't own. Should be interesting. I bought this for my son after I gave him a 64G iTouch so he could charge his phone and iTouch at the same time like I do with my favorite little Belkins. I never gave it to him out of concern over the 2.1a port. The thing had great reviews when I bought it, now everyone is screaming mad. There are allegations that it doesn't meet certain standards and they all seem to drop dead within a couple of months. Great stuff to test with :) I won't be using the 2.1a port.

    http://www.amazon.com/Scosche-reVIVE-Dual-Home-Charger/dp/B003N7NO4G/ref=sr_1_29?s=electronics&ie=UTF8&qid=1326445451&sr=1-29



    [​IMG]

    This cable with this little black tag saying "Charge only Cable" and marked "AT&T" on the full sized connector does NOT work for USB data connections. Beware. It does, however, faithfully charge the phone on every charger I have tested without triggering the stuck battery indicator issue. This includes one charger that won't properly charge with any other cable.
  8. Mr. Ed

    Mr. Ed Well-Known Member

    ^this is interesting. A handful of us tested numerous cables and always resulted in it being the charger


    The plot thickens
  9. Midiman

    Midiman Well-Known Member

    It makes very little sense unless there is a physical difference in the cables. I suppose I could get out my continuity tester and start probing individual lines. Having spent most of my life in the audio/video business, I know better cable allows better conductivity but I can't see that being an issue. I'll switch back and forth between cables for the next week or so and update the original post in the morning with my findings using both cables.

    It could just be a random problem.
  10. Mr. Ed

    Mr. Ed Well-Known Member

    Keep me updated please
  11. Midiman

    Midiman Well-Known Member

    Original chart updated. Night 2 on the stock cable/belkin charger, no stuck issue. Tonight I will go back to the 6' MediaNet cable.

    Yesterday I barely used the phone. I played with the camera for about 10 minutes in the middle of the day. Checking the usage chart just before plugging it in... I could see a very slight, continuous slope with a little bit of a fall off right in the center where my camera usage would have been. After 16 hours off the charger, the battery was still at 81%. I plugged it in at 3:30am and heard the "charged beep" 25 minutes later at 3:55... I let the screen die off by itself and left it on the charger till I woke up at 1pm today.

    The day I bought the phone at AT&T, I bought a second, aftermarket cable AT&T had on a rack. It looks about the same as the OEM. Flimsy and only about 3' long. I have never used that cable. I'll toss it into the testing mix eventually.

    I also have a dozen different blocks lying about including an Apple, a couple that came with my Jawbones, a new, never used Scosche that is a dual port with a 1amp and a 2.1amp port. The 2.1amp is for charging iPads and, presumably, other tablets. I'm not sure I want to put my phone on anything with that much amperage but it shouldn't harm anything. A device will only draw what it can.

    EDIT: It appears that the cable I have been using since buying the phone that does NOT result in the stuck indicator issue is the aftermarket cable I bought from AT&T for $9.99. It's part of their ZERO Charger system. It has the little black tag on it. The tag says "Data only Cable", you cannot use this cable for USB data connections. So I have apparently never used the OEM cable. Chart revised.

    [​IMG]
  12. Midiman

    Midiman Well-Known Member

    Used the 6' MediaNet cable last night and had the battery stuck issue. Seems an open and shut case between those two cables on that charger. Will try the OEM cable for the first time tonight. Depending on results, I'm going to move on to different chargers. Chart in original post is updated.
    Mr. Ed likes this.
  13. colton033

    colton033 Member

    I was also having the issue of the meter being stuck @ 100%. I had tried the stock charger, a usb style charger for iphone and both had same results. Stuck at 100 unless I cycled the phone off and on. Then I came across a charger that I got with my BB Storm a year or so back, tried it. Voila, no more issues of the meter being stuck at 100%.
    Just my "2 cents"
  14. Midiman

    Midiman Well-Known Member

    Using the OEM cable for the first time tonight, on the same Belkin charger I've been testing the other two cables with, resulted in the battery stuck issue. That's odd. The cables are nearly identical. Same 3' length and flimsy guage of wire. Could be the best way to avoid the problem based on my results is to buy one of the $9.99 NET Zero charge cable from AT&T. You don't need the block that is sold separately. I'm beginning to wonder if time on the charge is relevant and will start keeping those stats.
    Mr. Ed likes this.
  15. Midiman

    Midiman Well-Known Member

    Switched up chargers last night. Now using an HTC wall charger with a single 1amp port. 6' MediaNet cable resulted in no problem unlike with a Beklin charger. Chart updated. Charged 9:15.
    Mr. Ed likes this.
  16. iPhone Piper

    iPhone Piper Member

    Latest and greatest phone and the damn thing doesn't even have a working battery meter? :) wow.......... bummer.
  17. Midiman

    Midiman Well-Known Member

    Thanks for trolling. This thing has a perfectly fine working battery meter. If you're like many of us who like/need to charge from several locations and tend to use multiple types of charges and cables, there can be issues. Now please step back to your iPhone
  18. Midiman

    Midiman Well-Known Member

    When using the OEM charger, did you use the OEM cable? What does the output amperage stat on your OEM charger say?
  19. iPhone Piper

    iPhone Piper Member

    "This thing has a perfectly fine working battery meter". Apparently not, important enough to make a sticky about it.

    I'm not trolling, my point is............. 5V is 5V. Feeding it a max of 1 amp or 3/4 amp should not change a thing regarding battery indication. Slight voltage and resistance variations exist from charger to charger and if the system cant account for these common variations, then its a crappy design. Since I have a Skyrocket, it does concern me.
  20. Mr. Ed

    Mr. Ed Well-Known Member

    Lets all try and keep it civil and work towards the common goal ;)

    Midiman is making great progress with his chart


    What I still can not understand is this:

    My previous skyrockets had the issue, current skyrocket does not

    I am using the same chargers that I used previously
  21. Midiman

    Midiman Well-Known Member

    You are correct, 5v is 5v, however feeding at lower amperage than a device will attempt to draw will result in overheating a charge device (even a battery) which can lead to all sorts of irregularities including the death of the charger. That's why we don't put AAA batteries in slots designed for D's despite the fact that they are both 1.5v devices and the end terminal spacing is the same. Conversely, feeding at higher amperage, within reason, has no ill effects and just makes the charger more comfortable and efficient. For instance, I frequently power guitar devices that require 100ma with 2amp supplies but wouldn't care to put a 200amp supply on them. I no longer have access to the fancy kind of diagnostics gear I had in the engineering dept of the PBS station I worked for (please note, I was a producer and director, not an engineer... but once you're in the field, you become a bit of everything). That sort of stuff would monitor voltage over time, looking for irregularities so you didn't have to sit and stare at a display all day. I have only encountered the problem with one out of three chargers I have tested so far. I'll stick a VOM on that one and see if I find any discrepancies between published and actual output levels for voltage. Perhaps I can persuade an old friend who still slaves in the dept to toss the thing on for a while and see if he can come up with anything.

    That said, I've found a couple of 550ma USB wall adapters that came with my Jawbones. I'll get around to testing one of them to see how a substantially lower amperage unit does. I know Samsung seems to sell an adapter for the Skyrocket rated at 700ma. Odd since the OEM supplied with the phone is 1a.

    Unfortunately, for me, the Belkin charger is the one I like. I like it so much, I bought two and they functioned fine for the two year life of my HTC Tilt2 and everything else I've thrown on it. I like to be able to charge both my phone and iTouch at the same time, with a minimum of fuss and gear, in multiple locations. One stays in the bedroom, the other is usually at my main (one of four) workstations in the house. Of COURSE... that's the one I have issues with. Fortunately, the issue is avoidable by using the AT&T "charge only" cable in the bedroom. I don't need a data connection there. Unfortunately, the cable is only 3' long which makes it difficult to grab and answer the phone while it's connected. I might do some testing with a USB extension.
  22. Midiman

    Midiman Well-Known Member

    That throws an interesting monkey wrench into the equation.
  23. Mr. Ed

    Mr. Ed Well-Known Member

    Well....i did mention this previously

    :p
  24. kchandr1

    kchandr1 New Member

    Hi All...The post related to this issue in Skyrocket is extremely useful....I do own a SGSR from Nov 2011...Started facing the battery issues freezing at 100% right from last week....Called att customer care..and they are sending me a replacement battery for getting it fixed...will it help? ......Do I need to demand a new replacement phone in case...the issue persists?...Well...

    I do use only Samsung charger provided with the phone and it is rated..1A ...

    Can anyone help me out?
  25. Mr. Ed

    Mr. Ed Well-Known Member

    There has been one member on FDA that claims he was told it was bad firmware in the battery.. battery was replaced and the issue went away. Can you update us when you try the new battery?



Loading...

Share This Page