Slow bootup with rooted MomentSupport


Last Updated:

  1. Vagetarian

    Vagetarian Member

    So, I've done my fair share of reading in the forums. I know this question has come up several times, but it hasn't been sufficiently answered for me. That, and I'm a n00b. So sorry if this is a repeat or whatever.

    I got my Samsung Moment and rooted it. I had to root to get 2.1 I think. I don't remember much. Anyway, it was working pretty well. But I wanted the latest update! So when 2.2 became available (unofficially, from the SDX guys), I got it. Ever since then, my boot time has been horrible, and even the power down time is slow. I timed it and it's a full two minutes before the home screen even shows, let alone is ready for me to start using it. I went to factory default before flashing 2.2, so I don't know what the deal is. After I put several apps (no widgets or anything excessive), it became slow to use too. After taking a lot of them back off and switching back to the default launcher, it operates perfectly quickly. But the boot time is still slow as ever.

    I know this isn't a powerful phone, but it wasn't like this pre-root or after the first ROM. Is it possible my shitty phone just isn't made to handle 2.2 well? Or maybe I should have a different kernel version? I'm putting my specs so that someone can tell me if maybe there's a problem there. If there's no obvious problem, I guess I'll just go back to 2.1.

    Android version: 2.2.2
    Baseband version: S:M900.8.0S.DE03
    Kernel version: 2.6.32.9
    Build number: CrapKernel_2.2
    As for the custom recovery, uh... don't recall. It says at the top "Android System Recovery 3.0.8 SDX Samsung Moment SPH-M900" if that helps!

    Advertisement
  2. IOWA

    IOWA Mr. Logic Pants Moderator

    I'd just chalk it up to it being a phone that's 2+ Generations old, a senior citizen in the mobile world. It's aging, and the fact that it's running 2.2 is a feat in itself. Good luck =)
  3. Vagetarian

    Vagetarian Member


    That's basically what I figured. So, just like an old computer, I'd get more use out of it downgrading back to 2.1, I assume?

    On a funny note, before I removed the apps, it was so bogged down and laggy that it actually couldn't find my location with any app involving GPS. :eek:
  4. HeadlessPonch

    HeadlessPonch Well-Known Member

    I've used a few different versions of 2.2, and I have noticed that it takes longer to shut down, but my boot time is a bit faster. I'm not running ext2/3/4 or anything like that, which is supposed to help the phone boot really fast (need bigger/faster microsd card than stock to use it).

    Which version of 2.2 are you using? I'm on tEF09 with the included kernal and I've got way more apps than I should, and I don't have the problems you're reporting. I am using the dalvik cache to /cache mod and have a few things moved to the sdcard to free up some phone memory. Maybe you should try a newer/different version of 2.2 to see if that helps.

    Also, the latest version of your recovery is 3.1.1, although I don't think that would be the problem.
  5. Vagetarian

    Vagetarian Member


    EB28 v1.1. Yeah, I suppose before giving up and downgrading to 2.1, I ought to try different versions of 2.2. Just a lot of trouble I wish I didn't have to go through. ;)

    The forum from which I got it recommends this updated JIT, but I don't even know what that is. They say it may make it faster... *shrug*
  6. Vagetarian

    Vagetarian Member

    Ok, so I flashed tEf09 v1.7. It's still every bit as slow, if not slower. Wtf? And I'm having a lot of trouble with my data connection (this was happening before I switched from EB28). It takes a loooooong time (half an hour, maybe?) to connect to the data network and randomly disconnects sometimes.

    I don't freakin' get this. I could use some help.
  7. HeadlessPonch

    HeadlessPonch Well-Known Member

    The latest version of tEF09 has JIT included. I haven't really noticed any improvements myself from the previous, non-JIT version. Hasn't hurt anything, either.

    It might be time to flash back to 2.1 and make sure everything works fine. Use the SWupdater to flash the 2.1 tar and then 3.1.1 recovery and a kernel (I've attached inxane's 065 kernel). Check your speed and see if gps is functional. If your phone's at all like mine, gps will work better in 2.1. If all is well, apply the DJ07 deodex zip (for theming) and the arm11 zip that I've also attached. It speeds up the phone slightly, without the instabilities that JIT can add.

    I attached those 2 files because stuff can be tough to find on sdxforums sometimes, especially in the 2.1 section. I'd add links, but I'm posting this from work and sdx is blocked, although this site's not :cool:. You should be able to find the DJ07 deodex easily enough. There's also a mod that adds reboot/recovery to the shutdown menu and gives you the 5% battery, but otherwise looks stock.

    I do hope 2.1 fixes things for you. My Wife's phone has been running with 2.1, arm11, and the reboot/recovery w/5% for several months with no problems (except the whole wifi issue - just don't use it).

    Attached Files:

    Vagetarian likes this.
  8. HeadlessPonch

    HeadlessPonch Well-Known Member

    Almost forgot - the arm11 zip will break the stock calculator. Here's a replacement. I grabbed Office Calculator from the market so I don't even have the stock calc any more (no percent function!).

    New post because EDIT won't let me go advanced :confused: to attach this file.

    Attached Files:

    Vagetarian likes this.
  9. Vagetarian

    Vagetarian Member


    I actually got it into a boot loop trying to put a new 2.2 on it (not really sure how). And I hadn't created a backup right before flashing the new one. So I used my most recent backup, which was from a few months ago (before all these problems started). I discovered this backup actually IS tef09. So now I'm back on that, and it's a drastic improvement. My comma key still doesn't work without using the Shift instead of the Function key, but whatever. The speed and functionality of everything is greatly increased. The boot time is still slower than I feel it should be, but to be fair, I have a lot of apps back that I wasn't using when I had crappy EB28. I did go ahead and order a new phone though, just because I want an upgrade. But I'll be giving my mom this one, so I'm still bookmarking this thread so I can use it.

    So thanks for all your help. I'll also keep some of this in mind for my new phone because all the problems I've had have helped me understand Android phones. My new one is a Samsung too -- The Epic 4G. :)

    [Edit:] When I said I flashed tef09, I believe I tried and failed, because nothing was different. So then I got frustrated and tried to factory reset which seems to be what put it into the bootloop.
  10. HeadlessPonch

    HeadlessPonch Well-Known Member

    Glad you got it working.

    The Shift/Period is second nature for me now. I even find myself using it on my Wife's 2.1 Moment and in connectbot on mine. (Func/Period works normally in connectbot).
  11. Vagetarian

    Vagetarian Member


    Yeah, it's become pretty much muscle memory for me now. On my new phone, I'm going to probably be doing it that way out of habit.

    Also, I'm in a Java class in college right now. Maybe I'll be able to fix some of this stuff on my own soon enough. ;)

Share This Page