Slow down with Flash audio streaming

Last Updated:

  1. Darkfyre97

    Darkfyre97 Active Member

    This is the oddest problem I've ran across since I started playing with rooting and ROMs. After a few days of installing a new ROM and/or kernel(happens across Bugless Beast, Liquid Frozen Yogurt, Simply Stunning, and Sapphire, etc) any stream that incorporates flash and has streaming audio, the audio stream plays in slow motion. Oddly enough, the video is fine, but the audio is awfull. It doens't happen on day 1 on the ROMs, its ALWAYS a few days after I install and happens on any site I try. I've tried uninstalling the Flash player and tried several different builds of the leaked Flash player and it never fails. :(

    I know its a long shot, but does anybody have ANY idea what might be causing the audio to freak out after a few days? I can't deduce if its a combination of apps that I'm installing or some kind of imcompatibility between ROM and kernel choice I make...but its uber frustrating and I'm having to shy away from some of the nicer ROMs because I need my audio fix for the day.

    Thanks in advance!

    Just tried in the new RC3 of Cyanogen and it does the same exact thing..I'm really at a loss, I have NO Idea how to tell whats causing this problem =(

  2. Darkfyre97

    Darkfyre97 Active Member

    Gonna do one self bump since its been a couple days and if I still get no responses, I'll let it die...

    I also finally found another instance where this is happening. Completely different phone and I also tested my wife's Droid (she's using Liquid Frozen Yogurt) and its having the same issue.

    Adobe flash, on Skyraider 2.5.2 (Sense) - Android Forums is the post I found with issues similar to mine.

    Oddly enough, with the stock 2.2 with root from ROM manager, I haven't had any issues at all since I installed it, but I've tried fresh installs of all the major Droid ROMs and they all have issues with nothing but the system and flash installed. =( I hope somebody can shed some light on whats up with it.

    I'd ask some of you to try (Listen Live link) and (not works, but I hate the way it uses the phone's media player) and see what your results are. I'd be curious to hear if our phones are indeed just stupid.
  3. mdimbler

    mdimbler Member

    I've got a co-worker who just upgraded his Incredible to 2.2 (OTA) and he has experienced the same slow motion audio stream when playing through a web's flash interface. I installed the leaked OTA from 7/27/10 and mine runs fine. Tried installing the Flash version that I have on my Inc (from the Nexus One) onto his Inc it is still slow.

    Anyone else experience this or have a solution?
  4. Darkfyre97

    Darkfyre97 Active Member

    I've all but given up on this problem. My suggestion is (at least for the Droid, dunno about the DInc) to go with Sapphire 1.0 or a rooted stock ROM. I've found a few otheres here and there that work, like the new Steel Droid 1.9, which is really nice, btw, but for the most part, apparently theres something in the process of building the ROMs that has the potential to hose Flash audio and I think its so hit or miss that its gonna be impossible to reliably track down the root of it...just my 2 cents though.

    I'd LOVE for a dev to prove me wrong. If Flash streams ok on the 1.1.0 Sapphire thats coming tomorrow (I hope), I'll have definately found a new standard ROM for me and all my friends who are having the same problem.

    Chevy has given me a suggestion to try for SS 4.7 but it had no effect and I've posted on Cyanogen's forums as well, hoping for a few suggestions to try, but I know those guys are busy and this is affecting a small niche group of their users, so I'll just stick with what works for now.
  5. packfan21g

    packfan21g New Member

    Had the audio problem with SS4.7. Flashed to Sapphire 1.0 and the problem went away. Flashed to Sapphire 1.1 today and the problem returned. Don't know the cause, but when I flashed to Sapphire 1.0 from ROM Manager, I was given the option to enable Stafefright which I did. Didn't get that option with Sapphire 1.1 when I flashed via recovery.
  6. Darkfyre97

    Darkfyre97 Active Member

    I don't think its Stagefright vs Opencore causing the problem. Chevy had me disable SF in build.prop for SS4.7 and I still had the same problem.

    I upgraded to 1.1.0 for Sapphire today as well and promptly reverted back to 1.0.0 when I found that, like you, the problem returned. I guess I'm stuck with builds before FRG22D if I want a custom rom or a rooted stock rom (which all seem to work, regardless of build).

    At this point, I assume it has to be something with the way the ROMs are cooked on the newest builds, as its happening with EVERY new ROM thats out there that I've tried, except for Steel Droid 1.9, which, if I recall, is FRG22D works like a champ.
  7. mihalich

    mihalich Well-Known Member

    I have the exact same problem on CM 6.0, and it's pissing me the hell off. This was not happening at some point in the past with older 2.2 ROM.s

    With one station I got it to stream with the first beta of the flash that was released. But another station I go to still has the problem with that version of flash.

    Both of these stations work fine on my wife's Droid 2.

    The issue has to be some binary (kernel maybe ?) that has been modified in the ROM's we're installing. Some version of some binary broke this functionality.

    I went through all sorts of debugging on this. Different browsers, different flash versions, different radio station web sites...they all have the same behavior. The fact that I can get one station to work on an old version of flash, and the fact that you say it works fine on stock 2.2, points directly to some binary in the custom ROMs.

    This makes sense since when you upgraded to sapphire 1.1, the problem came back. They probably upgraded the latest version of the binary that broke this, in 1.1 which brought the issue back.

    I originally thought that the streaming services hosting the flash audio streams, were detecting the mobile flash player and doing this on purpose to keep us from streaming from the phones. That is disproved by the droid 2 working, and the stock 2.2 droid 1 roms working.

    The problem is figuring out what is causing it, and how to notifiy the people in charge to fix it.

  8. mihalich

    mihalich Well-Known Member

    Also, btw, just as a test, I just wiped data/cache, and installed CM 6 fresh. I installed the latest flash player, and the same issue occurs out of the box.

    I posted this same info in the CyanogenMod forum to see if anyone of there has any idea how to debug this and figure out what's causing it.

    I know it doesn't seem related the ROM but, the more eyes that see it, the better chance someone might know what's causing it.

    Just installed Pete's stock FRG22D rooted, and the audio streaming works fine with the stock kernel. I then flashed chevyno1's LV 1.1 Ghz Kernel, and the audio streaming still worked. So it's not the kernel.

  9. mihalich

    mihalich Well-Known Member

    Found a solution for this...head on over to this thread at zip file you need is down towards the bottom. This should work for any ROM that has this problem. It patches the stagefright jars that were modified by someone off the stock android version of the libraries.

    CyanogenMod 6.0 - Adobe Flash streaming radio - CyanogenMod Forum


Share This Page