Slow tethering (shared internet connection)


Last Updated:

  1. gizmostudios

    gizmostudios New Member This Topic's Starter

    Joined:
    May 8, 2010
    Messages:
    1
    Likes Received:
    0
    Hello, I'm a proud owner of a HTC Desire and I have a subscription with Vodafone NL. Now I use the tethering option a lot together with my Windows 7 laptop, but there seems to be something going wrong. When there is a HSDPA connection available with full coverage, the speed SHOULD be around 3.6 Mb/s. But when I run a speedtest on my laptop at Speedtest.net - The Global Broadband Speed Test, the speed shows around 0.6 Mb/s instead... BUT on my phone, when I run the speedtest app, the speed is around 2 Mb/s. And the ping timeout is rediculious on my laptop. So somewhere in the tethering configuration I'm losing a LOT of bandwidth. Here are the results (average out of 5 runs)

    Speedtest app on the Desire
    Ping: 130ms
    Down: 1.8 Mb/s
    Up: 0.4 Mb/s

    Speedtest.net - The Global Broadband Speed Test on my Windows 7 laptop
    Ping: 660ms
    Down: 0.6 Mb/s
    Up: 0.4 Mb/s

    I had a subscription with Vodafone before this one with an unlimited dataplan included, together with a HTC Touch Dual (WM 6.1), but then I didn't have this problem at all. And the ping was around 130ms on my laptop as wel.

    So is it because of Android? Or is there something going on at Vodafone where they squeeze the bandwidth when I tether? Please help, because it's a pain to internet with these figures.


    ====================== UPDATE ======================
    I found this article about the horrible ping results, it has something to do with the way Windows 7 handles your network traffic!

    SOLUTION: Run windows command as administrator and type:
    netsh interface tcp set global autotuning=disabled


    Also, if you use NOD32, the HTTP port checking can make your bandwidth go down a lot and your ping latency trough the roof!

    SOLUTION: Change config in Nod32. Go to Advanced setup.. -> Antivirus and antispyware -> Web access protection -> HTTP, HTTPS and uncheck "Enable HTTP checking".

    So that is fixable, but the slow bandwidth still bothers me.
     

    Advertisement

Share This Page

Loading...