SMS backup won't work after latest system update (Galaxy S2 Sprint)Support


  1. chewedpup

    chewedpup Well-Known Member

    I was using SMS backup very happily on my galaxy S2 (sprint) - worked like a charm, saving all my text messages to my gmail account. however, since the recent system updates, the app I had crashed every time I tried to open it. I tried about three OTHER apps for SMS backup - and they ALL crash. ONLY since the update - I have tried emailing the developers but no responses yet - and I have texts I need to backup to my gmail account.
    I have uninstalled and reinstalled the app but it makes no difference - if I try to do a backup, the screen goes black, and about 10 seconds later I'll get an error message.
    Any ideas? I have not done anything else to my phone except accept the update - if this can't be fixed, does anyone know a good app whereby i can backup my text messages/sms? To my gmail account?
    Thank you~!

    Advertisement
  2. itsallgood

    itsallgood Well-Known Member

    Your statement wasn't clear, but did you uninstall and reinstall the app? You might want to look into backing up to SD card, the apk's for all your apps. This way, when you receive a bad update, you can revert back to the last update before the current update with the problem. I use "AppSaver" and it works really well and I have done what I advised you to do.
    chewedpup likes this.
  3. chewedpup

    chewedpup Well-Known Member

    Thanks - I particularly like having it backup to gmail because I can then access the text messages any time - but if I can't find another app that works, I will try yours. Thank you! And yes, I did uninstall and reinstall (a couple of times) but it made no difference. Also, it didn't matter which app I tried to use for sms backup (there were a few different ones by different developers), they ALL crash now :-(
  4. CodeMonkey

    CodeMonkey Well-Known Member

    Try SMSBackup+. It's never crashed for me across a variety of Android versions.
    chewedpup likes this.
  5. chewedpup

    chewedpup Well-Known Member

    Package file invalid.... this happens now with all the sms backup apps I try to download. help :-( this ONLY happened since the system update..... Screenshot_2012-09-14-20-47.jpg

    I have tried the following apps: I get the package file invalid on all of them. something somewhere is conflicting with all of these...... again, I made absolutely no changes to my phone - I only agreed to update the system update (which it kept reminding me every few minutes so I kind of had to)


    SMS backup and restore (Ritesh Sahu)
    SMS Backup + (Jan Berkel)
    SMS backup (Christopher Studer)
    GO SMS Pro (Go Dev Team)
    SMS Backup (Gmail) Wooboo - this downloads but when I try to do a backup I get an error message saying Unfortunately SMS backup has stopped.

    don't know what to do :-(
  6. DonB

    DonB ♡ Spidey Sense !! ♡ ™ Moderator

    If all SMS apps are doing the same, then is it most likely an issue as you mentioned with the latest OTA you took for your phone. I know this might not be what you want to hear, but here you go, if the developer is not responding and others are not having this issue with the same OTA update, and you have not got any other advice then what you got to date, I am going to suggest to do a Factory Reset, that is always a good thing to do anyways when you do an OTA, 8 out of 10 times usually resolves most issues.. I will check in the staff section to see if there are any SG II users there and have them look at this thread and see if they have any other options for you. ;)



    chewedpup, Granite1 and ocnbrze like this.
  7. DonB

    DonB ♡ Spidey Sense !! ♡ ™ Moderator

    FYI, change your device in your profile to SG II since you don't have the 3VO anymore, lol :D:p

    I also think this should be in the SG II device forum for proper support, I don't believe it is an app issue and more a phone issue, let me know if you wan me to move it.
  8. 9to5cynic

    9to5cynic Well-Known Member

    Hey chewedpup, from that pic you posted it looks like the issue is in the play store yes?

    If so, what if you clear data and cache associated with the play store? Does that help it at all? If that doesn't work (which I'm guessing that's not the issue), then I'd try to see if you can get the .apk file for one of these apps (SMS Backup and Restore is my favorite :p ) from their website. Maybe sideloading the official apk will work?

    If that either isn't possible or doesn't work,then I'm out of ideas, but this will at least hopefully narrow out some wrong suggestions....

    Good luck amigo!
  9. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    yeah what both don b and 9to5 have suggested is what i can only see as a fix. not sure what else it could be. maybe you are getting full in your phones internal memory?
    9to5cynic and DonB like this.
  10. chewedpup

    chewedpup Well-Known Member

    Hi there:
    Thanks to everyone who responded. I cleared the cache for Google Play - now I was able to download the app for SMS backup, but again, when I tried to use it, after putting in my user name and password, it crashed.

    Same with the others. It seems the apps download now (I haven't got a package is invalid error message yet) but when I click on backup, the screen goes black for about 10 seconds, then I get sorry SMS stopped working, report or OK. I always report, just so the developer knows.

    I am so reluctant to do a factory reset, it took me days to customize my phone - but it may be my only option..... I will wait a while, give the developers some time to get my emails - and if anything changes I will report it here.
  11. chewedpup

    chewedpup Well-Known Member

    You can do this? Move the whole posting somewhere else? If you think there is a better place to move it, then yes please! THANK YOU!!!!!!
  12. DonB

    DonB ♡ Spidey Sense !! ♡ ™ Moderator

    OK I will move it to the SG II section, or Epic Touch which is the same I am told, and wait a few days and see what other says before you do a FR. ;)



    chewedpup likes this.
  13. chewedpup

    chewedpup Well-Known Member

    Spent the whole morning trying to install any of the SMS backup apps, focused on + above as lots of people said that it worked for them when other apps didn't. This kept on failing (package file is invalid) - but after about 8 attempts, it suddenly installed. I put in username and password and it kept crashing over and over again. Finally, for no apparent reason, it suddenly opened up and allowed me to do a backup. So I have ONE app that does work, after days of nothing working. So, SMS Backup+ is now working - I have tested it and texts are backing up to my gmail account. PHEW! Just wish I knew why it suddenly worked. I did nothing different.


    however, ALL the other sms backup apps still do not work - they either cannot download (package file invalid) or else crash when trying to open them up. So there is still obviously some massive incompatibility problem that occurred after the latest Galaxy S2 system update, but at least I have one that works, and my texts are backing up - so for me, the urgency is off - but I will still be interested to find out if anyone figures out a solution... THANK YOU TO EVERYONE WHO HELPED OUT.
    9to5cynic and DonB like this.
  14. DonB

    DonB ♡ Spidey Sense !! ♡ ™ Moderator

    Glad you got one app working, might be simply the update and the compatibility with the app, who knows, but maybe clearing cache and data in the market helped finally.o turn the phone off and leave it off for a minute or so to make sure everything shuts down, and then reboot, that will ensure all cache that you wiped is cleared. Lets see if others here have had this issue also now.
  15. 9to5cynic

    9to5cynic Well-Known Member

    Yeah, cool that it's working. :pepsi: all around!
  16. chewedpup

    chewedpup Well-Known Member

    I tried downloading an alarmclock app this morning, got the same error message above. I was using 4G to download it.
    I disabled that and tried hooking up to wifi and downloaded it easily - no error message at all. I don't have any settings on my phone that prevent downloading apps without a wifi hookup.
    I tried a few more apps on wifi - no problem. When I try with 3G or 4G, I get the error message. "Package file invalid" - even though I have great 4G signal and it seems to be downloading very easily until I get to the 100% and then it pops up with the error message. Doesn't happen with wifi. How bizarre. Sigh.....

Share This Page