1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

SMS messages wrong time order


  1. ItsMyDesire

    ItsMyDesire Member

    if someone sends me a message, then i send one back. sometimes my message is displayed before their message on the list?

    so.
    [me]
    [them]
    [them]

    instead of
    [them]
    [me]
    [them]

    i think this is due to the timestamp on the 3rd parties phone being a minute or so out.

    anyway to fix this ?

    Advertisement
    :
    ulysses4ever likes this.
  2. Jackco

    Jackco Well-Known Member

    The time difference is on the network...I have the same problem on the galaxy S
  3. richcowell

    richcowell Well-Known Member

    I also get this... and it's a nuisance! The only way I've found to resolve it is to leave it a bit longer before you reply...
  4. Jackco

    Jackco Well-Known Member

    how much longer do you wait? I got a 5 hrs difference... :(

    The difference is set on the time zone...

    Somehow the phone cannot get the sender's SMS time along with timezone and I guess it resets it to +0 GMT
  5. richcowell

    richcowell Well-Known Member

    I guess people might get a bit annoyed if you wait for 5 hours to reply to every text lol...

    Have you looked at the other Messaging apps? Handcent maybe? I've never used any of them myself, but it might order them differently...
    Handcent sms HomePage --sms plus software for android
  6. DesireMe

    DesireMe Well-Known Member

    I notice this as well. When i reply immediately to a SMS, my reply goes before the one i received. Bit annoying, especially when reading it back. All-singing, all-dancing phone and there's just some simple things that are wrong.

    Admittedly, i've not tried Handcent/Chomp as apart from that, i really like the standard SMS.
  7. Rogue

    Rogue Well-Known Member

    Turning off the Automatic time helps.
  8. DesireMe

    DesireMe Well-Known Member

    Can you ellaborate? :confused:
  9. StoneDeCroze

    StoneDeCroze Well-Known Member

    The only time I have this issue is when the other person has an Apple product, which as the wife's just got an iPhone 4 is a real pain. SMS Time Fix app sorted it.
  10. DesireMe

    DesireMe Well-Known Member

    Seems to lag my SMS app quite a lot. Think i'll live with the problems.
  11. OZZlE

    OZZlE Member

    This was never an issue for me untill last week, coinsidence? I don't know, but it seems like it doesn't matter from what network the sender is texting.. (I have Not changed operator)

    Usually I send my friend a SMS and then his/her reply is said to have came before I sent my text... ^^ which is kind of insane.. It's very confusing looking in old conversations, sort of like Jeopardy.. You see the answers before the question :p
  12. INJECT

    INJECT New Member

    im getting this problem too, and its very annoying. Only started happening after updating to Froyo.
  13. cracckhead

    cracckhead New Member

    Handcent SMS solves the problem. But i'd like to stick with original messaging editor on desire so as far as that is concerned, the problem still persists.
  14. richcowell

    richcowell Well-Known Member

    The only thing I can see is that it uses the network stamped time for incoming messages, but uses the phone's local time for outgoing messages...

    When I'm texting a lot I try to be conscious of it and leave it a 30-60 seconds before I reply... it doesn't always work out like that though! lol
  15. DesireMe

    DesireMe Well-Known Member

    There is a thread about this, where it explains to knock on the time a little. Anyway, i did whatever it said and it fixed the problem permanently. An alternative is Go SMS.
  16. richcowell

    richcowell Well-Known Member

    If you knock on the time, it will no longer be set to get the time from the network, and I would assume no longer correct automatically for DST?

    Following the iPhone alarm cock up during the DST change last year, I'm not prepared to take that risk lol
  17. d.chatten

    d.chatten Well-Known Member

    Try this, it worked on my Desire, disable automatic time and set the time one or two minutes slow, back out back to the home screen (you may not even need to go back to the home screen), now go back and enable automatic time, the time should now be correct and the sms order should be fixed on new sms's, till the next time that is.
  18. xeroemose

    xeroemose New Member

    Use SMS Time Fix by Matthew Precious, free on android market.... Worked for my sensation!!
  19. danniswave

    danniswave Member

    What exactly caused this?
  20. ulysses4ever

    ulysses4ever New Member

    Have exactly the same problem with my Desire S. Very annoying. Seek for solution.
  21. Heroyoulook

    Heroyoulook New Member

    Setting>Date and Time>Automatic (Use network-provided values)

    Not sure this will help anyone but it did for me. :cool:
Loading...

Share This Page