1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!
  2. All attachments uploaded on the first day of this new look need to be re-uploaded, or will appear broken. All prior to that, and all going forward, should work fine. We apologize for the inconvenience!

Support SMS not Showing in Default Message App (Using Google Voice)


  1. sumgi

    sumgi Member

    New Android user here, I've used a webOS phone for the past 2 years and finally decided to jump ship. It's a little different working with all the available options where as webOS often only had a single default application for Email or Messaging Android may have several.

    I've installed google's voice application, I actually used voice with my webOS phone however there was no native application. So all my voicemail has always been on the voice web site however I'm seeing this strange new behavior after installing the android app. My sms replies are showing in the voice app and not in the default message app. So I will send a text message out of the default app but the reply shows up in voice. I have recieved sms messages in the default app before but after installing voice last night they are showing in that application.

    I would rather see all my messages in one place, how do I receive my text messages in the default app?

    SOLUTION

    EDIT: Solution - I found the solution to this on the google voice forums. I am now receiving messages in both the default application and in voice.

    Phone not receiving SMS - Google Voice Help

    EDIT2: Single SMS notification(Only use if you have a text message plan) - I'm sure this is obvious, and most people are probably going to use the voice application for SMS anyway...however if you are going to use the default app for text messaging and only want to get a single notification this is what I did.

    In voice go to the menu | more | settings | sync and notifications

    1. Text Messages ( Notify via Text message ) is turned on
    2. Inbox Notifications ( Notify in Status Bar ..) is turned off

    Now you will only get text messages notifications for each voicemail in addition to the regular SMS and MMS messages.


    Not every sms I receive shows in voice and any sms I send from the voice app does not show in the default app...so only if I use the default app for all messaging would I get all my text messages in one place. Hopefully they will add MMS to voice one day but until then I'll just use the default app.

    Advertisement
  2. sumgi

    sumgi Member

    Update: Apparently MMS with pictures go to the Default Message app and not to Voice, so if you are having a conversation and any messages have pictures they will not show up in the same thread on the voice app. That kind of sucks. I can not be the first one to have run into this but I have searched and do not see a thread on the subject.
  3. Emblazon

    Emblazon Well-Known Member

    I deactivated my Google Voice account precisely because of this. I really, really like the Sense 3.0 Messages app, and really don't like Google's. I would love to have visual voicemail, but not at the expense of not having all my texts in one location.

    It's a known issue, and I'm sure Google is working on implementing a feature to turn off Google Voice texting, but who knows when they will release it to the public.
  4. Doomstang

    Doomstang Well-Known Member

    I use Handcent and have Google Voice activated...I only get alerts/messages through Handcent with my setup. If I get a picture mail, it goes straight into Handcent. I had started out using the Google Voice app for texting but it wasn't the greatest so I switched back over to Handcent when the workaround was found through Voice.

    By far the greatest part of using Google Voice (IMO) is the ability to send/receive texts right through a Chrome add-on.
  5. lbhocky19

    lbhocky19 Well-Known Member

    it's an option. either go to settings in google voice app or do it online. you can have it not alert you when texts come into google voice and you can tell them to also go to your phones sms. it freaked me out at first too
    marctronixx likes this.
  6. chubbzdroid2

    chubbzdroid2 Member

    same here!!! it was truly irritating , i was not receiving no txt through handcent nor stock mess app , they were coming in all through google text right after installing google voice, i changed all setting to voicemail only , but it seems that there is no settings for google text ( unless i miss read somewhere). after the google voice took a shyt on me, i was unable to receive calls till today ( since today) i had to have sprint delete google voice account , now everything is back to normal 8) . very upsetting since google voice worked flawless on my droid 2 and never had google text ..8(
  7. sumgi

    sumgi Member

    The first post provides a solution near the bottom...this will allow you to receive visual voicemail in google voice as well as text messages in the default app. However if you follow my solution you will not receive a voicemail notification from the voice app but rather get a text message(in the default app) when ever you get voicemail.

Share This Page