SMTP addressing issue? not sure but....Support


Last Updated:

  1. barrym

    barrym Member This Topic's Starter

    Joined:
    Oct 19, 2010
    Messages:
    19
    Likes Received:
    0
    Hi,

    New in here, I've asked this q on the 'offical' HTC site but no worthwhile reply. I've looked through the other smtp threads on here also, but didn't see anything that seemed to fit.

    I have a Desire and I use it over a wifi link in my home, fine for surfing and reading mail, but when I try to set up an outgoing mail a/c on my 'usual' mail a/c I run into a problem.

    Because I travel a lot I use a service called authsmtp to provide me with an smtp address wherever I am, works fine, annual fee is low (not a recommendation, works for me).

    However, in order to work it needs an smtp address of the form mail.authsmtp.com and a password.

    I can enter the mail.authsmtp.com ok but it always says it cannot check the a/c. Is this 'cos it cannot check the smtp or is it something else? All the other data seems to be ok, afaics.

    TIA for help.

    Barry, in France
     

    Advertisement
  2. Griff_LI

    Griff_LI Well-Known Member

    Joined:
    Jul 11, 2010
    Messages:
    371
    Likes Received:
    52
  3. Cougar

    Cougar Well-Known Member

    Joined:
    Aug 28, 2009
    Messages:
    420
    Likes Received:
    16
    You're trying to use a 'foreign' SMTP server, so it'll reject you as it doesn't know who you are.

    You either need to use the SMTP server provided by your phone's service provider for outbound email (so that's O2, Orange or whoever), or, you need to use an authenticated and / or encrypted connection to your email server.

    Settings will vary between services and I don't have settings to hand, but that's the gist of what you need to do.
     
  4. Cougar

    Cougar Well-Known Member

    Joined:
    Aug 28, 2009
    Messages:
    420
    Likes Received:
    16
    Reading Griff's link, that's essentially the section option I suggested. The "require sign-in" is the authentication step.
     
  5. barrym

    barrym Member This Topic's Starter

    Joined:
    Oct 19, 2010
    Messages:
    19
    Likes Received:
    0
    Nope, well, to be clear, I dion't have quite the same thing - I don't have an 'email' on my apps page but using 'mail and settings gets me to almost ther same place, but I don't get quite the same sequence, i.e. no 'require sign in' option. What happens is -

    Enter mail address
    protocol pop
    user name > next > verifying
    requires login is clicked and password next >
    verifying - long time .....
    "cannot connect to the mail server to verify your account. Your server is not responding OK/ continue" >
    Finsih setup....

    But no mails go.

    I've checked with the mail supplier and I can login there with the name/passsw combination I've entered.

    Not sure what server? I assumed it was pop, but why?? Then I thought about the smtp thing....

    Confused
     
  6. Griff_LI

    Griff_LI Well-Known Member

    Joined:
    Jul 11, 2010
    Messages:
    371
    Likes Received:
    52
    You're not the only one. You say:

    "requires login is clicked and password next > "

    But what about the rest of the setttings ?

    Login required - should tick
    username and password should be your authSMTP ones
    SMTP server should be mail.authsmtp.com
    Security time should be none
    Server Port should be 2525

    This final setting is weird - I've never seen SMTP running on that port. SMTP is normally port 25, different security systems employ other ports but it seems authSMTP use 2525. If you don't set these up as above it won't be able to connect to the authSMTP server.
     
  7. barrym

    barrym Member This Topic's Starter

    Joined:
    Oct 19, 2010
    Messages:
    19
    Likes Received:
    0
    It seems that I'm not getting the message as a result of the smtp (authsmtp) input, cos I've been getting "warning Authentication failed Please verify your username/password" and OK....

    Yes, authsmtp uses 2525 - they introduced it a while back when there were issues around the 'anonymous' nature of authsmtp whioch caused problems with some super sensitive isps. Note that you can use 25, 35, etc.

    To go back to the original sequence -

    I go to mail > menu > more > settings >account settings

    first step name@...... > next
    protocol > pop > email address . xxx@yyy.zzz . user name aaa.bbbb > next
    > verifying account information >

    login required is ticked on next page above user name then password > next
    smtp server mail.authsmtp.com > next

    Then it says it is verifying and come up with the message I gave in the previous post.........

    That is why I am confused whether it is smtp or the original pop which is causing the problem.

    Thanks for the help.
     
  8. Griff_LI

    Griff_LI Well-Known Member

    Joined:
    Jul 11, 2010
    Messages:
    371
    Likes Received:
    52
    This is where I'm confused. That page also has the security and port settings on it. Are you setting them up ? If you are (as prescribed) then it's a problem for authSMTP as they're not recognising their own settings.
     
  9. Cougar

    Cougar Well-Known Member

    Joined:
    Aug 28, 2009
    Messages:
    420
    Likes Received:
    16
    "protocol pop"

    Not SMTP then? POP3 is for receiving email, SMTP is sending. Either that setting is wrong or you're looking at the wrong screen (or I'm misreading what you're sending).

    I've not actually set up an email account manually on the Android platform so I'm not sure exactly how it words it.

    Just to confirm, you can receive email fine, just not send, yes?
     
  10. Griff_LI

    Griff_LI Well-Known Member

    Joined:
    Jul 11, 2010
    Messages:
    371
    Likes Received:
    52
    Cougar that's Barry being misleading (it had me for a while too). The pop server verifies - hence it goes onto "requires login is clicked and password next >"
     
  11. Cougar

    Cougar Well-Known Member

    Joined:
    Aug 28, 2009
    Messages:
    420
    Likes Received:
    16
    Try using your phone service provider's SMTP server rather than authsmtp's.
     
  12. barrym

    barrym Member This Topic's Starter

    Joined:
    Oct 19, 2010
    Messages:
    19
    Likes Received:
    0
    Thanks, thought of that, but authsmtp works fine if I use my mail over the same isp from my laptop, I never have to change the outgoing mail server when I move about, that's the benefit of authsmtp. I'm alwys using 'foreign' servers.....
     
  13. Cougar

    Cougar Well-Known Member

    Joined:
    Aug 28, 2009
    Messages:
    420
    Likes Received:
    16
    "The pop server verifies"

    Yep - I can see that now with the posted clarification. Ignore that comment. (-:
     
  14. Cougar

    Cougar Well-Known Member

    Joined:
    Aug 28, 2009
    Messages:
    420
    Likes Received:
    16
    ... on your phone?!

    *shrugs* I guess "I want my email to work" and "I want authSMTP to work" are subtly different questions. (-:
     
  15. Cougar

    Cougar Well-Known Member

    Joined:
    Aug 28, 2009
    Messages:
    420
    Likes Received:
    16
    Just had a quick look at my Mail applet. It runs a wizard that sounds like you describe; however, if instead of clicking 'next' on the first screen I select 'manual setup', it takes me through screens that look like the ones on the linked instructions.
     
  16. Griff_LI

    Griff_LI Well-Known Member

    Joined:
    Jul 11, 2010
    Messages:
    371
    Likes Received:
    52
    I'm sure (if it has previously worked) that it will work on the Desire (it's not that complicated). But you need to set it up as I described, if you do and it doesn't work it's authSMTP's problem.

    The settings you describe:

    "login required is ticked on next page above user name then password > next
    smtp server mail.authsmtp.com > next"

    Is only half of that page of the mail setup...
     
  17. barrym

    barrym Member This Topic's Starter

    Joined:
    Oct 19, 2010
    Messages:
    19
    Likes Received:
    0
    To try to reply to all the (very helpful) suggestions.

    I gave the sequence as it appears - the requires login ticked box appears after I say 'next' at the pop page - I appreciate the pop is the incoming.

    What is confusing me is that ticked box - I have assumed it is to say my pop server requires a login, it does, and I've entered the right username/password combination. The really confusing bit is the sometimes message saying it cannot verify that and says I must check the combination....

    However, there is no 'drop dead' message after that it allows me to go ahead with the smtp input and then the long delay of verification and the mail server not responding message. That was when I began to wonder about smtp.

    As I said earlier I checked the name/passw combination on the mail servers site. If I use the 'native' isp's outgoing here it isn't the same as my usual email address, if you understand. I have mails from this local isp forwarded to another one (my usual one) [still with me ;)]. I Use authsmtp as a universal outgoing and it has worked fine up to now, android time.....

    Thanks again for all the concerns.

    Barry
     
  18. Griff_LI

    Griff_LI Well-Known Member

    Joined:
    Jul 11, 2010
    Messages:
    371
    Likes Received:
    52
    I'm really not sure what you're asking there.

    When you set the Incoming (pop) settings and hit next the phone will attempt to connect to the POP3 server, if it succeeds it moves onto the outgoing (SMTP) settings. If it's not complaining at that stage the POP settings are fine.

    When you set the outgoing settings and hit next the phone tries to connect to your SMTP server with the settings you just provided. If it reports an error here the settings are wrong. You've never mentioned setting the security protocol or port - are you setting these as authSMTP want ?
     
  19. barrym

    barrym Member This Topic's Starter

    Joined:
    Oct 19, 2010
    Messages:
    19
    Likes Received:
    0
    Just to clarify, again. I'm trying to set up a 'reply' mail for use via wifi here in this location in France. I am not trying to set up anything on my 'roaming' telephone, I have a fundamental objection to paying the ripoff rates they want for dongleing.....;). Anyway, giving the probs I'm having setting up a plain vanilla mail, I'll need to lie down in a darkened room if I want to use the phone a/c......

    Barry

    Actually, I am now wondering how the mails reach me.... ho-hum.
     
  20. barrym

    barrym Member This Topic's Starter

    Joined:
    Oct 19, 2010
    Messages:
    19
    Likes Received:
    0
    Yea, that is the sequence. However, as I said, it doesn't always say it cannot verify the pop, it comes back with the 'requires login' box and then the user name and password boxes. Other times it says it cannot verify but allows me to continue to the smtp etc steps....

    So, where is the problem??

    In addition, I don't get the sequence that authsmtp are suggesting. I did see somewhere here an issue with items missing on the apps page (market for example) since the upgrade on Sunday. Did I have an 'email' app before, don't remember.
     
  21. Griff_LI

    Griff_LI Well-Known Member

    Joined:
    Jul 11, 2010
    Messages:
    371
    Likes Received:
    52
    So the POP settings sometimes work and sometimes don't ? This is a whole different issue, get them working fully (with the instructions from your ISP). Once that's good THEN worry about the SMTP settings. Make sure you're scrolling the set-up pages all the way to the bottom as they all have more settings than you've said you're setting-up.

    I'm afraid that's all I can suggest. Good luck!
     
  22. barrym

    barrym Member This Topic's Starter

    Joined:
    Oct 19, 2010
    Messages:
    19
    Likes Received:
    0
    Looks like it, doesn't it? I have checked the settings both by going to the mail server suppliers site and logging in to their webmail and getting to my mail, and it works just fine off thunderbird on my laptop. To prove that I get mails on the HTC and read them and then get them again off the server, answer the ones I need and dump or file the rest, on my laptop.

    Thanks, I'll just stay confused, for now.
     
  23. Cougar

    Cougar Well-Known Member

    Joined:
    Aug 28, 2009
    Messages:
    420
    Likes Received:
    16
    "If I use the 'native' isp's outgoing here it isn't the same as my usual email address, if you understand."

    That's not how it works. Your 'sender' address and the address you use to authenticate to an SMTP server are two distinct things. Once you've authenticated to the outgoing email server, you could set your sender address as spock@vulcan.com for all the SMTP server cares.
     
  24. Cougar

    Cougar Well-Known Member

    Joined:
    Aug 28, 2009
    Messages:
    420
    Likes Received:
    16
    Incidentally,

    Have you considered webmail? (-:
     
  25. chrisnotton

    chrisnotton Active Member

    Joined:
    Jun 16, 2010
    Messages:
    27
    Likes Received:
    5
    It works o.k. for me I use several different incoming pop accounts but only one smtp outgoing service for all of them. It is accessed with a username & password. The phone goes away & checks (pings?) the pop & smtp every time I set up an account. I suggest that maybe your smtp provider is not answering the ping.

    Why not set up the account with another smtp & see if you can subsequently edit the settings to use your paid for smtp? I suspect you will have tried this!

    Pip pip
     

Share This Page

Loading...