So I may have solved my battery drain issue...Tips

Last Updated:

  1. Trooper

    Trooper Well-Known Member

    Indeed. I have my phone off already and charging for the night. Will look at this thread over the next few days. If it seems to help, I will turn it off on my phone as well.

  2. Callahan

    Callahan Well-Known Member

    I thought they were extinct.
  3. MrGoodCat

    MrGoodCat Well-Known Member

    not trying to be rude, but i am assuming a lot of users here aren't used to smart phones? the first thing i did when i got this phone was find the data off switch. having data constantly run is useless. the os should be able to pull data when it needs it, not constantly leave it on. i am glad you all found this though. i can guarantee it will improve battery life. i'd also recommend a task manager (like advanced task killer). i thought you weren't supposed to have one with android, but it really does help. i installed it only to find about 130mb of ram being hogged when i was doing absolutely nothing on the phone. android is supposedly to kill tasks on its own, but all of em had been running throughout the night, so much for that theory (unless i missed some setting...i am new to android as well)

    anywho, yes, disabling constant data connection will greatly increase batt life, and adding a task killer to free up ram will help as well
    lordkaosny likes this.
  4. w0rdie

    w0rdie Well-Known Member

    You should read up on how the Android architecture differs from what you're used to using. Programs running in the memory aren't the issue. Do a little research.
  5. jonhapimp

    jonhapimp Well-Known Member

    Read the eris thread somebody linked too it pretty much answered ny question you may have
  6. jonhapimp

    jonhapimp Well-Known Member

    yeah there not i'm actually surprised how little the apps i left open are running they go into a standby mode were they barely use any resources and the only reason i know this is because of a task manager
  7. jonhapimp

    jonhapimp Well-Known Member

    This should be sticked
  8. Adamx

    Adamx Well-Known Member

    That depends on the app. Any app that syncs data should be killed or removed unless you want it to sync. The syncing that happens even while the phone is asleep drains battery.
  9. SecretSexyNinja

    SecretSexyNinja Well-Known Member

    Sweet, I am trying this as well. Will report back like the rest of the troops! :p
  10. w0rdie

    w0rdie Well-Known Member

    Which would make the sync requests the issue... not the fact that they're occupying memory.
  11. wonderbread

    wonderbread Well-Known Member

    I'm going to try this out too even though I don't have any major complaints about battery.

    If anyone noticed any lack of data updates, etc, please report them.
  12. load97

    load97 Well-Known Member

  13. MrBaseball

    MrBaseball Member

    I have been having terrible battery life. I'm going to give this a shot will report back tomorrow.
  14. patkicks10

    patkicks10 Well-Known Member

    hm... maybe thats why i had upward to 3 gigs of logged data on

    was hardly even using the data... nice find op.
  15. tats_06

    tats_06 Well-Known Member

    The setting was there on Eris as well. But in my case, my battery is pretty good. I have location off, this setting disabled and I got 15+ hours battery. I am happy, although will still buy the extended...The issue is not poor battery life, but that 1300 mah is not enough for this powerful of a phone. ;)
  16. Todd M

    Todd M Well-Known Member

    Great find.

    I did what the OP suggested, but unfortunately for me, this did not help my battery drain. I think the 1300 is just too small of a battery for this thing. I have turned alot of stuff off, and I feel that now I just have a Storm in a new cover.

    I will HAVE to get the 2150. I don't want a Storm in a shiny new cover. I want a phone that I can do all of the things I want it to do (with still being responsible with all of the bells and whitsles) without having to shut everything down so the battery will last! :rolleyes:

    Then again, I might have a defective battery. This thing drains fast and charges fast. I have done all of the other things in all of the other threads to try and squeeze life out of it. It's draining 50%-70% overnight...
  17. slumpey

    slumpey Well-Known Member

    so this on another thread will this work with saving battery life. What does it do exactly.

    Menu > Settings > Wireless & Networks > Mobile Networks (second one) > Enable Always-On -- checked by default, I unchecked it.
  18. thegrumpyyoungman

    thegrumpyyoungman New Member

    i just unchecked it....does anyone know if this interferes with google voice sms notifications? im willing to bet it doesnt just from reading the posts in this thread. we'll see.
  19. Dex

    Dex Well-Known Member

    Gimme a GVoice invite and I'll let you know. =P
    dbgoolsby likes this.
  20. nate3382

    nate3382 Member

    Just turned mine off also, Really hope this works like everyone is saying since the battery dies every 6 hours for me
  21. Todd M

    Todd M Well-Known Member

    Ummm, this was in the first post of this thread. That's what this thread is about! :rolleyes:
  22. alamoe

    alamoe Well-Known Member

    I don't understand the reasoning behind putting a smaller battery in the INC than the one in the N1. I'm pretty sure SenseUI is a bigger battery drain than stock Android
  23. FunkyBoss

    FunkyBoss Well-Known Member

    I too have had terrible battery life, dies by 5pm when 100% at around 7am. Moderate usage. Giving this a try today!
  24. slbailey1

    slbailey1 Well-Known Member

    More MONEY for Verizon.
  25. garment69

    garment69 Well-Known Member

    Did this last night. I have not noticed any significant improvement.

Share This Page