SO worried in case ive bricked my phone

Last Updated:


    GEMINIH Member

    Hi, i am a complete novice when it comes to anything technical which makes my situation even more ridiculous, i have just stupidly rooted my Samsung Galaxy S2 GT-19100 then i panicked in case i had voided the warranty and tried to unroot by pressing RESET in the SETTINGS on my phone now my phone is stuck on the boot screen with a yellow triangle and an exclamation mark then it goes to the big S logo screen and plays the little start up tune but then freezes, i cannot get past this logo screen, i tried the rooting procedure again but its still stuck. Please please help if you can i feel sick, shoulsd never have rooted in the first place.

  2. Slug

    Slug Check six! Moderator

    Are you sure it freezes? If you've performed a factory reset the initial reboot afterwards can take several minutes.

    If it remains like this for more than say 5mins, pull the battery to power off, then hold VOL_UP+HOME+POWER until you boot into recovery mode. Now select "Wipe dalvik cache" (usually in Advanced), "Wipe cache" and "Wipe data"; this should allow you to then reboot normally.

    Note that the handset will remain rooted unless you reflash a stock unrooted kernel or an official firmware package.

    GEMINIH Member

    Hi many thanks for your reply, i have done what you suggested but unfortunately it is still stuck on the logo screen is there anything else that i can try i am desperate to get my phone working again as there is no way i can afford to buy a new one. Many Thanks

    GEMINIH Member

    Hi again i also meant to ask how do i reflash a stock unrooted kernal or an official firmware package , my phone version is as follows PDA...19100XWLPT, PHONE....19100XXLQ6....CSC...19100XEULPA. Build Info: Fri July 27th 2012 KST , My phone was running Ice Cream Sandwich version of Android Firmware, all i want to do is unroot my phone and reinstall Ice Cream Sandwich firmware. Please help if you can. Many Thanks.
  5. ironass

    ironass Well-Known Member

    I hope Slug doesn't mind me butting in... I know he's busy.

    Download the firmware, here:- One click file hosting:

    and flash it via Odin, using the instructions and video under the heading, "My firmware is not eligible for ICS yet but I want it now!", in post #1, here.

    This will install the official XEULPA firmware with un-rooted kernel.

    GEMINIH Member

    Hi, Thank you so much for your reply, i have downloaded the file but now i cannot open it, its saying that it is an MD5 file and winzip or 7zip will not open it, sorry for being such a pain but can you help again please. Many Thanks.
  7. ironass

    ironass Well-Known Member

    You should not need to extract it. Just navigate to it from PDA in Odin.

    GEMINIH Member

    Hi, Thank you so much for your reply, can you please explain to me in lay mans terms how do i navigate the file from PDA in Odin, also i have realized that i did not enable USB debugging before i tried to root my phone and also my phone will no longer connect to Kies, i probably sound very stupid but i am definately learning my lesson now. Please help if you can. Many Thanks.
  9. ironass

    ironass Well-Known Member

    First and foremost. my bad, here in post #7...

    You do need to extract the file from SamMobile (I was confused as I'd been dealing with a kernel previously)...

    7-Zip (or similar... WinRAR or WinZip) to extract the .zip files on your PC. Download, here.

    Download the .zip file to your desktop and unzip it, (To extract the file, just right click on it and select 7-Zip/WinRAR/Winzip and, "Extract here". This extracted file is the one you will need.). This is the .tar file. Place this file on your computer Home screen

    Click on the PDA button in Odin and select DeskTop and the file that you previously extracted. Do not have Kies running at the same time.

    Before you can do any of the above you need to make sure that you can connect to Kies and Odin first. There is an excellent post by Hawker, entitled, "Advanced steps to take for Kies connection problems", that will walk you through the steps you need to take.

    If the worst comes to the worst, you will have to try it on another PC.

    Should you be unsure, after carefully reading the instructions and watching the flashing video, then please ask as I am sure someone will be able to help you.

    GEMINIH Member

    Hi, Thank you again for your help, Odin recognises my phone and installs clockwork recovery mode no problem, i get the green pass in the box so alls well with Odin, however Kies no longer recognises my phone and will not connect it, i just get the yellow triangle with exclamation mark on first screen and then it goes to the large S on the second screen and plays the samsung start up tune but then it just stays there on that second screen. Is it possible that i may have deleated ICS compleatly from my phone and thats why it stays stuck on the second screen.
  11. ironass

    ironass Well-Known Member

    As per post #2 of, "Rooting Galaxy S2 - Dummies Guide", wipe cache and dalvik and install Triangle Away.

    GEMINIH Member

    Hi, i have had a little success and been able to install a version of ICS on my phone but unfortunately there are still a few problems, firstlybefore i messed everything up my phone information was as follows...PDA:19100XWLPT, PHONE:19100XXLQ6, CSC:19100XEULPA, Build Info Fri July 27th 2012 KST, now with this other version installed it reads, PDA:19100XXLPH, PHONE:19100XXLPH, CSC:Unknown, Build Info Thu Feb 9th 2012 KST, Also when i go to Kies it recognises my phone but i get the following message, "Your devices current firmware version is not supported to update firmware via Kies" also another small thing iv'e noticed is the logo for Google Play is the old logo for Android Market,is there any way i can download and install the Official correct firmware for my phone so that everything works normally again. Many Many thanks for all your help and your time, you are an angel.
  13. ironass

    ironass Well-Known Member


    GEMINIH Member

    Yes i liked your firmware very much but i could not or should i say was unable with my very limited knowledge to get it to load with odin, it was out of sheer desperation that i tried this one that explained step by step how to load it onto odin, i must be doing something wrong when trying yours because all i am getting is unable to open this MD5 file, it will not open with winzip or 7zip and i do not know how to flash it straight to odin, i am so very very grateful for your help and your expertise if there is a way of explaining simply to me how to install it it would be a tremendous relief.
  15. ironass

    ironass Well-Known Member

    This is a video of the instructions I gave you in post #9...

    How To Unzip a Zipped Up File Using the Free 7 Zip Tool - YouTube

    Did you watch the video in the link I linked you to in post #5...

    This is a direct link to the instructions and video contained in the above link and shows you how, step-by-step, to load the extracted file using Odin...

    How to install Ice Cream Sandwich on your Samsung Galaxy S2 | Reviews | CNET UK

    DO NOT use the firmware file they show but use the one I linked to previously. You may need to re-download it again.

    Don't worry old son... if you get stuck, just tell me precisely what you are stuck on and we'll see if we can sort it out for you.

    P.S. WARNING: You get much friendlier answers after I've had my first 3 cups of double strength, black coffee. :coffee:

    GEMINIH Member

    Hi, good news at last, i followed your instructions and hey presto i now have the correct firmware back on my phone and everything seems to be back to normal. I cannot thank you enough for all the help you have given me, dont know what i would have done without your help, i will never mess around with rooting etc ever again, just two more questions and that is now that i have the official firmware installed will i receive official updates to my phone again and will my warranty be back in tact. Many thanks once again.
  17. SCPadgeebar

    SCPadgeebar Well-Known Member

    The answer to both of your questions is yes. :)
  18. ironass

    ironass Well-Known Member

    :congrats: Well done GEMINIH! Modesty prevents me from taking any credit for your success. ;)

    Compared to what you have just done, rooting is easy... honest! :pcguru:

    GEMINIH Member

    Hi its me again, hope you have had your coffee, i think i may have been bitten by the firmware update bug, is there an official samsung Jelly Bean firmware update for my sim free Galaxy S2, my phone information is as stated in post 12, I know Jelly Bean has started rolling out in the UK For the Galaxy S2 but every time i check for updates on my phone and through Kies it states that " No updates are available" Many Thanks once again.
  20. ironass

    ironass Well-Known Member

    Loads of mugs of Taylor's Rich Italian Roast... so you should be fine! ;)

    Your CSC code, as we now know, is, "XEU". As per post #2 of the, "Jelly Bean update - Dummies Guide", there is no JB update for that UK CSC code yet. In fact, the only UK JB update so far is for Vodafone, VOD, users.

    You could update by flashing a JB firmware for another CSC code as per post #1.7 of that link but to be honest, you might as well just root your phone and flash NEAT ROM LSJ.

Share This Page