SOD - Sleep of death - SGS2


  1. dramed

    dramed Well-Known Member

    Hi,

    Since around 2 months I started to get this issue in my SGS2. Gets into deep sleep and doesn't wake up on incoming calls or messages or by pressing any of the buttons. Only available option is to keep the Power button pressed for 10 sec to restart it.
    Strange thing, although it doesn't answer to any command the phone is connected to the network, people are calling and for them is ringing and no answer. But for me nothing showing and after restarting there is no log of the calls or messages received during this SOD stage.
    It doesn't happen everyday, like 1-2 times a week, but is very annoying to check continuously on your phone to be sure is still working.
    Anyone has any idea what it is or how to solve it? Tried to find a solution by searching forums, but nothing.

    thanks

    Advertisement
  2. Hawker

    Hawker Well-Known Member

    What kernel are you running?
    Are you undervolting?
  3. dramed

    dramed Well-Known Member

    Yesterday I flashed speedmod k3-24, to check it up and today i got the SOD.
    I happens even with Siyah and Cf-root. Changed 3-4 roms without result.
    No undervolting no extra settings. Whatever is coming by default with the kernel is in place.
    Drives me nuts.

    * Apps running: Juice defender, eCID, 3G Watchdog, Smart Stay Ex (late addition so no blame on his one).
  4. Hawker

    Hawker Well-Known Member

    Juice defender isn't recommended particularly. It can cause more drain that it saves.
    If you are on ICS you dont need 3g Watchdog, as this functionality is inherent in the OS.

    Try wiping cache+dalvik.
    Install Siyah 3.3.2 (3.3.3c is latest, but I know for a fact 3.3.2 is rock stable)
    Activate "battery" profile in ExTweaks (paid version) or CWM Recovery (non-paid)

    Then see how this setup fares.

    What firmware/ROM are you on by the way?
  5. dramed

    dramed Well-Known Member

    I'm using JD mostly to turn on and off WiFi & Data as my phone is connected to the company mail. Watchdog is just for keeping track of the usage, changing roms can`t keep record of the usage.

    Tried wiping cache&dalvik, no help. It happened with siyah 3.3.2 once, but i`ll give it one more try.

    I`m on NeatRom Lite 1.2, baseband LPX.

    Here 2 screenshots: Android Forums - dramed's Album: Screenshots
    one with phone infos & one where you can actually see the phone status & battery drop in the SOD state.
  6. sflannery07

    sflannery07 Well-Known Member

    Have you tried installing CPU Spy? Pretty sure it won't solve your problem but it might give you an indication of what's going on.
    dramed likes this.
  7. dramed

    dramed Well-Known Member

    I have CPU spy, unfortunately doesn`t help to much in this situation.After restarting the values are resetting.

    It seems that the phone just hangs itself in the deep sleep phase. Although if you see the screenshot i posted it shows that it is fully awake at that time.

    Puzzling...really
  8. sflannery07

    sflannery07 Well-Known Member

    Hmm, was hoping that you could see if the phone was running on the higher states. It's so sporadic that it might even be a hardware issue. Puzzling indeed, have you tried doing a factory reset. Do a nandroid backup first though. :dontknow:
  9. dramed

    dramed Well-Known Member

    Just got another SOD today.
    Same ROM: NeatRom Lite 1.2
    Kernel: Siyah 3.3.3c

    Really strange...
  10. Calvo1

    Calvo1 Well-Known Member

    I have had this problem myself....happily sitting in work thinking I had loads of battery left then it would crash and the battery would decline by a good 30%

    It seemed to me that this happened when I was putting my phone through its paces and multitasking. I changed my stock battery so that could be taken out of the equation.

    I don't know the solution but one thing that has helped me is using Jkay to select "long press back button to kill foreground app" I haven't had one since

    Just a suggestion
    dramed likes this.
  11. dramed

    dramed Well-Known Member

    I have Jkay d`Lux installed :), no help either.
    Actually looks like the problem is becoming worse. Last night I charged the phone, took it out of charger by 22:54 hrs. In the morning I woke up (luckily I got up before the alarm time) to find my phone on get on. tried to press Power btn for 10 sec, nothing. Plug it in charger, turned it on, battery 0% :(. In 7-8 hrs of supposed deep sleep my phone went from 100% to 0%.
    Might be the time to switch to a different brand or model if i cand solve this problem. :(
  12. cristianu

    cristianu Member

    I have the same problem. Can you hslpe me?
  13. dramed

    dramed Well-Known Member

    Can you give little more infos: kernel, android version..??
  14. mckocak

    mckocak New Member

    Same happens to me and it is unacceptable.

    This happened the first day I got my phone before even charging it. So it has nothing to do with later installed apps.

    Has anyone tried with a different battery to see if it is caused by the battery?

    As the screenshots show, there is a massive battery drop when this happens.

    I have a Galaxy s2, GT-I9100 Android version: 4.0.4 Kernel version: 3.0.15-1056084

    [​IMG]

    As you can see, it even happened twice in a day recently.

    I just want to know actually if this is a common problem for Android ICS and it will disappear after the Jelly Bean is out.

    OR if this is not happening to everyone, so I should send my phone or battery to service.
  15. ironass

    ironass Well-Known Member

    Hello and welcome to Android Forums mckocak! :)

    Yours is not a SOD, (Screen Of Death), problem but rather a battery calibration problem that is experienced by new, and old, users and those who flash ROM's.

    Battery calibration on the Samsung Galaxy S2 is automatic but you can reset it by following the guide, here. Then just give it a few charge cycles to settle down.
    mckocak likes this.
  16. mckocak

    mckocak New Member

    Thank you ironass! :)

    I will try it right now.
    Tough I am not sure, because I also get my screen closed, phone gives no response to any button, except when I press and hold the power button for around 10 seconds. (Or taking out and putting the battery back in) Then the phone is able to restart.

    And I didn't flash ROM. The phone is brand new, and it is confusing for me that when it is this new, making such a fatal problem. :-/

    I will try the battery calibration and let you guys know how it looks.

    Best,
  17. dramed

    dramed Well-Known Member

    Hi mckocak,

    I used to have exactly the same issues and yes after restarting the phone a drop of 15-25% in battery was always present. During few hours though I could see that the battery percentage was increasing like charging without the phone being plugged.
    Didn`t get to the roots of the problem, I just flashed a different version of NeatROM (LPI if i remember) and re-installed all the apps with titanium without the data. Problem solved.
  18. Hawker

    Hawker Well-Known Member

    It isnt a problem as such. Its one of the quirks of having a fuel gauge chip that never requires calibration (at least through software). However, it can lose track occasionally on a power off, whereby it will slowly creep back up to its true level when left idle.
  19. cristianu

    cristianu Member

    I think i solved. I have first 36 hours without sod.... i think android don't know to do battery calibration. And after manual calibration my s2 with jelly bean is moving like i never think...
  20. mckocak

    mckocak New Member

    Battery calibration did not solve the problem.
    And actually after the process, my battery is draining now definitely faster. It used to go 2 days with my use. Now it goes only 1. It think the process suggested by ironass on that forum only destroyed the calibration.

    So as the images show, it happened again.
    The screen going black and no buttons working.

    But I realize this has nothing to do with battery because when the phone blacked out I was listening to radio and it was working. When I tried to stop the audio from the headset button, then I realized the phone was not responding. So I restart.

    Bit now it happened in 1 hour 2 times and it is annoying as hell. I really do hope it is about android version and when finally the official jelly bean is out all will be solved.

    I don't want to flash a custom rom since the phone is not even 1 month since purchase.

    Maybe I just call samsung and ask what they can say about this? I mean, a steady working phone is the most basic thing that I expect from a big brand in 2012 for the money I pay.

    [​IMG]

    [​IMG]
  21. naith_kk

    naith_kk Well-Known Member

    @mckocak - Just wondering, did you ever attempted any Factory Reset with the device before using it?

    I had those issues you're experiencing eversince Gingerbread to ICS... and performing a complete factory reset (resetting firmware, erasing the built-in USB storage and even formatting the external SD card) after backing up all my data to my computer - especially after experiencing issues after upgrading to an official firmware using KIES seems to have solved many of the problems... I rarely get those issues anymore. (for your case, you may have not done any firmware upgrades, but the principal idea behind my suggestion is still valid, that you're ensuring the phone is reset to its brand-new state; reducing any glitches and errors - either by conflicting firmware settings or conflicting software applications installed)

    If you do decide to try and attempt doing this, I suggest you save most of your personal data using KIES (if its working) and begin noting down those free and paid apps that you've installed (together with their repurchasing/reinstallation policies in case you've purchased apps in the Google Play store) as KIES might not be saving those applications nor the data contained in them. You'll need to go to Google Play store once your phone is reset, and either re-download or repurchase/reinstall them and re-import your applications data (if the app has an export/import feature). The less apps/paid apps you have on your phone, the faster this procedure is.

    If this is all too much a hassle, then its best to wait for the upcoming JB official release and see if the next update does fix your issue.
  22. dramed

    dramed Well-Known Member

    The calibration process described by ironass and suggested to you by Hawker is working. I did it myself. As for your problem it might not be a battery issue as it wasn`t for me.
    Take naith_kk suggestion, save your personal data and do a factory restore (reset your phone to basic state). Don`t install any app from Google Play or from anywhere for about 2-4 days, try to keep& use only the apps installed by default and use your phone as a phone only, meaning that you`ll just have your contacts and other basic features; you`ll survive believe me :D.
    If nothing goes wrong during this time (no SOD), try to put back your apps one at a time (and again follow ironass & Hawker advises to restore only the apps without their data, in case you used a backup), and wait at least one day between installations. You`ll have to be patient if you wanna nail down the culprit.
    Good luck.
  23. cristianu

    cristianu Member

    So... after battery calibration... i have again same situation described in this pictures... maby i have to send the phone in warranty ?

    Attached Files:

  24. mckocak

    mckocak New Member

    Thanks for the advice guys,

    I can also try to factory reset but the thing is, the first day I had the phone out of its package, no apps installed at all, this issue happened.

    It happened again then in one week, where there were still no apps installed at all and the phone was just as it came out of factory. :-(
  25. cristianu

    cristianu Member

    I think is battery issue... after new year hollyday i'll send in warranty...

Share This Page