1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Soft-Bricked - What do boot options mean?Support


  1. Pikaro

    Pikaro Member

    Hi!

    I think I just bricked my phone... I was trying to upload an .apk of Tasks+ to the phone (no Warez stuff, but can't find it outside of Market and don't have a Google acc), when the install process froze (transmit worked). I tried it again with a different version, same problem, so I decided I would just try a reboot. Everything looked phine while the Motorola logo was displayed, it disappeared as usual, but then nothing came up; the screen stayed backlit, but black. adb was not able to connect to the device, and wiping the cache from Android Recovery didn't help.

    Now, I am presented with several choices at boot time, and unfortunately, I cannot find any explanation of what they mean. They are the following:

    Fastboot
    NvFlash
    BP HW Bypass RSD
    BP HW Bypass QC DLOAD
    BP HW Diag & Boot AP
    BP HW Bypass BP Only
    BP HW Bypass RSD
    Android Recovery
    Boot Android (No BP)
    Device UID
    console=tty50,115200n8
    Early Usb Enumeration
    BP tools
    RSD

    Can anyone explain what the acronyms stand for, and what each choice does? I found the choices mention quite a bit when searching, but they were never fully explained, and I fear I might brick the device even more. I could, of course, try resetting the thing to factory state, but as I just had it set up completely to my liking, that would be very unfortunate.

    Being given access to a console or a log would maybe suffice, if the latter can be read like a standard syslog. (BTW, can the phone use a syslog server?)

    Thanks for any advice!
    Pikaro

    Advertisement
    :
  2. rsevans64

    rsevans64 Well-Known Member

    di you try a batterry pull?
  3. Pikaro

    Pikaro Member

    Yes, of course. Also tried removing SIM and uSD. Nothing helped.
  4. Pikaro

    Pikaro Member

    Good news, everyone.

    I managed to access the phone with adb logcat (chose option "Early Usb Enumeration") and the phone told me:

    02-25 02:58:08.669 1541 1555 E PackageManager: Package com.iss.tasksplus has mismatched uid: 10186 on disk, 10002 in settings

    So looks like there was no major screwup. Unfortunately, adb uninstall says "Error: Could not access the Package Manager. Is the system running?". adb shell works, but I have no idea how to remove the packet manually.
  5. Pikaro

    Pikaro Member

    Same thing every time with me, I fight a problem for hours, then post to a message board, and half an hour later I solve it myself ^^ Just had to remove the .apk from /data, and hooray, everything worked out perfectly. Off to enjoy the forums now ^^ (And to find out how to get Tasks+ onto my phone...)
Loading...

Share This Page