softkeys randomly turn off or freak outSupport


Last Updated: 2012-09-12 22:32:22
  1. rigglemania

    rigglemania Well-Known Member

    Alright, so I've been having this problem on and off with every kernel/rom that I've tried for as long as I can remember, and I would say *probably* with the stock rom/kernel as well (though I don't recall for sure).

    It happens something like this - I hit one of the softkeys, and either the button lights turn of, or more annoyingly, they completely freak out and start blinking/flickering and become unresponsive. I have to hit the power/lock key to get them to stop. The frequency with which this occurs seems completely random, and there is no particular app or set of circumstances that I can reliably use to duplicate the issue consistently.

    It's not killing my phone or anything but jeebus christmas it's freaking annoying! Has anyone else experienced this? Anyone have any ideas on what the cause or fix might be?

    For the time being I've disabled lagfix and gone back to the adryn's 1212_test kernel posted with his DJ05 release here - http://forum.xda-developers.com/showthread.php?t=869990

    At the very least, it seems more resilient to the issue (aka no incidents so far, but I've only been back on it for 20 minutes)

    Advertisement
  2. saps

    saps Well-Known Member

    Sounds like a hardware problem if its been happening since you were stock
  3. NuclearEMP

    NuclearEMP New Member

    I don't think it is a hardware problem, the same thing is happening to me.

    I think it has to do with a bad google sync (bad app or something)

    If I use Odin and flash to DI01 I don't have the issue at all.

    Going back to EB01 (stock) at first boot I don't have the problem but after I sync with Google and a few reboots later the problem comes back.
  4. Leonard1818

    Leonard1818 Well-Known Member

    I just started having a similar issue today. Worked fine up through this morning but then I looked down and noticed that everything was still lit up (had sent a txt about 2 mins prior). It should have dimmed and shut the screen/ softkeys off on its own. So first thing, reboot. Upon reboot, it showed "safe mode" in the bottom left corner... hmmm... Battery pull. Upon reboot after battery pull, no longer "safe mode" but now seeing "problem loading widget" for many of my widgets. Uninstalled Launcher Pro... battery pull. Still "problem loading widget". I had been wanting to do a factory reset for a while so I decided to do that. Everything seems OK except now my bottom buttons (softkeys) seem to have the lights turning off randomly. I'll be browsint thru the settings and they'll turn off. They're responsive, as if I hit one, it comes back on, but they shouldn't be randomly turning off. Also, sometimes, they'll need a "double-press" to register. I will hit the "settings" softkey button (lower left) and it will blink, as if it knows it's been pressed, but it won't do anything and I'll have to hit it again.

    Hmmm... anyone else!?
  5. joshica

    joshica Well-Known Member

    I've had the same issue as the OP since I have gotten my phone. I had 2.1 and figured that when 2.2 came out it would fix the issue. I had to take my phone back to stock using Odin to update to 2.2 and when I did and loaded a few programs, I began to notice it again. I didn't have it with only the factory apps for long to report on whether it was doing it then or not but this phone is worthless if you can't load apps like any other phone. I thought it was a memory issue but I think it may just be a bad phone because not enough people report these issues. Verizon thinks I'm crazy when I call and have yet to offer me a new/refurbished phone.
  6. Leonard1818

    Leonard1818 Well-Known Member

    Yeah, I'm still trying to figure out if it's software or hardware. It very very rarely happens to me.

    I too flashed it back to stock using ODIN and I don't remember if it's happened since then. I think it usually happens when in phone mode (for me). Like if I'm actively on a call or someone is calling me.

    I really don't receive too many calls (ha ha)
  7. joshica

    joshica Well-Known Member

    Well.... I called Verizon last night and after an hour of talking to them, they agreed to send me another phone. They will be calling me in a few days to see if it is still happening.

    The tech wanted me to wipe the phone first but I explained that I did that already before I updated to 2.2. The problem is still happening. We'll see if that fixes the problem.
  8. Leonard1818

    Leonard1818 Well-Known Member

    keep us posted!
  9. joshica

    joshica Well-Known Member

    Got my new phone and everything seems to be alright. I have loaded most of the apps back on my phone and my buttons haven't freaked out once yet. No strange things happening either. I'm very pleased so far. If it happens again, I'll post but so far so good.
  10. jonsfoley

    jonsfoley New Member

    Anyone find a resolution to this? I am experiencing the same issue. Non-Rooted, no screen protector, cleaned the screen, have done a factory reset several times.. nothing works. Sometimes the phone will spasm (starting apps, vibrating, going home, etc) without anything touching the phone.

    Phone is 3 weeks out of warranty- 6 months until I can renew and get a new phone. Please help!!!

Share This Page