Solution to "SD CARD UNEXPECTEDLY REMOVED"


  1. andre1499

    andre1499 Member

    SOLUTION


    Some user experienced SD removed unexpectly after updating there phone so i made this thread. Commonly problem ito sa Galaxy Y.

    Step:

    1. ROOT your phone

    2. Install and open Root Explorer


    3. Edit files in the folder/ sys/devices/virtual/bdi/179: 0/read_ahead_kb by pressing and holding the read_ahead_kb then choose open in text editor.

    note: Other phones don't have 179:0.. but is ok 179:8


    4. Replace the numbers in it from the default (128KB) to 1024 / 2048 / 4096 (according to taste max = 4096) and then save and exit.



    3. read_ahead_kb Navigate the file again and select the permissions or hide tick marks on the User -> Write.

    Advertisement
    rsrluck, babouseif and viperbeam28 like this.
  2. paulvenson

    paulvenson Member


    i dont understand you did it. but can u explain it in a simple way? where to download that root explorer? PLSS. TNX
  3. viperbeam28

    viperbeam28 Member

    thnks for this info andre. Will do this now. hope it works ^^


    @Paul -- try searching it on google.. just type Root Explorer.apk on the google search bar. then download it :)
  4. viperbeam28

    viperbeam28 Member

    Hi andre,,

    Sadly i've done the steps you gave here.. but after saving it,, the file read_ahead_kb keeps on changing back to 128kb by itself. and the error keeps coming back.

    effective ba syo yang steps andre? Any tips?

    -rooted Samsung galaxy Y
    -used root explorer as you instructed. Edited the "read_ahead_kb" with 1024 and then i save and exits.
    -navigated again on the file "read_ahead_kb" and choose permission and i uncheck the box - "write".
    then i exit the root explorer. After sometime when my fone auto locks when i open the lock screen the error notification is back again. >.<


    I'll try SD Card Speed Boost (1.0).apk hope it will work.. T_T
    benshem likes this.
  5. draiyan

    draiyan Member

    updating to the newest version of gingerbread is the best solution..
  6. hakimann

    hakimann New Member

    I got the sd card problem since day one ...... everytime screen lock... the sd card error... its getting worse day by day....sometime my apps on the sd card undetected by the phone...>>> i want to update thru kies... but the galaxy wont connect... so i do the simplest solution found in this thread... format the sd card to FAT file system using windows... and copy back everything..... VOILA!!!!! Problem Solved forever!!!

    My Device: Galaxy Y - Gingerbread 2.3.6 Build DXKK1 ( SD Card Samsung 2GB Original)
  7. mmiranoc

    mmiranoc Member

    I've experiencing this problem but mine is actually rescanning the SD card when i unlock it.
  8. wasim0

    wasim0 Member

    After doing all this i still have the problem, the number keeps changing back to 128 even after unticking on WRITE ....can anyone please help
  9. skalka

    skalka Member

    Reformatting to FAT32 doesn't solve the problem for me.
  10. mmiranoc

    mmiranoc Member

    turn off phone when it is totally off

    press the volume up + the square button + open botton
    then choose wipe cache partition and wipe data/factory reset

    backup your messages, contacts, all applications and games before doing this because this will make the phone like brand new.
  11. varun.chitre15

    varun.chitre15 Well-Known Member Developer


    Before mentioning this you should warn the members that factory reset will erase everything
    I.e. messages, contacts, all applications and games and make the phone as new it was.
  12. mmiranoc

    mmiranoc Member


    ops sorry i edit it.
  13. antochakko

    antochakko Member

    Latest firmware update available in Kies for Indian users, DDKK1, Kernel version 2.6.35.7, Build # GINGERBREAD.DDKK1.

    I updated yesterday almost 24 hours now, now I am not having the problem of "SD card removed unexpectedly" after that update. Though we have to watch for some more time and hope this is a solution to the problem.
  14. skalka

    skalka Member

    Same version for italian users too, I'm upgrading now, I'll let you know if issue is solved or not.
  15. A70_Slave

    A70_Slave Member

    Hi antochakko...
    facing same problem....
    Mine is Kernel 2.6.35.7 but built is GB.DDKJ2...
    how to upgrade??
    pl. tell me in detail as i'm not good at these things....tell me step by step...i wil do...
    Thanks in adv.
  16. skalka

    skalka Member

    Kernel 2.6.35.7 root@DELL130#1
    Build GINGERBREAD.XXKK6

    Sd card issue seen again today :(
  17. rsrluck

    rsrluck New Member

    there is only one solution 4 the SD card problem.... just go to samsung service center and explain them the problem... they will do boot format and update the firmware.....
    mostly this problem occurs if u update ur mobile with the speed less than 10mbps....so its better to get update from samsung service center... and its 100% free of cost till 1 year from the purchase date.
    arimle likes this.
  18. Techero

    Techero New Member

    What I would suggest is to try downloading sd booster app if you have rooted your phone and set the cache value to 2024 or something that works best for you I have used 2024 and have yet not seen this problem again so hope it works for you all also. I also don't know if increasing sd cache limit has helped me get rid of this problem our something else so really can't say if it will work for you'll. Do let me know if it works .
  19. harigavara

    harigavara New Member


    give ur facebook name bro.so that i vil take ur help in this problem.my fb name " Hari Ism " . so can u pls addme/contact me there.
  20. ranjitkr

    ranjitkr Member

    hi
    I Had this issue before now my phone is working fine with this Latest firmware update in kies and i also rooted my phone!!
  21. SylentEcho

    SylentEcho Active Member

    Just restart the phone. It solves the problem.
  22. arimle

    arimle New Member

    i update my software and suddenly when composing message the font size becomes larger than before. i hate it. I want my message font size back!!!!! :( can someone help me?
  23. chaitanyak

    chaitanyak Well-Known Member

    yeah it works SD BOOSTER resolves i reckon coz after installing it and increasing itz cache value to 2048 i got rid of dis un mounting issues itz been 5 dayz now i havent seen dis issue after installing it now all my apps installed on SD CARD works like charm and it also made SD card work bit faster
  24. vner06

    vner06 Member

    i updated mine and seems work perfectly..no problem at all :D
  25. rizaaal

    rizaaal Member

    i had been tried all the solutions from this thread, and they still didnt work :(

    and now im asking, how to upgrade my phone to kernel DXKK2 ? Because if i upgrade through KIES, it says that the newest firmware is DXKL1 ?

    please help me
Loading...

Share This Page