Root Solution to Status 0 and Status 7 error in CWM

Discussion in 'Android Devices' started by nabeeleinstein, Nov 9, 2012.

  1. nabeeleinstein

    nabeeleinstein Well-Known Member
    23

    Nov 1, 2012
    87
    46
    23
    Hi guys
    If you may have noticed, cooking a rom directly in kitchen and then flashing in cwm gives a status 7 or a status 0 error, which is very very frustrating.


    ===============================================================
    PLEASE READ ONLY IF YOU UNDESTAND WHAT I'M TALKING ABOUT.
    ===============================================================

    Here is the solution.

    *optional stuff
    +++++++++++++++++++ A little Background Story+++++++++++++++

    When I got this phone, I saw the poorly coded mmx rom, the horrible battery meter and the memory hogging mmx crapware.

    I rooted the phone at night and installed cwm right away.

    I went to the kitchen (android's kitchen :p) and cooked a rom based on this firmware itself.Loaded it in the phone and flashed it.

    Then something weird happened. It didnt flash and I got a status 7 error.

    Searching the forum told me that sethuram had solved the issue, so i hesitatingly sent him a pm.

    (I'm not a fan of sending PM's)

    ++++++++++++++++++++++++++++END++++++++++++++++++++++++++++

    What follows is the result of my conversation with him.
    And thanks to him I solved this issue.


    Now


    ++++++If you get a status 0 error++++++++

    * "##" are input for kitchen.

    You have not created an updateR script when asked and followed with the old update script which kitchen uses itself.

    Go back and after pressing "99" to build, press "2" (The lazy method)
    It will do it for you.

    Now you will get a status 7 error :)p i know stupid right)
    continue reading.


    ++++++If you get a status 7 error+++++++


    Congratulations! Your build succeeded, and this is NOT your fault.

    Now,

    Open the archive (DONT EXTRACT)

    Navigate go to Meta_inf\google\android and open updateR script using Notepad++

    Search for mount points

    change

    mount("MTD", "system", "/system");

    TO

    mount("yaffs2", "MTD", "system", "/system");

    and save.

    Thats all there's to it.


     

    Advertisement

    sooraj87 and idhbar like this.
  2. idhbar

    idhbar Well-Known Member
    38

    Nov 7, 2010
    181
    13
    38
    Male
    Thanks. Hope you will released your first build very soon. Best of luck.
     
  3. cooldude007

    cooldude007 New Member
    5

    Sep 28, 2012
    4
    0
    5
    nabeeleinstein Its not working..
    Done same as urs (Credit=abhijit) not working :(
     
  4. nabeeleinstein

    nabeeleinstein Well-Known Member
    23

    Nov 1, 2012
    87
    46
    23
    yes this sometimes happens if u do a wrong step during building or mod something after the build,
    anyway do this:

    complete your build
    build ROM zip
    open the zip (don't extract)
    Go to meta inf , updater script
    edit it there
    save it
    close and flash.

    that should solve it
     
  5. Spiffy Jay

    Spiffy Jay Member
    15

    May 8, 2014
    19
    0
    15
    Male
    school
    LA
    For me it doesn't show mount("MTD","system","/system"); I have the status 7 error please help thanks in advance :)
     
Tags:

Share This Page

Loading...