1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

[Solution / Tutorial for Galaxy S i9000] MTP Application crashingTips


  1. toureiffel

    toureiffel New Member

    Many of you have problems with the use of your Samsung Galaxy S phone with tool Samsung Kies.

    Here is a video that shows the problem:
    http://www.dailymotion.com/video/xe3dj3_samsung-galaxy-s-crash-mtp-applicat_tech

    Samsung said the problem comes from the phone.

    It's here (french translation) : http://translate.google.fr/translat...terieux-bug-trouve-enfin-une-explication.html

    For the phone works with Kies (and remove the MTP application crash), you must simply connect the phone to "USB (mass storage).

    Just after, you found and erase all the files more than 16 caracters until Samsung publish a update/fix.

    After, Disconnect and reconnect the USB cable and select "Samsung Kies" mode.

    If all works, the bug lost... and you can use Kies ! Enjoy ! :D

    I hope this tutorial can help you :cool:

    Advertisement
    :
  2. Darkplek

    Darkplek Well-Known Member

    Should point out it's more than 16 chars after the last dot. I.e. an extension like "bla.12345678910111213".

    But yeah, I found this fix elsewhere, but I can vouch for it :). My MTP app was doing that when trying to connect to Kies. I trawled through the files and deleted all the ones that had stupid extensions. Cleared the caches etc too. And now it works with kies again, and i was able to flash to the new firmware. Which i might add has made a noticeable improvement to lag i think :p
    Chai99 likes this.
  3. saj_2001ind

    saj_2001ind Well-Known Member

    how do we know in which path and directory which files to delete ?

    can you tell me the exect directory where I should look for these type of file, I do not see it anywhere ... pls help
  4. PhoenixFx

    PhoenixFx Well-Known Member

    Thanks, I have given up using Kies because of that MTP application error. After deleting one file with a long extension now it works like a charm. Thanks :D
  5. PhoenixFx

    PhoenixFx Well-Known Member

    I wrote a small program in c#, couldnt find out a way to search for long extensions in dos mode :eek:.
    Exe is attached. Click the search button and select the SD card or Phone's internal memory , then you will see a list of files with extensions larger than 16 characters. Click on each file entry in the listbox to open the folder location. Hope this helps...

    P.S : Needs .Net runtime.

    Attached Files:

  6. saj_2001ind

    saj_2001ind Well-Known Member

    dude, you rock, it worked perfectly fine I found some long files and deleted them and now KIES working perfectly fine

    Thanks a lots :)
  7. Darkplek

    Darkplek Well-Known Member

    Haha, I love how somebody else thought to do this :p

    Only difference is you actually did, whereas I couldn't be bothered at the time and just searched manually xD

    Nice job.
  8. PhoenixFx

    PhoenixFx Well-Known Member

    I was already working on something else in visual studio; had the IDE open when I read the post, so I thought why not make a simple tool, its only 4 or 5 lines of code anyways, and I was in the mood to do some more coding ;)
    Otherwise I wouldn't have bothered either..
    aminghorori and tomjhealy like this.
  9. Digi79

    Digi79 New Member

    Glad that you did mate, coz that has been giving me hell from day one... just love how they preload software that breaks the features of the phone :p
  10. snapper.fishes

    snapper.fishes Well-Known Member

    I had the same problem until I deleted the clockwork recovery mod folder. I used ES file manager to copy all the files in my internal SD to my external SD. I then formatted my internal SD, and moved the folders back one by one until I located the folder that was causing the issue. Took a while, but it was worth the effort.
  11. MadBob

    MadBob Active Member

    mine finally connected to Kies using this method, I then successfully updated the firmware that it said was available, now it is stuck on a black screen after the S logo on reboot and then nothing, just hangs there.

    really don't want to try factory reset, any ideas?
  12. mafya

    mafya New Member

    I followed the tutorial and used the code you wrote, but I still cannot get connectivity with Kies. MTP Device is still not installing coerrectly either. Any thoughts where to go?

    I removed the long named files, reinstalled Kies and nothing. :(

    Kies ver 1.5.1.10074_2 (says its the latest version)


    You know, now that I think of it, why exactly do I want to connect with Kies? Aside from making the phone do what its supposed to...
  13. yunome

    yunome New Member

    Thank you very much. I follow your step. finally, I can fix this MTP crash problem.
    Would you mind if I teach your solution to other in my country ?
  14. micstewart

    micstewart Well-Known Member

    Thanks for the utility.. I thought the problem was something to do with a long file name left behind from the skyfire browser app. Your utility found it, I deleted, and kies now working again.


    thanks again.
  15. veenone

    veenone New Member

    Great solution mate! Thanks alot!! :D
  16. Iosipov

    Iosipov New Member

    thenx man, thenx a lot !!!!!:p
  17. DerekB

    DerekB New Member

    Well, I only bought the galaxy S 3 days ago and Kies runs fine on my laptop but crashes with umpteen errors on my main PC, even without the phone being connected. I've had to delete it as I don't want important work stuff getting trashed by it. Frustrating that I can only sync stuff now on the laptop.

    I got the phone as a solution but this has created even more problems for me and my business.
  18. mogo22

    mogo22 Member

    Sweet Betty Brown it worked!

    Thanks a lot for the info and the file searcher.
    What a joke, a simple thing like that and Samsung can't get out a fix. That with their Kies issues. They need to be quicker with their patches.
  19. sudburys

    sudburys Member

    Why is it that everyone else seems to sort thier problems but me?!?!?! lol!!

    I tried deleting the 2 long file names that were found in the internal phone memory (both in the picture gallery(and thanks for the programme by the way!!)) but the damn thing still wont connect to Kies.

    Suds
  20. jokerZwild

    jokerZwild New Member

  21. azeraza

    azeraza New Member

    by doing the method, i've finally get my i9000(DXJG4) connected to kies (1.5.1.10074_2).
    thank you very much.
  22. tupique

    tupique Member

    In my i9000 (DXJF4), there are no file with long extension, but still can't connect to the latest kies 1.5.1.10074_2

    My laptop (vista 32-bit, UAC turned off, all Samsung drivers were successfully installed) can detect the phone properly. No errors in Windows' Device Manager. Can connect to the phone using 'USB debug mode on' + 'USB mass storage' and transferring files via Windows' Explorer.

    But everytime I connect the phone using USB for Samsung Kies, the phone is going crazy and Kies is trying to "connect to media" for ever... :(

    How to upgrade the firmware (or the OS?) if I can't connect to the phone using Kies? I read that upgrading the firmware using Samsung Kies is the easiest way.
  23. skk-john

    skk-john New Member

    thx 4 sharing tis post~ really usefull 4 who using samsung galaxy s~
  24. test.connettivita

    test.connettivita New Member

    oh yes! we are in the same boat :(

    so ...

    in a windows xp sp3 i installed samsung galaxy usb driver, then i installed kies, but kies dont recognize the smartphone and don't connect it.

    i use "reinstall driver" as i found in a forum, to delete samsung usb driver and restore originals driver.

    but kies don't recognize the smartphone.

    so i use the fix to remove all 16 lenght or more file, and i removed one.

    but kies don't recognize the phone.


    when i connect smartphone windows xp says that a new MTP device is found ... and found, and found and found, all the time.

    so is the mtp device driver the problem ?

    my only need is to install froyo . can i install it without use kies ?
  25. Ramchi

    Ramchi New Member

    I have recently purchased Samsung Galaxy I 9000 and have problems connecting using my USB cable.

    Thank you so much and it worked after running your EXE which helped me cleaning up long extension files.

    Many have wrongly guided to reinstall drivers which according to me may not really resolve this particular issue. Hope Samsung fixes this in its next release.
Loading...

Share This Page