[Solution / Tutorial for Galaxy S i9000] MTP Application crashingTips


Last Updated:

  1. Metusion

    Metusion Active Member

    KIES is such a POS... It again won't recognize my phone and just says please wait for device:.... I just don't understand why this was so hard for samsung to program...!!

    Advertisement
  2. Metusion

    Metusion Active Member

    can't get it to work anymore no matter what I try.. I don't have lengthy files on my phone so that isn't it.. what could be it???
  3. MrBusy

    MrBusy New Member

    Thanks a lot for that little app!
  4. fbarbas

    fbarbas New Member

    Hi all:

    I did find some long file names, deleted those, got rid of the flashing mtp error. Thanks to the person who wrote that program. The next problem was KIes is now stuck on connecting to galxay phone (same problem on two different pc's). Left for a half hour, noda, no connection happening. It did connect though with explorer and media player. Long story short, had an extra hard drive quicking around, install windows, installed kies, nothing else, finally it connected and I could do a firm ware upgrade. I think Samsung should include a PC with every phone purchased, LOL. or at least an extra harddrive.
  5. Ben-B

    Ben-B New Member

    I've got the problem too. It has worked for me in the past, though before I installed doubletwist (That is all I can think of that changed) I removed 3 files with long extensions, uninstalled and reinstalled Kies, but the MTP Application screen comes and goes forever still. I really want to get this working before Froyo comes out!!
  6. rcl4444

    rcl4444 New Member

  7. rcl4444

    rcl4444 New Member

    Metusian & JokerZwild, have you checked for long files on your external SD card?

    Also try
    1. Remove external SD card
    2. settings>SD card and phone storage> int SD card>unmount SD Card
    3. Connect to computer
    4. settings>SD card and phone storage> int SD card>mount SD Card
    (thanks Geryatrix)
  8. Saj galaxy s

    Saj galaxy s New Member

    to all the people having problems with the phone not connecting in kies ,

    run kies and in top left corner kies menu run driver recovery , once done exit kies ,

    on the phone go to settings,sd card and phone storage unmount the external sd card , then unmount the internal sd card and only format that , if you have anything important on it back it up

    in settings menu go to about phone,usb settings and select samsung kies and then exit the menu and reboot the phone

    run kies , connect usb cable to the phone , let the drivers install and the phone should now be connected in kies

    keep usb connection on phone in samsung kies mode to avoid connection problems in future

    i hope this helps
  9. test.connettivita

    test.connettivita New Member

    hi, i'm using samsung 9000 by "AT&T" so called Samsung Captivate

    i tried disconnecting internal sd card, removing long extension filename, connecting as kies mode, using original driver, using samsung driver ...

    nothing to do : i'm not able to connect to kies so i'm not able to install froyo

    other help? :-(

    thanks ....
  10. cuentil

    cuentil New Member

    try this, WORKS FOR ME:D:

    -Close Kies on PC
    -Connect the phone to PC / Laptop & Select Mass Storage Mode.
    -Select the USB icon from the Notification section in Samsung Galaxy S to Mount the drive.
    -You should now see Phone
  11. Wolfgang Kurz

    Wolfgang Kurz New Member

    Hi, what is to do to install runtime??

    Regards, Wolfgang
  12. hoe_liday

    hoe_liday New Member

    this works like a charm! thank you!:)
  13. kitmac

    kitmac New Member

    thanks for this!! i was so frustrated by not being able to connect my galaxy s to samsung kies but with your help. boom. works like a charm.
  14. o.maille

    o.maille Member

    toureiffel Great spot, been looking all over for this, I wonder if someone could ring google and ask to bump this thread to the top of all the searches related to kies!
    PhoenixFx brilliant fix, you should ask samsung for a job, clear they need help!
  15. elproserado

    elproserado New Member

    thankyou, thankyou, thankyou! I've trawled through loads of forums, all with different advice and yours worked perfectly. I've never posted on forums before to say thanks but I'd have never sorted this without your help. So once again, thankyou.
  16. Profpinz

    Profpinz New Member

    Ditto! ..... Brilliant fix!
    I've tried numerous fixes and reloaded Kies more times than I've had hot dinners but it was all to no advantage till I read this post!
    I'm a happy Samsung owner again! .... Thanks for posting the information!
  17. lars_stecken

    lars_stecken New Member

    I was trying to do it manually and failed to find one last file...:eek:

    Thank you so much for this little tool.

    Cheers...
  18. sublimenaz

    sublimenaz New Member



    I'm f#!king lost.....what the heck is .net runtime? All I'm trying to do with Samsh!t kies is to get the GPS update. I've been wasting almost two hours on my computer trying to get this crap to work so I can simply download the fix for my gps. I'm so close to chucking my phone into oblivion from my deck and going back to a dumb phone. :mad: :confused:
  19. Sleeper69

    Sleeper69 Well-Known Member

    just spent an hour on the phone with samsung. Kies is not ready for win 7 64 bit OS yet. NOT SUPPORTED.

    The fix that worked was the 16 character thingy that is mentioned above. the guy at samsung even emailed this forum link to rectify the problem.

    nice work samsung. NICE! :-(
  20. mikeshutt101

    mikeshutt101 New Member

    Hi people, never actually signed up and used a forum before, but I've had a revelation and want to share it with you all! After a frustrating couple of months I've tried connecting my SGS to Kies via XP and Windows 7 and no joy. I finally decided to try and reset to the factory settings, loosing all my apps and data on the internal SD. Low and behold it starts working on Kies with XP! Haven't tried it with windows 7 yet, but I'm hoping it will work. It continued to work as I reinstalled all my applications. still connecting to Kies: great! then I wanted to use Google Navigation and it told me I've got to install Text to Speech app. After this is installed it no longer connects to Kies or mounts in windows at all! Coincidence? After a bit of hunting I used the SGS application manager and found TTS (Text to Speech) running in the background. I used Force stop option in the application info and low and behold Kies connects again! So TTS was the problem for me! I imagine most people with a SGS have installed this, so give this trick a go and maybe it'll help you?!
  21. ardz

    ardz New Member

    Tried everything on this thread, i've been trying to get this working for the past month now.

    Kies simply doesn't support w7 64.

    Samsung are complete muppets, I'll never buy a phone from them ever again. Worst droid ever.
  22. parikksit

    parikksit Member

    Thanks so much... :) .. a real tech!
  23. kentsu

    kentsu New Member

    the knowledge of "driver recovery" in kies saved my day and provided me froyo update this morning. Thank you Saj, I was really going insane not being able to connect my i9000 to my pc in any way, not kies nor mass storage. I've tried all sorts of tricks gotten from other forums like installing drivers from 3rd party sites etc...and almost did a factory reset.
    The froyo update did not loose my data. All my apps were intact. Settings and home screens were resetted.
  24. Oct-Al

    Oct-Al New Member

    Thank you to everyone for your help with this long-standing problem - all I got from Samsung support was that there was a problem with my laptop.

    On checking, I found that TunnyBrowser contained files with long file extensions. I deleted these files and was then able to connect to Kies. I have sent an email to support@dolphin-browser.com informing them of the situation.
    :)
  25. ArmadaTattoo

    ArmadaTattoo Well-Known Member

    Thank you, thank you, thank you! I am delighted to say this has worked a treat. I had files in Seesmic (avatar filenames) and some thumbnails which were more than 16 characters.

    Thank you for bringing this solution to light and thank you PhoenixFx for your handy little search tool.

    I can now happily wait for FroYo to be released for my SGS in Ireland. Or do the registry hack if I get impatient :)

Share This Page