[Solution / Tutorial for Galaxy S i9000] MTP Application crashingTips


  1. jamescgray

    jamescgray New Member

    +1 for the file search app in post #5, ran it, deleted the offending files (seesmic and thumbnail data in the camera app were the culprits) now connecting. Many thanks PhoenixFx!
  2. SlowRain

    SlowRain Well-Known Member

    I'm trying to do this 16-character fix, but I ran into a snag at the very start. I connected using the Mass Storage option. My PC (Windows 7, 32 bit) listed it under Devices and Printers. However, I couldn't browse the files. The drives for K and L were light grey, like it was an option I could see but wasn't allowed to choose. What could be hindering me from browsing those drives?

    Thanks.
  3. amsams

    amsams New Member

    This works finally thanks alot

    sourabhshankar likes this.
  4. SlowRain

    SlowRain Well-Known Member

    Thank you. Thank You! THANK YOU!!! A thousand thanks. May you and your children be healthy and happy. May you all enjoy long, fruitful lives. May you never be lacking the necessities of life. May your libidos last forever. May your Galaxy S never break.

    The step I was missing was:

    "-Select the USB icon from the Notification section in Samsung Galaxy S to Mount the drive."

    Take care, everyone.
  5. enspyre

    enspyre Member

    Hi all,

    I just thought I would post my experiences with this phone, MTP, and Kies:

    - I have kies installed on two PCs - Home (newest version) & Work (ver: 5.32222)

    - Kies at home was crashing everytime I wanted to cancel a firmware upgrade (even just a check) so I decided to uninstall and reinstall the same version at work, which operated fine

    - Upon uninstall and reinstall, Galaxy now started doing the "MTP" loop

    - I also noticed that after I disconnect the device from the PC, I can no longer access my internal SD card, unless I do a hard reboot.

    - I initially thought this was caused by the new home install, but the looping also happened at work now, which leads me to believe Kies messed up the internal SD on the Galaxy, or how it handles it.

    - After a lot of trial and error, I found out that I have to connect the Galaxy in mass storage mode... simply browse the directory (NOT CHANGE ANYTHING)... disconnect & reconnect, select Kies, and it now connects fine.

    - Problem solved right? Nope. Upon disconnect from Kies, if I reconnect Kies again, home or work, the MTP looping starts up again, and internal memory is no longer accessible. I have to follow the same steps above in order to connect, but first do a hard reboot in order for the phone to recognize the SD.

    A weird change that I have also noticed is that If I try to connect the Galaxy to my PC in mass storage mode AFTER the failed kies attempt, I no longer have to mount the drive, the PC already sees the files. In fact, even if I select mount, it does nothing. In the phone information, it tells me my internal SD information is "unavailable".

    So my theory so far is this:

    Connecting to Kies first, causes the phone to mount the internal SD for reading, but messes up the connection somehow. Once I disconnect from the loop, the SD is still mounted, so the phone doesnt recognize it, BUT it doesnt know that the SD has been mounted so it just thinks one doesnt exist.

    I think somewhere in the memory, the phone is now defaulted to have the internal SD always mounted, but still accessible. When I connect to kies, it again tries to mount an already mounted SD and crashes. I believe that is the reason why I need to do the mass storage first. By mounting and unmounting the SD in mass storage, you set things right, allowing the connection to Kies. When you disconnect from Kies, it doesnt unmount the SD and messes everything up again.

    I don't know, I may be way off but Im getting tired of all this troubleshooting.

    I will be trying this 16 character thing to see if that is the reason everything is messing up, be regardless, there are some major issues with Kies and how it handles this phone.

    Hope this helped anyone.
  6. nitinkcv

    nitinkcv New Member

    Thanks a lot for sharing the exe. The files were under the location DCIM/photos. The file names were of the type .thumbdata3--1967290299 and .thumbdata3-1763508120.

    Thanks.
  7. enspyre

    enspyre Member

    Just an update,

    I am sure now everytime I connect my Galaxy S, the phone automatically always mounts the internal SD. Works great for Mass storage, not so great for Kies. All I do now is:
    1 - connect the phone, select Kies (MTP error starts looping),
    2 - I press the home button to exit
    3 - pull down the notification bar
    4 - unmount internal SD (which is already mounted)
    5 - Kies connection starts up again automatically
    6 - and a connection is successfull

    Works for now...

    btw, the exe found some long file names but didnt solve my looping MTP issue. I think the MTP looping happens at any SD related error, whether long file names or SD mounting.
    Tigro and biba like this.
  8. sayyeng

    sayyeng New Member

    My phone had never connect with my computer before and i just tried it recently. i cannot seem to connect my phone with my computer, totally no connection.

    When i plug it in, and press mass storage, i waited and waited, but nothing came up. i installed kies and tried pressing samsung kies but still couldn't connect.everytime my computer tries to install the driver, i will fail and my phone cannot connect with my computer help please...

    oh and i also have the mtp app blinking problem, but since my phone cannot connect with my computer, i cannot use the finder to solve this problem. help please, i'm desperate
  9. SlowRain

    SlowRain Well-Known Member

    Did you "select the USB icon from the Notification section in Samsung Galaxy S to Mount the drive"?
  10. sayyeng

    sayyeng New Member

    Yes i tried. Its already mounted. I tries plugging it in another computer, vista. But the same thing happened
  11. SlowRain

    SlowRain Well-Known Member

    Can you see your device's internal and external storage listed as separate drives under My Computer on your PC? Can you browse them?
  12. sayyeng

    sayyeng New Member

    No,when i plug in and press mass storage then the comuputer will have that sound. Then the driver on my computer is no where to be seen. I tried on other computers too but nothing
  13. SlowRain

    SlowRain Well-Known Member

    Weird. So you pull down the notifications drawer and mount it, but it doesn't go through. Is that correct? Is the Windows Device Manager showing any errors?
  14. aseesko

    aseesko New Member

    Good job... thanks from germany for your program :FileSearcherforKiesFix.zip :)
  15. sayyeng

    sayyeng New Member

    Ya it will always fail to install de driver de.
  16. willows

    willows New Member

    I have a problem like that after installing voodoo lagfix. Now i cant use kies for upgrade firmware, i tried to disable voodoo lagfix but same result mtp error and crash. Can someone help me how to uninstall voodoo lagfix and back to samsung partition?

    Thanks
  17. jeremyelijah

    jeremyelijah New Member


    :) i connected my Galaxy S to kies. i can synchronize my contacts to my pc. thank you so much...
  18. Marinosbitter

    Marinosbitter New Member

    Dude...
    one word...


    EPIC!!!


    thnks so much for this ridiculously helpfull program.
    deleted both long files on my internal and external sd and it worked!!
    (at first I only deleted the files on the internal sd but that didn't suffice, but after I checked the external sd and removed the long files it finally worked again)

    thnks again
  19. mtriper

    mtriper New Member

    Thank you PhoenixFx!!! I knew the problem HAD to be this filename stuff but could not find the long named ones... You lilitle coding save me from have to re-format the phone and star from 0.

    You
  20. sonune.amol

    sonune.amol New Member

    See the end of this message for details on invoking
    just-in-time (JIT) debugging instead of this dialog box.

    ************** Exception Text **************
    System.UnauthorizedAccessException: Access to the path 'C:\Windows\System32\wfp' is denied.
    at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
    at System.IO.Directory.InternalGetFileDirectoryNames(String path, String userPathOriginal, String searchPattern, Boolean includeFiles, Boolean includeDirs, SearchOption searchOption)
    at System.IO.DirectoryInfo.GetFiles(String searchPattern, SearchOption searchOption)
    at FileSearcherforKiesFix.Form1.DirSearch(String sDir)
    at FileSearcherforKiesFix.Form1.button1_Click(Object sender, EventArgs e)
    at System.Windows.Forms.Control.OnClick(EventArgs e)
    at System.Windows.Forms.Button.OnClick(EventArgs e)
    at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
    at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
    at System.Windows.Forms.Control.WndProc(Message& m)
    at System.Windows.Forms.ButtonBase.WndProc(Message& m)
    at System.Windows.Forms.Button.WndProc(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
    at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


    ************** Loaded Assemblies **************
    mscorlib
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.4206 (VistaSP2GDR.050727-4200)
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
    ----------------------------------------
    FileSearcherforKiesFix
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Downloads/Software/FileSearcherforKiesFix.exe
    ----------------------------------------
    System.Windows.Forms
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
    ----------------------------------------
    System
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.4205 (VistaSP2GDR.050727-4200)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
    ----------------------------------------
    System.Drawing
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
    ----------------------------------------

    ************** JIT Debugging **************
    To enable just-in-time (JIT) debugging, the .config file for this
    application or computer (machine.config) must have the
    jitDebugging value set in the system.windows.forms section.
    The application must also be compiled with debugging
    enabled.

    For example:

    <configuration>
    <system.windows.forms jitDebugging="true" />
    </configuration>

    When JIT debugging is enabled, any unhandled exception
    will be sent to the JIT debugger registered on the computer
    rather than be handled by this dialog box.


    I'm getting above error while trying to run the FileSearcherforKiesFix...Please help
  21. Speed Junkie

    Speed Junkie Member

    I done that and it still doesn't find it, maybe I did something wrong.

    Edit: Both come up clean and yet it doesn't accept the phone :mad:
  22. biba

    biba New Member

    That works .. thank god :)

    You forgot to mention that Samsung Kies needs to be default when plugging in the USB cable. All the other hints did not work so far.
  23. RaZz0R

    RaZz0R New Member

    PLEASE!!!


    Before doing the driver recovery - try to just simply unmout the SD card - after having Kies working perfectly it starting flashing the MTP app and wouldn't connect - after reading this therad I simple unmounted the SD card & it connected to Kies in 1 second flat!

    Sync'd my calandar and all good - please just try the SD unmout before you perform any driver recovery.

    Cheers,

    Chris


  24. agaryt

    agaryt New Member

    You are the GOD !!!!
    thanks!!!
  25. bind00

    bind00 Well-Known Member

    I found files with long extensions by mounting the phone as a USB drive and searching in Windows Explorer for *.?????????????????* (that's 17 question marks). Removing these stopped MPT crashing and flashing about twice a second but the MTP screen does refresh every five seconds or so. Is this normal? Previously I saw the Android desktop in between crashes but not any more. I think I've resolved that part of the problem at least.

    The problem now though is that Kies just hangs with 'Connecting the device... Please wait' forever. On the phone it says Initialising. I tried downloading the drivers linked from a site mentioned above but no luck. In any case, why on earth should this be necessary when there's a recover drivers link within Kies? Surely that should be more trustworthy? I'm using the version 1.5.3.10103_100 of Kies and have reinstalled innumerable times.

    Edit: I'm using Windows XP SP3. In device manager I don't see portable devices or MTP as other posters have mentioned.

    Frankly I'm absolutely disgusted to have been put to so much inconvenience for what should be a very simple operation.

    Anyway, if anyone has any other suggestions they would be welcome. Maybe I should open another thread. I don't know any more. I need a break.

    BTW, when searching this forum for "MTP" nothing comes up, whether advanced search or not. What's that all about?
Loading...

Share This Page