SOLVED: Desire.SLCD.Black.Screen.Bricked


Last Updated:

  1. defaye

    defaye New Member

    MY SITUATION:
    My phone was rooted with unrevoked3. I tried to install one of the modaco ROMS and did not realise that it was incompatible with my phone because my Desire has a newer type of screen (not amoled) but SLCD.

    This caused the phone screen to go black on startup and be unresponsive. It was frightening because at first the HTC bootscreen (green HTC on white) had black streaks through it , then goes black. But don't worry it is easily redeemed in below instructions.

    You need the latest ROM in zip form, put onto your phone and run recovery. Sweet as suzi, you will be debranded (if you were in the process of doing this , remember to make your gold card).




    ISSUE:
    1. Desire screen not switching on at all even though phone switches on.
    2. Phone boots but doesn't go beyond bootloader/recovery/fastboot
    3. Can get into recovery even though nothing comes on screen (test: press volume down and power. Wait for 10 seconds. Press volume down. Press power. Phone should vibrate. Wait 20 seconds. Phone should now be in recovery mode.)
    4. Can get into fastboot (back+power)
    5. No goldcard

    CAUSE of ORIGINAL AUTHOR'S ISSUE:
    I had Aura Sense7.9+AlphaRev S-Off. Cause::Ran a very old RUU just because I wanted to bring things back to stock. The RUU overwrote my HBOOT from 0.93 to god knows what. Turned out, the RUU was for amoled screens and not for SLCD screen. So even though the phone turned on, the screen never did.

    SOLUTION:
    1. Make sure you have HTC Sync drivers installed. Install HTC Sync and then just remove the application and not the drivers. I also installed the unrevoked hboot drivers. Do the same.

    2. Get Android SDK http://dl.google.com/android/android...07-windows.zip

    3. Check that your phone is recognized in recovery and fastboot by your system once drivers are installed -- once you install the drivers, boot into recovery (point 3 of issue -- you should hear beeps in win7 signalling a device connection). Open android_sdk/tool directory in command line and type 'adb devices'. Your device should come up. Similarly take phone into fastboot, and then in command line type 'fastboot devices' your phone should come up.

    4.Switch off phone after test. Next, take phone into recovery mode and create gold card. Follow http://theunlockr.com/2010/03/10/how...te-a-goldcard/ or use the Gold Card Tool . The last part of the Gold Card Tool (Patch MMC) didn't work for me so I used the hex editor manually. Make sure you start with the SD Card that came with your phone. I tried 2 cards and it didn't work. Just the SD Card with the phone did!

    5. After gold card is made, download 'RUU_Bravo_Froyo_hTC_Asia_WWE_2.13.707.1_Radio_32. 44.00.32U_5.09.05.30_2_release_143921_signed' RUU from shipped-roms. This is the latest RUU that I could find for SLCD screen.

    6. Run RUU and if your gold card is correct, you should sail right through. and be greeted by a working Desire.

    Phew!

    Inspired from this article: :)
    [SOLVED] Desire.SLCD.Bricked.Help - Android @ MoDaCo

    NOTES: if you have any problem with this - I am happy to help you just leave a message. It is all self-explanatory though.

    Advertisement
  2. EddyOS

    EddyOS Well-Known Member

    Any RUU which is 2.xx.xxx.x is fine with the SLCD as they're all FroYo
  3. Rastaman-FB

    Rastaman-FB Well-Known Member

    good to know you can make gold cards via recovery
  4. droidzone

    droidzone Well-Known Member

    As long as you have a working Recovery. For me, running the RUU wiped the Recovery.
  5. rajverma3135

    rajverma3135 Member

    Hi

    I need help as I did blunder mistake, I just run the RUU for my phone as I was having probs n thought to unroot n root using RUU and everything went well but now my screen just went black, I can hear the animation soundn feel vibrations and key lights are working as well, but main display is not.

    Any suggestions please

    I will really appreciate the help

    Many Thanks

    Raj Verma
  6. SUroot

    SUroot Well-Known Member Developer

    Run the correct RUU
  7. rajverma3135

    rajverma3135 Member

    Hi
    Thanks for the post
    I hope i will be able to sort my phone, which have the same display problem like urs

    When i conncet my phone in fastboot it gives me the serial number after fastboot devices but shell command does not work in fastboot

    but in recovery or normal phone adb devices does not work

    can u guide me with something, some idea plz

    many thanks in advance

Share This Page