[SOLVED] GPS aquistion on EC05


Thread Status:
Not open for further replies.
Last Updated: 2012-09-15 02:33:18
  1. Aero1

    Aero1 Well-Known Member

    Folks I am now seeing symptoms of stickiness in the GPS cache on both our ec05 Epics. The symptom is GPS on, application requiring GPS on, and the device not obtaining any GPS after several minutes optimum conditions, followed by a battery pull and a GPS acquisition within a few seconds.

    This was a known issue on older firmware, one I never saw with eb13, which I had for a month, but which has returned on both our epics wiht EC05.

    Lets track this to see if anyone else has this. Please do not cloud thread with discussions of accuracy or results one sees within a couple of days of any reset.

    Advertisement
  2. fareal

    fareal Active Member

    I've experienced the same. And appears the dialer code to access gps startup mode is no longer availble.
  3. pley

    pley New Member

    After EC05, I got very slow GPS lock like 10 minutes. Before it was instant. I had my phone since Dec 10 with the previous release until the recent upgrade to Froyo.EC05
  4. Flaspeneer

    Flaspeneer Well-Known Member

    I really thought we were past this circle of GPS purgatory.

    Last night, a friend and I took the wrong exit heading for Tribeca. Thinking I'd help and, since the signal in that area's good, I got out my Epic. Minutes went by and I couldn't get a lock. I did a reset, but before the phone could restart, my friend rolled down the window to talk to another driver. Never thought I'd say this, but I'm considering either picking up an Evo 3D in six months or a Shift for backup.
  5. kristv

    kristv Well-Known Member

    This is why I’m sticking with custom ROM’s from the folks over at the xda developers forums. I have yet to experience GPS problems with the ROM’s I’ve used from there. Currently on Bonsai 4.0 and I get a lock very quickly. Samsung/Sprint can’t seem to program worth a damn from what I’ve seen. A bunch of hackers and independent programmers have made this phone run far better than it ever would have on the stock crap Sprint/Samsung have been shoveling out to us.

    Just my opinion, of course…
  6. Aero1

    Aero1 Well-Known Member

    Just spoke with Sprint and they are getting reports of GPS lock problems on ec05. If it is the same problem from d118, I can not believe they fixed thi in the final of eb13 and then screwed it up again on ec05! I am especially miffed since they seem to have removed the user ability to set cold start as default as well.
    How did it work after reset?
  7. fareal

    fareal Active Member

    One good thing about EC05 update is that I can now get a lock on GPS when I'm indoors. Confirmed with the GPS Status app.
  8. toyman317

    toyman317 Well-Known Member

    Me too. Mine works great. Wife's too.
  9. slwelsh

    slwelsh New Member

    I'm having the problem on Syndicate Frozen, and I can confirm I also had it on stock EC05 that I got OTA. Symptom is that GPS works great for a while, then at some point quits altogether. GPS stop/start does not cure it, nor does AGPS State Reset from the GPS Status app. The only reliable way I know to get the GPS working again is to reboot. Wonder what's different about Bonsai that you are not seeing the same problem. Is this an EB13-based build? -Sean
  10. someguy1984

    someguy1984 Well-Known Member

    I use GPS everyday for work and I have bonsai. I have not experienced one problem. My phone is seriously on GPS about 4 hour daily.
  11. dksnet

    dksnet Guest

    Sprint GPS or Google? Both of mine start and work fine. EC05
  12. Aero1

    Aero1 Well-Known Member

    This isn't about where you can get a lock. I see no difference (improvement or degradation) in SNR or multipath rejection. It is about differnce in ebb13 v ec05 assistance data handling. Several users are seeing signs that something has gone wrong with that
  13. Aero1

    Aero1 Well-Known Member

    Bonsai is a modified eb13 kernel. We are discussing stock EC05 kernal
  14. kristv

    kristv Well-Known Member

    Bonsai 4.0 is not an eb13 kernel, it's EC05. This is what I'm running and GPS works just fine with it.
  15. Inspekt

    Inspekt Member

    Gps worked fine with eb13, but after update it no longer functions as well. I usually don't reboot my phone for several days. I notice that immediately after a reboot the gps works fine. Later though, It can see the sats but it never locks. If I reboot at that point the gps works fine. Thanks for breaking it again samsung.
  16. Aero1

    Aero1 Well-Known Member

    Is this you claiming Sprint ID is not on EC05? :eek:
    http://androidforums.com/2473154-post111.html

    And looking at Bonsaa forums essentially everyone is rebooting for one reason or anotehr every 24 hours. Of course you are not having a stuck cache issue.

    And this is a thread about GPS issues with OTA stock EC05, which is what 99.9% of Epic users have. As with the prior discussion of what was a verified GPS cache bug people with custom roms in constant develpment have a differnt usage habits, specifically booting and other cache clearing (known or unknown to them)
  17. saxologist

    saxologist Well-Known Member

    used mine for trip yesterday. works fine
  18. wrangler88

    wrangler88 Member

    i can agree, mine does not work indoors at all, outside it works pretty well but sometimes it does take a while to lock. Sorta sucks, I really like this phone but geez its got some issues!
  19. Aero1

    Aero1 Well-Known Member

    Irrelvent to the issue. please read the first post. this is not a question of when it works, whcih could easily be 80% of the time with the bug present but the conditions present when it does not.
    Even when the major bug was in the software for 6 months it worked after a reset .
  20. kristv

    kristv Well-Known Member

    My comment about Sprint ID was incorrect...because it was actually EB13 that I installed on my wife's phone, not EC05. She currently has EC05 Bonsai now though...

    Don't know about anyone else, but I'm not rebooting every 24 hours and still do not have a problem with my GPS. But sorry, I guess my input isn't wanted here so I'll keep my mouth shut. My bad....
  21. Howard Packer

    Howard Packer Well-Known Member

    I am having GPS issues since the OTA update. Seems not to be a problem with my RunKeeper app, but I am having problems with Sprint Navigation, Google related navigation apps (Navigation, Maps, Places, etc.), Gas Buddy.

    Not having issues every single time but most of the time. Sometimes a reboot fixes the issue. Today, it didn't fix after shutting down and restarting about three times. I finally gave up.

    I haven't yet tried a battery pull instead of just shutting down and restarting the phone. Very frustrating! :mad:
  22. buggerritt

    buggerritt Well-Known Member

    I can confirm this issue. I had my phone on for 2 hours, used GPS status/tool and gave up trying to get a lock, after 3 minutes. I rebooted and almost immediately got a lock on 10 satellites. Accuracy was 4 meters, in my house. It is random, though. Afterward, I had my phone on for another 2 hours and checked status, again. Immediately I got lock on satellites with same accuracy.

    I am running midNIGHT latest ROM, which uses the Bonsai EC05 kernel. I realize you started this thread but, the bug doesn't seem to be stock dependent. slwelch confirmed the same issue on syndicate's EC05 ROM, as well. The only ones (above in this thread) who are not having the problem, seem to not understand what the problem is. Yes, GPS works and works well and with great accuracy. But, randomly, when the phone has been turned on for some time, it does not get a lock and a reboot is necessary to refresh the cache and get lock, again. There was a fix for this in DK28. I wonder if the same fix would work on this kernel. It would take flashing back to DI18 to find out. I'll let someone else try. I have everything else the way I want it, right now and can't be assed.
  23. boomerbubba

    boomerbubba Well-Known Member

    @Aero1:

    Did you have the Cold Start workaround set on this phone before updating the OS to EC05? Not sure what the update would have done to those settings, or what the default settings are under EC05.

    I've been meaning to install LauncherPro to run the hidden GPS Setup utility, now that the dialer codes have changed.
  24. buggerritt

    buggerritt Well-Known Member

    I cannot find LBSTestmode in launcher Pro Activities. If you find it, please let me know.
  25. boomerbubba

    boomerbubba Well-Known Member

    There is no LBSTestmode app on the Epic. That app is for the Vibrant, Captivate, and other GSM-based Galaxy S phones.

    The corresponding app on the Epic (and the Fascinate), which have a different GPS chipset and thus a different utility, is called GPSSetup. The interface is not identical to that on LBSTestmode, but it is similar.
Thread Status:
Not open for further replies.

Share This Page