1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

[Solved] GPS problems


  1. So i currently have and love this rom... but i have one problem which i cannot figure out.. with GPS. when i go into maps and i go into navigation, the system just sits at searching for gps (never actually finding a signal and giving me directions) ive had it sitting for almost 10 min just to see if it was slow and it never found...

    the thing that is weird is that it will give me directions (the turn by turn list) but when i go into the actual nav, where it speaks... it just wont work...

    Advertisement
    :
  2. rmk

    rmk Well-Known Member Developer

    Oddly enough I ran into this today. Go into Settings->Location and enable all the location services. That should get you going again.
    wryun likes this.
  3. wryun

    wryun Member

    If that doesn't work, try the suggestion in my signature.
    Also found here: GPS FIX
  4. Chip Chipperson

    Chip Chipperson New Member

    not sure if its a fix for your situation, but every time I flash a rom, I make sure to disable mock locations under applications development..
    wryun likes this.
  5. thanks for your input everyone, i will be testing it out today.. But the other day i needed the gps so i restored back to my rooted stock 2.1 and when i tried to go back to my backup of virt it wouldnt boot... guess something got screwed up in my back up... so sadly i need to start all over. Damn, and i had everything set up and working perfect.
  6. so i have all the locations services activated.. (the vzw, standalone gps, and google location) and i have also installed gps status (i have reset and redownloaded) still NOT working. Just sits at the searching screen

    and even when i locate my self, its off by a decent amount, when it usually locates me (rooted stock) fine

    Hey rmk- would it be better to keep this discussion here or put in in the xda section where it was brought up first?
  7. incred99

    incred99 Well-Known Member

    Just want to check, are you using a 2.x radio (baseband) version?
  8. how do i check that?

    I also noticed that when i went back to stock rooted 2.1 everything worked fine. I went to a spot in my backyard (4 bars of service) and it connected right there with no delay.

    When i flashed back to virt, it only had 1-2 bars and would not connect....
  9. wryun

    wryun Member

    Bummer.
    Make sure the required radio is installed and follow instructions exact.
    My GPS works fine, and I didn't even have to do the "GPS Status" app fix.

    Good luck. :)
  10. haha caught that edit! i followed the directions :D
  11. wryun

    wryun Member

    LMAO. I noticed AFTER I posted that reply you said you DID follow instructions. :D
    I would suggest un-rooting, install specified radio, root, and install ROM from a fresh download.
    Pain in the butt I know, but this ROM is worth the stress.
    Once that is done and you have your phone set up the way you want, do a ROM backup via recovery.
  12. incred99

    incred99 Well-Known Member

    From the Main Screen
    Menu
    Settings
    About Phone
    Software Information

    Look under Baseband Version

    I had this issue too, I went from Stock Rooted to Virtuous and my GPS didnt work because I hadn't updated my radio version to 2.x
  13. im on basebase 1.xx thanks for the help everyone.
  14. incred99

    incred99 Well-Known Member

    No prob.
    Go here and you can upgrade the radio version.
    wryun likes this.
  15. i updated the radio! and it works! thank you!!!! im so glad it worked out. Great rom, quick response, no lag and gps works great!
    wryun likes this.
  16. incred99

    incred99 Well-Known Member

    Thats great!
    Glad you were able to get it working :)
  17. b1gg134

    b1gg134 Well-Known Member

    Hey Chip!!

    Mock locations? what's next ... fake locations or something?
  18. dcmot

    dcmot New Member

    Aloha, I have been stumped for a few day on this problem. See what you guys think.

    Google maps will not get a lock on my phone inside, but will pretty fast outside. Also the weather and clock widget does not find or update my location nor does google web page, it says location unavailable. I have reflashed rom with a full wipe multiple times. Even tried other roms. Checked and unchecked all location settings to no avail. I even downgraded from the 9.01 radio to 7.28, but nothing. Also called verizon to see if their aGPS system was out, I think that is what it is called, they didnt have a clue. Finally tried the GPS staus fix and still nothing.

    Previously had Virtuous 2.7 and everything worked fine. Basically the phone will pick up location using gps,but does not appear to find location via the network( i.e cell towers). Thanks
Loading...

Share This Page