1. Hot New Devices! HTC One M9 | Samsung Galaxy S6 | LG G4

[SOLVED]Help plz, my device is completely dead.


  1. earthw0rmjim

    earthw0rmjim Active Member

    Hey!

    I bought my Desire S from a third party reseller with 12+12 month warranty. It was unlocked and S-OFF. It's like 10 days old now.
    Installed Revolutionary hboot, flashed some roms, played around and stuff. Didn't have any problems.
    But today when i tried to recover to stock rom i got some error message in the process, like "cannot mount /cache" or something like this.
    I did a reboot, but stuck on HTC logo, so i did a battery pull.
    Now my device won't turn on. Not even to recovery. When i plug in the charger, the LED doesn't light up. It seems completely dead.

    (Occasionally i had some problems with the battery, sometimes it just didn't turn on, but after moving the battery it was fine.)

    What can i do?

    Advertisement
  2. Rico ANDROID

    Rico ANDROID Well-Known Member

    sounds like a lose battery or charge connection? did you say you used to hve to move the battery around just to get it to turn on ? I wonder if something has finally loosened and the connetion is just not there. what does the previous owner say about this known issue when you bought it?
  3. earthw0rmjim

    earthw0rmjim Active Member

    It was a brand new device.
    Did i lose the warranty because of the revolutionary install? (The phone was already S-OFF)

    edit: Seems it's a battery issue, i just managed to turn it on by moving the battery.
  4. FoX777

    FoX777 Well-Known Member

    Why did you install rev if the phone was already s off? if you still can, flash a Eng hboot and install a ruu.
  5. earthw0rmjim

    earthw0rmjim Active Member

    Cuz i'm a noob and didn't really know what i was doing :)

    I managed to recover the stock ROM with clockworkmod recovery (made backup before started to flash custom roms), then did a factory reset.
    Now everything seems stock, except the hboot.

    I have: Revolutionary HBOOT 6.98.1002 S-OFF
    I need: Stock HBOOT 0.98.0002 S-OFF

    What's the easiest and most safe way to do this? (if possible)

    Thanks in advance.
  6. FoX777

    FoX777 Well-Known Member

    1) install an Eng hboot, current is 0.98.2000, then flash 0.98.0002 over the one you just instal'd.
    2) install the Eng hboot and then flash the stock ruu.
    earthw0rmjim likes this.
  7. earthw0rmjim

    earthw0rmjim Active Member

    Thanks.
    So should i just install this HBOOT and then flash a RUU from here? (i guess a "Europe" one, since i bought my phone unbranded/unlocked)
    Sorry if i'm being stupid, but i'm really new in this stuff.
  8. FoX777

    FoX777 Well-Known Member

    Yip,

    You can flash the hboot using fastboot, PG88IMG.zip, or android flasher.

    The HTC_Europe_1.47.401.4 has 0.98.0002 hboot, not sure about the others

    Before you run the RUU check your phone CID

    Boot into fastboot, and run this command from cmd;
    Just to verify your have aren't running a branded phone

    It should be one of these if it is unbranded;
    I am pretty sure after you so all this you will be S-on and not S-Off as the phone came to you, although It should still be covered by warranty.

    But I suggest you read A LOT before doing it, cause you can always brick your phone. Read through the RUU thread and Eng Hboot thread of others doing the same/similar thing.
  9. earthw0rmjim

    earthw0rmjim Active Member

    $ fastboot devices gives this strange output: ???????????? fastboot
    $ fastboot getvar cid gives this: cid: 11111111

    Seems i have the "superCID", but i'm worried about the first command's output.
    Fastboot definitely sees my phone since i can "fastboot reboot-bootloader".
    Am i good to go?
  10. FoX777

    FoX777 Well-Known Member

    fastboot devices should give your phones serial SH***** you can check on the phones box, if its not that then I don't know.

    Have you found out what the person who you bought the phone from did to the phone?

    I am unsure if the phone would ship with a superCID, but who knows.

    You can ask notebook on this forum.
    earthw0rmjim likes this.
  11. earthw0rmjim

    earthw0rmjim Active Member

    I just flashed the RUU, it went fine, my recovery is now stock (clockworkmod recovery got removed).
    On the other hand i still have the Revolutionary hboot (and S-OFF). When i try to install the eng hboot it says something like "hboot bypassed..." and then just reboots.
    I can't install the 2.3.5 update either, i guess that's because of the S-OFF.
    Any suggestions? Is it possible to get back to the stock bootloader?
  12. FoX777

    FoX777 Well-Known Member

    Did you try all the methods to install the hboot? you need to flash the hboot first, then the ruu cause the current hboot cannot be overwriten by the ruu.
  13. earthw0rmjim

    earthw0rmjim Active Member

    I tried to "install zip from sd card" with clockworkmod recovery, before i flashed the RUU.
    That's when i got the "hboot bypassed" (or something similar) message. So i just flashed the RUU.
    What are the other methods?
  14. FoX777

    FoX777 Well-Known Member

    1) Fastboot, boot into fastboot run, put new hboot in folder with fastboot.exe and run "fastboot flash hboot engHBOOToverARX.img" (not that direct/easy)
    2) Updater file (PG88IMG.zip) (put the file on sd card root, and press power button in hboot (easy)
    3) Android Flasher, select hboot and flash (easy)
    earthw0rmjim likes this.
  15. earthw0rmjim

    earthw0rmjim Active Member

    Thanks man, i think it worked.
    Revolutionary disappeared from hboot.

    SAGA PVT ENG S-OFF
    HBOOT-6.98.2000 (PG88*****)

    Now if i flash a RUU, will it replace this with it's own bootloader?
  16. FoX777

    FoX777 Well-Known Member

    That's the idea, so yip.

    The reason why you flash that hboot is because the Revolutionary one is write proteccted, this one isnt.
  17. earthw0rmjim

    earthw0rmjim Active Member

    Perfect.
    Now i'm stock with S-OFF and superCID :)
    Even updated to 2.3.5 with Sense 3.0.

    Thanks for everything!
  18. kginglis

    kginglis Member

    I'm also trying to return from HBOOT 6.98.1002 to 0.98.0002 and receive an error "Cannot Rollback HBOOT Version". Which of the 3 methods suggested by FoX777 worked for you?
  19. FoX777

    FoX777 Well-Known Member

    Whats the reason that you need hboot 0.98.0002? are you trying to get completely stock again?

    Are you first trying to flash the 0.98.2000 Hboot
  20. kginglis

    kginglis Member

    Yes, I need to return the phone to it's original state. I've tried downloading the HBOOT-0.98.2000 image from here and placing it in the root of my SDCARD. When I try to install it I get an error "Cannot rollback HBOOT Version".
  21. FoX777

    FoX777 Well-Known Member

    Check section 2 in this thread.
  22. kginglis

    kginglis Member

    Section 2 Step 1 reads:

    I've tried the 3rd method here and that's when I get the error. Would trying one of the other 2 be any different?
  23. FoX777

    FoX777 Well-Known Member

    Yes, try the other methods.
  24. kginglis

    kginglis Member

    Okay so method 2 seems to have worked.

    Code (Text):
    1.  
    2. C:\android-tools>fastboot flash hboot engHBOOToverARX.img
    3.      sending 'hboot' (1024 KB)... OKAY [  0.192s]
    4.                writing 'hboot'... OKAY [  0.334s]
    5. finished. total time: 0.528s
    6.  
    And my HBOOT now shows (no Revolutionary):

    SAGA PVT ENG S-OFF
    HBOOT-6.98.2000 (PG8810000)
    RADIO-3805.06.02.03_M
    eMMC-boot
    Feb 24 2011,21:19:05

    Now, how do I get this too 0.98.0002 and replace ClockworkMod with the stock recovery image? Do I need another ENG HBOOT 0.98.0002 or do I have to find an appropriate RUU for Virgin Mobile? Or can I use a stock HTC ROM?
  25. FoX777

    FoX777 Well-Known Member

    Good stuff,

    I'd rather flash a RUU (get from here) even more so if you did other stuff your your phone (like roms/kernel etc).

    Rather use a virgin RUU to get back to stock stock.

Share This Page