[SOLVED] is this possible - browsing internal storage via adb (unable to boot up phone)Support


Last Updated:

  1. foo

    foo Well-Known Member This Topic's Starter

    Joined:
    Oct 20, 2008
    Messages:
    483
    Likes Received:
    105
    my father was killed in a car accident last week, and my family & i are trying to get pictures off his phone. the phone doesn't boot past the red Moto logo, but i was able to pull out his SD card & get stuff off that. strangely, it's not every picture he had taken. i imagine some of it is internal? i can get to bootloader mode, but is it possible to use ADB to browse internal storage if I cannot boot into the actual OS itself on the phone? I don't know why it's messed up...i guess it got jacked up what it tumbled around in his vehicle. anyway, if i can browse internal storage (assuming i install proper USB drivers etc), can i pull files from internal storage on a stock/non-rooted bionic?

    ANSWER: just needed a stupid battery.
     

    Advertisement
  2. Thom

    Thom Guides Guide

    Joined:
    Feb 16, 2011
    Messages:
    10,692
    Likes Received:
    4,227
    Are you sure the battery, SIM, and SD-Ext cards are properly seated when you try turning it on?

    Did you try another battery?

    In playing around with this for you I encountered a surprise. I had previously connected to a workstation with USB cable and had selected Mass Storage mode. I am usually unlocked.

    I turned the lock screen on and then powered off the Bionic.

    I powered on the Bionic and then connected it to a USB cable connected to my workstation. The lock screen was displayed. I had access to the SD and SD-Ext cards from my workstation.

    Wow.

    ... Thom
     
  3. doogald

    doogald Guides Guide

    Joined:
    Jan 7, 2010
    Messages:
    6,592
    Likes Received:
    1,884
    Gosh, Foo, horrible news. I'm so sorry.

    Thom (or anyone else), do you know if you choose wipe data/factory reset from stock recovery, will it wipe the internal storage as well? It does *not* on a Droid 3, but I don't know if the ICS upgrade also upgraded the stock recovery to wipe internal storage as well.

    (Steps for this that should work: with Bionic powered down, hold both Volume buttons and press power. This should bring up a boot menu. Use VolDn to move down through the menu to "Recovery" and press VolUp to select that option. That will show a screen with a triangle with an exclamation point - again, press both Vol buttons to bring up a menu. Use VolDn to move down to "wipe data/factory reset" and, in this menu, press the power button to select menu options.)

    If this works, you could wipe the phone to a factory reset, either set up the phone again from scratch or skip setting up by hitting the four corners of the opening screen in this order - upper left, upper right, lower right, lower left - and see if the files/photos still exist on internal storage. They should be in the /DCIM folder.

    On my Droid 3 I could find no way to access the phone with adb from stock recovery or the fastboot screen. I believe that the phone may have had to had USB debugging set up first anyway. I know that the ICS Bionic may now be different, but I believe that the two phones are still relatively similar. If anybody knows differently please let us know!
     
    foo likes this.
  4. OutOfPhase

    OutOfPhase Premium Member

    Joined:
    Dec 7, 2010
    Messages:
    4,023
    Likes Received:
    2,122
    I am 99% positive it will not wipe the internal sd card when a factory data reset is done.
     
  5. Thom

    Thom Guides Guide

    Joined:
    Feb 16, 2011
    Messages:
    10,692
    Likes Received:
    4,227
    I do not know.

    I have seen many messages in the past where there was a recommendation to copy data (like pictures and contacts) from the SD to the SD-Ext card because the SD-Ext card was not touched with a Factory Data Reset and the SD card was.

    I have never tried looking at it so I do not know.

    ... Thom
     
  6. OutOfPhase

    OutOfPhase Premium Member

    Joined:
    Dec 7, 2010
    Messages:
    4,023
    Likes Received:
    2,122
    There is an option after you choose FDR from settings-privacy to include your internal sd card or not before you commit. I believe when you do an FDR from recovery it does not give you the option to wipe internal storage. When I get a moment I will backup my system and give it a shot.
     
    foo and Thom like this.
  7. foo

    foo Well-Known Member This Topic's Starter

    Joined:
    Oct 20, 2008
    Messages:
    483
    Likes Received:
    105
    I'd REALLY appreciate that, OutOfPhase. Thank you everyone :)
     
  8. foo

    foo Well-Known Member This Topic's Starter

    Joined:
    Oct 20, 2008
    Messages:
    483
    Likes Received:
    105
    I should also add that i don't have his battery. It was never found in the wreck. I've never had any issues powering on a phone with just the power cable(no batt) in the past, unless it's different for the Bionic?

    Starting to think this might be why it's not booting up. When I get to bootloader mode & select recovery, it still just hangs at the red Moto logo. If I choose 'fastboot mode' it says battery low cannot program (which there is no battery). shit. i guess i should try getting a battery first...?



    Can anyone test to see if their phone will boot up off a power cable with no battery in their phone?
     
  9. Thom

    Thom Guides Guide

    Joined:
    Feb 16, 2011
    Messages:
    10,692
    Likes Received:
    4,227
    I found that in my testing for you. It will not boot up without a battery. This could be the basis of all your problem.

    ... Thom
     
    doogald and foo like this.
  10. foo

    foo Well-Known Member This Topic's Starter

    Joined:
    Oct 20, 2008
    Messages:
    483
    Likes Received:
    105
    AW! Good to know. I'll just go pick up a battery then. thanks man...i really appreciate it :thumb:
     
  11. Thom

    Thom Guides Guide

    Joined:
    Feb 16, 2011
    Messages:
    10,692
    Likes Received:
    4,227
    My unasked for opinion ... get a battery from a trusted source (Verizon Store ... Best Buy) ... you have enough other things on your mind.

    Let us know how it works out.

    (Lost my dad when I was 15. Still vivid.)

    ... Thom
     
  12. foo

    foo Well-Known Member This Topic's Starter

    Joined:
    Oct 20, 2008
    Messages:
    483
    Likes Received:
    105
    Feel like an idiot. All I needed was a battery. doh
    all is good..thanks again everyone
     
    OutOfPhase likes this.
  13. Thom

    Thom Guides Guide

    Joined:
    Feb 16, 2011
    Messages:
    10,692
    Likes Received:
    4,227
    Great.

    Were there pictures?

    I had no idea that you had to have a battery inserted for it to load. I happened on it by accident.

    ... Thom
     
  14. foo

    foo Well-Known Member This Topic's Starter

    Joined:
    Oct 20, 2008
    Messages:
    483
    Likes Received:
    105
    Yep! It was nice to hear/watch the vids and see the images of my dad.
     
  15. SNeitzel

    SNeitzel Well-Known Member

    Joined:
    Aug 11, 2010
    Messages:
    636
    Likes Received:
    102
    Being the guy that "knows about computers and phones and stuff", I have had many people bring devices to me and ask if I know how to retrieve pics, video, contacts or other files off of them. Most of their stories are not as tragic as this one, but I do know how happy and thankful they are when I am able to retrieve something they thought was lost. I'm glad you figured it out.
     

Share This Page

Loading...