[solved] Windows 7: Device Not Recognized


Last Updated:

  1. nofxdan

    nofxdan Active Member

    I've been having some issues with rooting my device using Windows 7 x64.

    I have installed the 64 Bit Motorola drivers, but my device is not recognized by ADB or Pete's One Click Rooting tool.

    For clarification, USB debugging is enabled, and I have selected "Charge Only" after plugging in the phone. The phone charges, but still I cannot seem to root.

    Any help would be greatly appreciated!

    Advertisement
  2. amageus

    amageus Well-Known Member

    Are you able to mount it at all? I mean without Charge Only. Have you tried other USB ports? The back ones on the motherboard and not the ones in the front.
  3. messenger13

    messenger13 Well-Known Member

    Are you sure that your version of Win 7 is 64-bit? Is it Windows Ultimate?
  4. OutOfPhase

    OutOfPhase Premium Member

    I believe I read that some people with 64-bit also installed the 32-bit drivers to get everything to work right. I don't know why that would be but then I only have 32-bit windows 7.
  5. nofxdan

    nofxdan Active Member

    It's Win7 Home Premium 64 Bit.

    I will try installing the 32 bit drivers and report back.
  6. amageus

    amageus Well-Known Member

    I'm running Windows 7 Home Premium 64 bit as well and have not had issues. However I don't recall ever re-installing the 64 bit drivers since I last wiped my windows since D1...cause last night I installed a fresh Android SDK o_O...
  7. nofxdan

    nofxdan Active Member

    Alright, so I went ahead and ran Motorola Mobile Driver.exe, and selected the Clean and Reinstall option. After that, my computer detected the phone and it looks like Pete's tool is working.
  8. amageus

    amageus Well-Known Member

    Good to hear. Now that you're rooted get those ROMs on there lol.

Share This Page