**SOLVED** Windows can't detect my HTC Vivid. My particular case seems to be different than others.Support


Last Updated: 2012-09-24 03:00:18
  1. sugarshock

    sugarshock Member

    Let me start off by saying I've searched the hell out of this issue and tried a couple solutions. I'm not posting here because I'm too lazy to figure it out myself. You guys are my last hope. Here goes:

    I plug my Vivid (running the latest software) in to my 64 bit Win 7 PC, but nothing happens. My phone charges, but windows does not see it. It doesn't even have the pop up that says it doesn't recognize the device.
    I have USB debugging enabled (it doesn't work when disabled, either), and I've tried every connection type (including htc sync mode and Disk Drive), and I have the box checked that's supposed to ask me what connection I want whenever I plug it in. Again, nothing happens but the charge.

    I downloaded some drivers, but it doesn't come with an exe. The only way I know to manually install the drivers requires me to first find the device in device manager. I don't know how to find the phone in there, as no errors pop up, and none of the names look like it could be my phone. I went to the official site and downloaded, installed, and updated HTC Sync when I found out it includes the drivers. Still no success even after a reboot.
    I've tried multiple charging cables (not the cheap ones, but the ones you get when you buy the phone) in every USB port, and still no luck.

    I really tried to figure this out but I've run out of ideas. I turn to you in desperation, PLEASE HELP :(

    SOLVED!

    I guess some of the cables are ONLY able to charge. I popped in a Kindle charger that I know can transfer data and plugged it into my phone and it worked perfectly!

    Advertisement
  2. alpha0990

    alpha0990 Well-Known Member

    I'm not on my pc so can't remember exactly ... With the device manager, click on the items on the toolbar, select show hidden devices. Going by what you have stated, I doubt if that will help though.
    CuBz likes this.
  3. Soundteq

    Soundteq Well-Known Member

    This has happened to a lot of different devices for me, but never a phone. However I've always fixed it the same way. In your hardware manager, go up into one of the toolbar options (I forget which it is, but it should be easy to see) and select "scan for hardware changes". It will say "scanning for plug n play compliant hardware".

    This usually does the trick. Sometimes it takes no time flat, and other times it takes like 5 minutes =\. Occasionally it will not recognize the device or it will freeze up, but just close out and retry.
    sugarshock likes this.
  4. sugarshock

    sugarshock Member

    The only thing that pops up is the addition of "non plug and play drivers" which doesn't have anything that can help.
  5. sugarshock

    sugarshock Member

    Soundteq, unfortunately that hasn't helped either. I tried doing it a couple times before with no luck.
  6. sugarshock

    sugarshock Member

    Is there another way to access my phone (maybe through wifi) that gives me access to every file and folder? I'm using the Astro app, but there are some folders that appear as empty when I know there is stuff in there.

    EDIT

    Wow, sorry for the triple post. I don't know why I didn't just edit this into the last one :dontknow:
  7. ryancmatchett

    ryancmatchett VIP Member VIP Member

    Can I make a suggestion? Can you check on your phone for the following setting:
    In settings-storage click the 3dot or menu button and go to the USB computer connection....the check mark should be ON for the MTP connection and the PTP connection should be off. (This may be what you referred to in the OP, but thought I would mention it anyways...)

    I hope this helps, but you may have checked this already....good luck

    Edit: I had to spend a lot of time finding the right drivers for each of the phones in our house...that would work with the win7 64bit machines, but once I got the phones set up properly...it was great. Also, I use airdroid for everything if I don't have a cable, so you might check that one out.
    sugarshock likes this.
  8. sugarshock

    sugarshock Member

    hmm. Nothing happens when I hit the menu button under storage. I'll see if I can find a way to access that another way. Some things about my phone seem to be different than others. For example, most tutorials say that developer options(where you can check usb debugging) is in the "applications menu". I don't have that. Instead "Develop option" is at the bottom of the main settings menu.

    EDIT

    To provide a bit more info on my phone: It's not rooted. I bought it new from AT&T only a couple months ago. I keep it in good condition and reboot it every night.
  9. alpha0990

    alpha0990 Well-Known Member

    sugarshock likes this.
  10. sugarshock

    sugarshock Member

    I'm running a file check now. How do I run the CHKDSK? It requires me to click on the drive in question, however the problem is that it doesn't show up as a drive. I can't click on what's not there.
  11. iowabowtech

    iowabowtech root@android:/ #

    Airdroid will do that but I'm a little skeptical that it will work if it's not being recognized by the PC.

    I know you've beat this to death already but just to be absolutely sure, you are also checking for connection by viewing your drive list at "my computer" right. Cuz being an HTC device, it should register two drives as letters. One for your internal memory and one for the sd card.

    Some other thoughts. Nice job on the self troubleshooting. You really did try about everything on the list of usual suspects. Have you tried it on another computer though to rule out some odball thing with your PC? Also, how about connecting another device to that PC. Will it recognize another phone, ipod, mp3 player, digital camera, anything at all?

    edit: well your post above pretty well rules out any storage showing up as a drive.
    sugarshock and ryancmatchett like this.
  12. iowabowtech

    iowabowtech root@android:/ #

    k wait a minute, that seems strange to me that you can't access the settings for MTP. Although I just changed mine to PTP and it still recognized my device so I don't necessarily think it's the straw breaking the camel's back but I'm wondering why you aren't seeing the secondary settings mentioned by Ryan. Doesn't seem normal.

    Key question: Did you get your ICS update by way of OTA?
    sugarshock likes this.
  13. sugarshock

    sugarshock Member

    Just wanna say thanks for all the help guys. I've made three different posts over at the Droid subreddit at reddit.com and got no responses.

    iowa: airdroid works, but it only gives me access to the sdcard filepath. Even Astro gives me more than that. Nothing new pops up under my computer by the way. I guess I should have included that before.

    My PC recognizes every other device I connect it to except my mom's phone. I tried her Vivid as well and it has the same problem. I have a laptop I can try connecting it to. I'll update this post with the results.

    Again, thanks for the help.

    EDIT

    "Key question: Did you get your ICS update by way of OTA?"

    Mind explaining in simple terms what this means? I'm experienced with computers but pretty new to smart phones.
  14. iowabowtech

    iowabowtech root@android:/ #

    Did her phone receive the ICS update as well?
  15. iowabowtech

    iowabowtech root@android:/ #

    Did you get the update over the air? In other words, did you get a prompt on the phone that an update was available and you chose to allow the update?
    sugarshock likes this.
  16. sugarshock

    sugarshock Member

    I updated my phone via "AT&T software update". If that's what you're talking about, then yes. Both have been updated this way.

    "Did you get the update over the air? In other words, did you get a prompt on the phone that an update was available and you chose to allow the update?"

    yes. I checked through AT&T software update and it asked if I wanted to update(which I did).
    iowabowtech likes this.
  17. iowabowtech

    iowabowtech root@android:/ #

    k, interested in finding out what happens with the laptop or any other computer just to rule that out.
    sugarshock likes this.
  18. sugarshock

    sugarshock Member

    gonna check right now. It's a really slow one, so it might take a bit.
  19. iowabowtech

    iowabowtech root@android:/ #

    Is the laptop Win7 64 bit also or something else? Thing is, the HTC Sync should have provided the drivers IMO. It typically works for the matter of usb driver recognition. Although I did just notice that the last update to HTC Sync was 2/14/12 whereas the ICS update came in on 3/22/12. So I wonder if the driver needs updated. But if that were the case on a device that's being actively updated to ICS, you'd think all sorts of people would be reporting this problem. Besides, you'd think it'd at LEAST show up as an unrecognized device in device manager. You don't have any yellow ? showing up in device manager by chance?
    sugarshock likes this.
  20. sugarshock

    sugarshock Member

    no dice on the laptop(running the same os and 64 bit). No question marks in Device Manager on my laptop and desktop. Is there a way to undo that update without losing any other data?
  21. iowabowtech

    iowabowtech root@android:/ #

    Hang on, let's try one more thing:

    Download PdaNet

    Download pdanet for win7 64 bit. Install it, follow any instructs. May ask you to locate your phone, not sure. If not and even if so...reboot your PC afterward with the phone still hooked up to the USB port at the time. Let us know the results after the PC boots.
    sugarshock likes this.
  22. alpha0990

    alpha0990 Well-Known Member

    Run a disk check on the hard drive/partition/volume where Windows 7 is. It might be possible that after doing that, Windows will detect the new hardware.
    sugarshock likes this.
  23. sugarshock

    sugarshock Member

    The program is 3mb but it's taking it's sweet time installing...

    EDIT

    Okay. It says it's installing. After a while it says:

    1. Enable USB Debugging(I did)
    2. Plug the phone in (I did)
    3. If prompted with the new hardware wizard, click "install the software automatically"

    Select OK to continue if driver has been installed. If a reboot is requested, please reboot and reinstall after rebooting.

    -----

    So I hit ok assuming the driver is installed, but it tells me a Droid isn't detected and brings me back to the previous screen. So I hit Cancel this time, but it simply uninstalls itself.

    I have the worst luck...
  24. iowabowtech

    iowabowtech root@android:/ #

    One other quick thought why you're waiting. How new is your PC? Are you using USB 2.0 or 3.0 ports or have you tried both. Plug into USB 2.0 if you haven't already.
    sugarshock likes this.
  25. sugarshock

    sugarshock Member

    My computer is a gaming rig I've been upgrading through the years. MoBo and CPU(six core 1100T) are newish, but the MoBo is USB 2.0

    I gave the PC a reboot anyway with no luck.

Share This Page