1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Some apps won't install from Market


  1. alanthing

    alanthing Active Member

    I set up Virtuous 2.6 (was running CMod 6.0.2 but it was restarting, even with the default kernel) this morning and have had this problem with Seesmic and Google Voice in Market where it downloads and then the progress bar goes away and the only button is Cancel download. But I can go into Astro /mnt/sdcard/download and there's Download.apk that is the file downloaded from Market. I was able to install both Seesmic and GV that way but neither are registered in Market, and running Market Doctor in Titanium Backup does not do the trick either.

    Any ideas on what the issue might be? I'd prefer to stay on Virtuous but not if this keeps happening...

    Advertisement
    :
  2. dscribe

    dscribe Well-Known Member

    I am running Virtuous 2.6 and have had the same issue from time to time. Discussed this matter in another thread with someone who was running Sky Raider (3.0 RC3, I think) that was having the same problem.
  3. chrisjz

    chrisjz Well-Known Member

    hmm i thought this was just happening to me. im running skyraider 3.0
  4. chris98891

    chris98891 Active Member

    i have this too, rooted and running 2.2, no roms or anything
  5. killadanny

    killadanny Well-Known Member

    yeah, keep trying, they will eventually, happened to me a couple of times..
  6. jpallen77

    jpallen77 Well-Known Member

    Same here on Virtious 2.6. I went into manage apps and cleared cache from market and gvoice installed but then it went back to not installing anything again.
  7. iowabowtech

    iowabowtech root@android:/ # Moderator

    This is a workaround only but if there's one hung up, long press the progress bar and cancel. Exit market, reopen, menu, downloads, select failed app and the install button should come back. Anyway, that's worked for me.

    Don't think I've ever had the progress bar go away entirely like the OP mentioned though.
  8. The Boots

    The Boots Member

    Yeah, this happens to me on Skyraider. The cancel and install doesn't work for me most of the time, but going into the settings-applications menu and clearing the cache for the market app has worked every time so far. I often have to do that for each new thing I want to install.
  9. chris98891

    chris98891 Active Member

    i've tried all the fixes mentioned in here, havent had any luck. it just says "downloading"
  10. ReuseablePlastix

    ReuseablePlastix Active Member

    I was having this same problem, found this. I checked and I wasn't logged into Talk at all. Logged into talk and set myself to available and it started working again. Odd, but it helped. Hope that's not just coincidence.

    I'm using ShadowROM right now.
  11. dscribe

    dscribe Well-Known Member

    Since I have updated to Virtuous 2.7 my problem with this issue has disappeared. So guess what I would recommend if you want to run Virtuous?
  12. Beatlesfan

    Beatlesfan Well-Known Member

    This was happening as well on my stock unrooted inc. It only started AFTER the 2.2 update. I don't think it's something to do with being rooted, but rather something with our 2.2 updates. BTW, I updated via the leaked ota update.zip file.
  13. headbanger51

    headbanger51 Well-Known Member

    Ever have any luck fixing this? I'm rooted with 2.2 running Fabolous' NEXBEAST FRF57 V0.1.1. I've tried installing the Yahoo! Mail app to no avail...it downloaded but won't install. The only option is to click "Cancel Download" -- when I do that, Market crashes and requires a FC but that does nothing...if I click on the app again, the only option is to cancel.
    I just tried installing Steelers Gameday app so that I can track who Ben Roethlisberger is going to sexually harrass next and that wouldn't install. Clearing the cache and clicking "Cancel Download" did actually work and allowed me to install the app...so right now Yahoo! Mail is the only app that won't unf*ck itself. Not a big deal since I just have the bookmark saved as a shortcut and I use GMail as my primary mail anyway. It's just the principle of the matter now.
  14. craighwk

    craighwk Well-Known Member

    I've had my phone rooted for about 2 months now and I never had this problem up until the past week or so. I've tried several different ROMs (Currently using the newest Virtuous) and they all have this problem.

    It seems like it's a 50/50 shot whether or not the app gets installed. I click to install, everything looks like it's working fine, but after the download finishes, the app never gets installed and if I go back into the market, there is an empty progress bar with a CANCEL button. I am able to click CANCEL and INSTALL again and usually it'll work the second time...sometimes not. It eventually goes through though.

    Also recently had this problem with SkyRaider and MIUI.
  15. chris98891

    chris98891 Active Member

    i'm still not sure whats up with it, i know it has something to do with my SD card. i phone runs perfectly without it. i imagine its titanium backup that does it....always causes funky things with my phone
  16. Spectrumpigg

    Spectrumpigg Well-Known Member

    Goto settings. SD and phone storage. Unmount SD card. Goto market and install until your heart is content. Don't forget to remount. Thank me later. It's the only proven way of working.
  17. craighwk

    craighwk Well-Known Member

    Unfortunately that didn't fix the issue. Just tried to update a bunch of apps and some of them still froze after downloading.

    Oh well. I'll deal. Maybe it'll stop someday.
  18. kenbanks

    kenbanks Member

    PROBLEM SOLVED (with NO HELP from Android or the Market app)
    I replaced my 16GB SD card with a spare 2GB sdcard and everything started working normally again. Apps would install again.

    I connected my 16GB card to my Windows system and ran chkdsk which reported two broken chains that it could not repair. I put the 16GB card back into my phone and let ROM Manger repartition and format. It's been running great ever since.

    HERE IS THE BEEF:
    You mean to tell me Android is incapable of detecting/notifying when the sdcard file system is corrupt?!? No indication whatsoever that this could have been the problem.
    Nothing in logcat.
    But that's not all.....
    Why or how could a corrupt file system on the sdcard effect the behavior of the Market, after I had enabled only installing apps for internal (not to use the sdcard)? But I also went so far as to operate without the sdcard mounted.
    Could the Market App not display a single message to help indicate why it was doing nothing, that maybe there might be a problem with the accessing certain files?!?

    With the sdcard unmounted I also attempted to perform an fsck, but it was not available in the ROM. This would seem to me to be a standard tool. Every Linux I've ever dealt with (and even god-forsaken Windows) performs file system integrity checks and reports when there is a problem. Am I missing something here?


    A person should NOT have to Google around to find out whether or not they need to guess that their sdcard might be the culprit for this problem.
  19. tdavis1515

    tdavis1515 New Member

    a big thank you for that tip!
Loading...

Share This Page