1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

Some Help me PleaseSupport


Last Updated:

  1. rayhan23

    rayhan23 New Member This Topic's Starter

    Joined:
    Dec 16, 2012
    Messages:
    3
    Likes Received:
    0
    Hi All,

    I would really appreciate if any of you know the solution to my problem.

    Just bought a new nexus 7 , the battery on the device seems to be faulty (correct me if i am wrong) it doesn't charge. The device comes on when you keep the charger on and then completely goes off the moment you take the usb cable off. The device shows that the battery can run for over 9 hours however battery charge % is 0 and the status is unknown.

    I have tried holding the power button for even over thirty seconds but it still didn't work for me. the device reboots and I can manage to get it in again if the cable is connected.

    I have left the device on charge all night after it died to on me once but still the battery doesnt seems to be charging !!

    please help !!!!
     

    Advertisement
  2. h4x0rj3ff

    h4x0rj3ff Chemist

    Joined:
    Jan 20, 2011
    Messages:
    2,565
    Likes Received:
    874
    are you using the stock charger? i would return it and get a new one if your not happy with it. did u get it from google or a big box store?
     
  3. rayhan23

    rayhan23 New Member This Topic's Starter

    Joined:
    Dec 16, 2012
    Messages:
    3
    Likes Received:
    0
    using the stock charger from a store
     
  4. h4x0rj3ff

    h4x0rj3ff Chemist

    Joined:
    Jan 20, 2011
    Messages:
    2,565
    Likes Received:
    874
    sounds like unless something happend to your charger you have a defective device. if you can, exchange it. i would.
     
  5. pastafarian

    pastafarian Pâtes avec votre foie Moderator

    Joined:
    Nov 4, 2009
    Messages:
    5,621
    Likes Received:
    4,618
    Before you return the whole device, have you tried charging via a pc usb port or another charger? It's probably a defective battery, but it would suck to return the whole thing over a defective charging brick.
     
    rayhan23 likes this.
  6. balloonshark

    balloonshark Well-Known Member

    Joined:
    Nov 21, 2012
    Messages:
    49
    Likes Received:
    9
    In addition to the 30 second power button fix, this thread suggests trying another usb cable. Someone one the 2nd page also suggests that the battery cable may be loose inside the device. If you're handy you could try to fix it yourself. Please note that if you do any damage while attempting to repair it yourself you will void your warranty. http://androidforums.com/nexus-7/594627-nexus-7-dead-wont-charge.html

    If it is convenient I would definitely return the device.
     
  7. Rcarnes91

    Rcarnes91 Well-Known Member

    Joined:
    Mar 7, 2012
    Messages:
    306
    Likes Received:
    32
    Pull the back cover off and push the battery cable into its socket better it is super easy don't worry about hurting anything that seems to fix the problem for most people
     
  8. rayhan23

    rayhan23 New Member This Topic's Starter

    Joined:
    Dec 16, 2012
    Messages:
    3
    Likes Received:
    0
    As it was a brand new device, opening and trying to replace a battery or fixing a cable would have been silly as it would have thrown the warranty out in the bin. It was the battery at fault that's my analysis suggested. I logged a fault with google and then passed that fault number to the store who will now replace the device for me.
     
  9. Rcarnes91

    Rcarnes91 Well-Known Member

    Joined:
    Mar 7, 2012
    Messages:
    306
    Likes Received:
    32
    You can do that no problem I was just saying it was a super easy fix there are no stickers or anything that can prove you opened the back so worrying about a warranty is kind of mute unless you brag about opening it to a Asus employee it is just waiting weeks for them when you can do it your self in 2 minutes
     
  10. balloonshark

    balloonshark Well-Known Member

    Joined:
    Nov 21, 2012
    Messages:
    49
    Likes Received:
    9

Share This Page

Loading...