Some Help Please


  1. Snowe

    Snowe Member

    Hello :D

    I just finished unlocking and rooting my Rezound using Scotty's AWESOME noob friendly guide (Thanks Scotty!!). Now I'm just confused. I've been lurking for the last week trying to figure out the best thing for my Rezound when I visit Italy (I leave Thursday).

    I know I want to put the new ICS for world phone capabilities onto my phone, but I'm just confused at this point. I'm feeling a bit ignorant and overwhelmed reading through the forum. I don't even know if my phone is s-on or s-off (I'm assuming s-on).

    If anyone can help me get though this process it would be most appreciated!! Thanks for reading.

    Advertisement
    :
  2. scotty85

    scotty85 Guides Guide

    if all youve done is unlock with the guide,then you are s-on. make sure you read this: http://androidforums.com/rezound-all-things-root/587430-s-want-flash-roms-read.html

    you have 2 options:
    1)relock,install world phone firmware( find it in this thread: http://androidforums.com/rezound-all-things-root/600915-new-world-phone-capabilities.html ),re-unlock,flash a world phone rom(search at Rezound Android Development - xda-developers )

    2)relock,run world phone ruu,reunlock and install superuser(Shipped ROMs)

    actually you have a 3rd option:
    3)if you did not permantly install a recovery and are on the official ICS release(3.14.6505.12) ,then you can simply wait for the world phone OTA. acept the ota,re-launch recoovery,reinstall supersu :)

    hope that helps :)
    Snowe likes this.
  3. Snowe

    Snowe Member

    I got through all of Obscuro's steps in the new world capabilities link up until

    "-pull the battery and replace. Hold down volume down button plus power button to boot into hboot, then fastboot mode.
    -fastboot boot amon ra
    -restore full backup
    -reboot"

    I can get into the bootloader screen, but I can't seem to find my recovery image. It will no longer communicate with the pc either. If I reboot the phone it just chills at the 4G screen. The phone is currently unlocked and the new firmware has been flashed. It's just not functional.

    Did I load my recovery image incorrectly? When I first rooted I had flashed the recovery temporarily. Any help is most appreciated.
  4. thornev

    thornev Well-Known Member

    post deleted as I gave incorrect info. Sorry about that.
    scotty85 likes this.
  5. Snowe

    Snowe Member

    Hi :) Thank you for the response. When I'm in the bootloader it says PH98IMG.zip not found, image missing. The phone will not communicate with the computer atm, it was earlier until I was to this point.
  6. scotty85

    scotty85 Guides Guide

    just an FYI... your edits are a lil confusing,as they dont resend email notifications when you do them ;) i read your first question,came here to answer,and saw your edit that you had successfully re-unlocked. i came here just now to coment on that(since im home and not trying to type fast on my phone at work) and find a completely different post :eek:

    anyway,back to the prollem at hand. the phone is not booting becasue the signed "firmware" package contains a new boot image,i.e., a new kernel. youll need simply to install an old boot image to use your current rom,or install a new rom to match the new boot image.

    when you say it wont communicate with the PC,understand that there are 2 modes of comunication:

    1)via ADB,in the phones booted operating system

    2)via fastboot,with the phone in "fastboot" mode. like earlier,youll need to select fastboot from the hboot screen. once in fastboot,try fastboot devices wich should return your serial number. if the phone does not respond to this,you may need to close and re-open your cmd window,unplug and replug,try different usb cables and ports,and pull the battery on the phone for a few seconds,then go to fastboot again. if all else fails,restart the PC as well.

    you are missing a key factor in obscuros directions:

    in otherwords,you need to have the image in your mini-adb_vigor folder(or wharever folder you are using for adb/fastboot) and launch recovery with:
    fastboot boot recoveryname.img

    you cannot select "recovery" from the hboot menu,as that will take you to either: -a permantly installed custom recovery OR -the stock recovery(red triangle and !)

    so:
    -get your phone recognized in fastboot with the tips above
    -fastboot boot recovery
    -restore a backup or flash a new rom

    and youll be back in business :)
    Snowe likes this.
  7. scotty85

    scotty85 Guides Guide

    if you have a permantly installed recovery,you can select recovery from the hboot menu,and it will take you there. if you have been fastboot booting recovery,then selecting recovery will take you to the stock recovery.

    for any ADB commands to work,the phone must be booted into a fuctional OS with usb debug on. just like selecting recovery in the hboot menu adb reboot recovery will take you to either the stock,or a permanent custom recovery. :)
    thornev likes this.
  8. scotty85

    scotty85 Guides Guide

    that is normal,its just showing hboot checking the sd card for files it recognizes. the things you see on the screen have nothing to do with fastboot working(or not)

    try the tips above to get your phone recognized in fastboot again. :)
  9. Snowe

    Snowe Member

    Thank you so much!!! It's rebooted! I was making the mistake of typing in the incorrect file name when I tried the command the first time. After that, since adb devices wasn't populating my phone I didn't think it was communicating.

    I may wait until tomorrow to mess with the rom. Thanks again, most appreciated!!
  10. scotty85

    scotty85 Guides Guide

    anytime! glad you got it working :cool:
  11. Snowe

    Snowe Member

    Thanks again for taking the time to help me :D I was wondering, does it matter which rom I flash? I'm looking at Ineffabilis Deus v1.2 who highly recommends flashing the 4.03.605.2 RUU first (Is that what I just did?). I'm also looking at Nils Business Sense Rom.

    Is there one that you would recommend that would be easier/better for me?
  12. scotty85

    scotty85 Guides Guide

    you just flashed the firmware,wich is all that you need to do... so you have hboot 2.27 and the rest of the "world phone" compatible firmware.

    it doesnt really matter wich rom you chose,its all a matter of preference. just remember,as long as you fastboot boot recovery,it will install the kernel,so you can follow s-off directions for flashing :)

    business sense is a nice rom.... ive run the sense 3.6 and 4.0 versions. :)
    obscuro likes this.
  13. Snowe

    Snowe Member

    I just flashed my rom, been loading for 5 minutes, come on rom! Do it!
  14. Snowe

    Snowe Member

    So... The first flash did not seem to work :pcguru: I reloaded the recovery, wiped everything this time (/system & /boot), re-flashed, then re-booted.

    I loaded boot.img onto my mini-adb_vigor folder, and loaded the .zip file onto both removable drives - before my exploits.

    It's been sitting on the white screen for several minutes now rather than the 4G screen which I let sit for 35 minutes. Here's my latest command list (I was going to load my original and wait til morning, computer died, I got angry at pc, tried again, and this is where I'm at :rolleyes:). Hopefully I fixed it, and didn't hurt it more.:


    Microsoft Windows [Version 6.0.6002]
    Copyright (c) 2006 Microsoft Corporation. All rights reserved.
    C:\Users\Renee>cd c:\mini-adb_vigor
    c:\mini-adb_vigor>adb devices
    * daemon not running. starting it now *
    * daemon started successfully *
    List of devices attached

    c:\mini-adb_vigor>fastboot boot recovery-ra-vigor-3.14-gnm.img
    < waiting for device >
    downloading 'boot.img'... OKAY [ 1.607s]
    booting... OKAY [ 0.002s]
    finished. total time: 1.610s
    c:\mini-adb_vigor>adb devices
    List of devices attached
    HT19YS227363 recovery

    c:\mini-adb_vigor>adb reboot bootloader
    c:\mini-adb_vigor>fastboot flash boot boot.img
    sending 'boot' (3942 KB)... OKAY [ 0.950s]
    writing 'boot'... OKAY [ 2.640s]
    finished. total time: 3.592s
    c:\mini-adb_vigor>fastboot reboot
    rebooting...
    finished. total time: 2.068s
    c:\mini-adb_vigor>
  15. Snowe

    Snowe Member

    Yep, still white screen with green htc on it. I'll check back in the morn.
  16. scotty85

    scotty85 Guides Guide

    what rom are you trying to install? where did you get the boot image that you flsahed?

    how long did you give it on the 4g screen the first time?
  17. Snowe

    Snowe Member

    Hi Scotty,

    I was trying to flash Nils Business Sense v6. I left it on the 4G screen for 35 minutes. Here's a link to the folder screen shots: https://www.dropbox.com/sh/0rrh0vundj5vnzk/3K__1SDT44?m#f:PH98IMG folder.jpg

    I put the boot.img from the main folder onto my mini-adb_vigor. I'm beginning to think I should have put the boot.img from the kernel/PH98IMG.zip folder instead.

    The .zip folder i put onto the sd card was the business_ICS4.0.3_Sense3.6-v6.zip file. Should this have been the PH98IMG.zip file instead?

    Thanks for being so patient with me :)
  18. Snowe

    Snowe Member

    I am trying to re-install by re-wiping and choosing zip from sd option in recovery. Looks hopefull, aroma installer loaded, and its working on installing now.
  19. scotty85

    scotty85 Guides Guide

    unflortunately your cmd code doesnt really show anything,other than you successfully booted recovery,and you successfully flashed the boot image. if you extracted and rezipped the rom to get the boot image,you may have altered something in that process. the boot.img thats in the main folder should be the same one that aroma installer will deposit on your sd for s-on flashing(and therefore should have been the correct one). i really hate aroma installer,and all the methods folks have dreamed up to try and "autoinstall" the boot images. IMO both just make things even more confusing. :mad:

    do you have a working backup? if so,go ahead and:
    -relaunch recovery
    -wipe everything
    -restore backup

    and make sure it boots. once youre back to a working phone we can tryand figure out where the install went wrong.

    did aroma ask if you were s-on or s-off? or did it auto-detect s-on?

    if you told aroma you were s-on,or it auto detected it,that prolly changed how the rom was installed.

    if you were asked:
    -relaunch recovery
    -wipe everything
    -install rom(chose s-off this time)
    -reboot

    if it auto-detected,leaving you with no choice,you have a couple different optuins:
    1) let aroma install boot.im
    -delete any ph98img from sd
    -launch recovery
    -wipe everything
    -install rom
    -i believe aroma will kick you into fastboot once the rom has installed. if so,push power to select "bootloader"(this takes you to hboot)
    -allow ph98img to update
    -reboot
    -immediately delete ph98img

    2)manually install boot.img
    -remove ph98img from sd
    -relaunch recovery
    -wipe everything
    -flash rom
    *heres where im not sure what will happen. if aroma kicks you to fastboot,just stay there. flash the boot.img like you did earlier(fastboot flash boot boot.img using the image from the main folder.dont unzip and rezip,just copy and paste the boot image. or extract a copy you arent going to flash).

    however,if youre left with a choice,you can chose to reboot to bootloader,or you can:
    adb devices
    if you get xxxx recovery,then
    -adb reboot bootloader
    then manually flash.

    failing all that,try and describe in as much detail as possible what your process was,and waht you selected in aroma.

    im off to work,so it may be later this evening before i can give more detailed replys. as long as you can launch recovery and load your backup to get your phone working,you should be ok to mess with it some more if youd like :)
    Snowe likes this.
  20. scotty85

    scotty85 Guides Guide

    im confused... is that not how you flashed the other times?
  21. Snowe

    Snowe Member

    Its loaded, and its beautiful!!! :D Thank you so much for all of your help, I could not have done it without you.

    Thank you, thank you, thank you! :D
    scotty85 likes this.
  22. Snowe

    Snowe Member


    It is, I'm just an idiot and forgot that step :eek:
    scotty85 likes this.
  23. scotty85

    scotty85 Guides Guide

    Awesome! Glad you got it working :cool:
Loading...

Share This Page