Sony Ericsson Xperia X10 Power-On problemSupport


  1. rupeshd18

    rupeshd18 Member

    I have SE Xperia X10i Handset. More details are below:

    Model Number: X10i
    FirmWare Version: 1.6
    Baseband version: 1.1.31
    Kernel Version: 2.6.29-rel (semc-android@SEMC #2)
    Build number: R2BA026

    Today while talking over the phone, Xperia rebooted 3-4 times continuously. After that it did not come up.
    As a solution, I started Update Service Software and reinstalled software by following proper instructions. Before updating, I charged battery for 2-3 hours. The screen was blank hence there was no battery charging indication. I observed battery was warning up and hence I took it as battery charging indication.

    After successful installation via Update Service software, I powered-on handset. Initially it gave me single vibration as signal of starting up handset but neither Sony Ericson Trade mark appeared nor any LED glow.

    After 2 -3 minutes, handset started vibrating continuously. It did not stop until I remove battery from handset. After that, I assumed it could be due to insufficient battery charge hence I connected charger. After connecting charger, green LED started glowing on top of handset. After some time, green LED went off and handset started vibrating continuously again. This time I removed battery from handset but still vibration did not stop until I removed micro USB connector from handset.

    I again started update service and was about proceed for reinstallation of software. As usual Update Service software asked to press Back key and then connect Micro USB cable, but this time without pressing back key green LED glow and I started to reinstall.

    But after many successful reinstallations, still handset vibrates continuously and green LED glows when I connect charger or PC cable to it.

    How to get rid of this weird problem of continuous vibration. Please help. :mad:

    Regards,
    Rupesh

    Advertisement
    cristofer1978 likes this.
  2. rosered

    rosered VIP Member VIP Member

    That doesn't sound good!

    If the phone won't connect to the update service cos it won't start in boot mode (holding back button and connecting usb) you could try on a different PC, don't know why but this does work often. If you can get the firmware back on there it might sort out the problem but if you can't then it sounds like a service centre job.

    Others may have different suggestions.

    Good luck and let us know how you get on.
  3. cristofer1978

    cristofer1978 New Member

Loading...

Share This Page