1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Sony Xperia Play on straight talk?Support


  1. NaHPrO

    NaHPrO Well-Known Member

    I got an at&t xperia play and was wondering if it will work with straight talk? my iphone does, but this one does not have 3G...the texting and calling works when i put the sim in the sony play, but the internet does not. how do i get this to work? any suggestions ?...anybody done this before?

    Advertisement
    :
  2. Jake-SonyXperia

    Jake-SonyXperia Well-Known Member

    Just to clarify, have you had the settings for internet sent to the device so internet services could be used?

    If not I suggest contacting them now and requesting them.
  3. NaHPrO

    NaHPrO Well-Known Member

    what do you mean? have the internet settings sent to the phone?
    im using a nokia e71 sim card. when i unlocked the iphone all i did was go to unlockit.co.nz and download the apn settings.. that doesnt work with android. so who do i call for the settings?
  4. mnmax

    mnmax Member

    So...
    You have an AT&T Iphone that works on straight talk???
    What plan are you using? unlimited monthly?
    Are you able you access the internet?
    Do you need to use a straight tlak sim card?
    Is your iphone unlocked jail broke?

    I tried to do the pay as you go with AT&T and they said they were not allowed to do that due to apple regulations.
  5. beau420

    beau420 Well-Known Member

    Can you access the internet at all over 3G over the phone?

    If not, then it is a setting on the phone.

    Open Wireless->Mobile->APN. Make sure you have the MMS settings for your phone from your carrier.

    Just google x10 MMS settings and your cell phone provider name.
  6. mod777

    mod777 New Member

    I just put an at&t compatible straight talk sim into my Xperia Play 4G and set the APN and it works perfectly... sms, mms, internet (Hspa+), phone all work

    Settings I used (have to go into wireless and networks > mobile networks > access point names > Menu button > new apn)

    name: StraightTalk
    apn: att.mvno
    Proxy: <Not set>
    Port: <Not set>
    Username: <Not set>
    Password: <Not set>
    Server: <Not set>
    MMSC: http://mmsc.cingular.com/
    MMS Proxy: mmsc.cingular.com
    MMS Port: 80
    MCC: 310
    MNC: 410
    Authentication Type: None
    APN Type: Not Set
Loading...

Share This Page